summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/dosemu/files/dosemu-1.4.1_pre20091009-fix-glibc.patch')
-rw-r--r--app-emulation/dosemu/files/dosemu-1.4.1_pre20091009-fix-glibc.patch35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-emulation/dosemu/files/dosemu-1.4.1_pre20091009-fix-glibc.patch b/app-emulation/dosemu/files/dosemu-1.4.1_pre20091009-fix-glibc.patch
new file mode 100644
index 000000000000..62a4319c1a47
--- /dev/null
+++ b/app-emulation/dosemu/files/dosemu-1.4.1_pre20091009-fix-glibc.patch
@@ -0,0 +1,35 @@
+The patch is a subset of
+
+ commit b028d3fd33b004ac61583927884a64577e2d64c3
+ Author: Bart Oldeman <bartoldeman@users.sourceforge.net>
+ Date: Sun Dec 23 22:08:11 2012 -0500
+
+to fix glibc detection for
+Bug: https://bugs.gentoo.org/597880
+diff --git a/configure.ac b/configure.ac
+index 70bc154..b8da5e2 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -644,19 +640,9 @@ if test "$GCC" = "yes" ; then
+ fi
+
+ AC_MSG_CHECKING(for glibc...)
+- set `printf '%b\n' '#include <features.h>\nXXAaZZ __GLIBC__ XXBbZZ __GLIBC_MINOR__'|${CC-cc} -E -|awk '/XXAaZZ/ {print $2 " " $4}'`
+- major=$1; minor=$2
+- if test "$major" = "__GLIBC__"; then
+- AC_MSG_ERROR([Sorry, you need glibc-2.1.3 or newer.])
+- else
+- if test "$minor" = "__GLIBC_MINOR__"; then
+- minor=0;
+- fi
+- GLIBC_VERSION_CODE=$((($major * 1000) + $minor))
+- AC_MSG_RESULT([yes, version code $GLIBC_VERSION_CODE])
+- if test $GLIBC_VERSION_CODE -lt 2001; then
+- AC_MSG_ERROR([Sorry, you need glibc-2.1.3 or newer.])
+- fi
++ set `printf '%b\n' '#include <features.h>\nXXAaZZ __GLIBC__'|${CC-cc} -E -|awk '/XXAaZZ/ {print $2}'`
++ if test "$1" = "__GLIBC__"; then
++ AC_MSG_ERROR([Sorry, you need glibc.])
+ fi
+ fi
+