summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/ophcrack/ophcrack-3.8.0.ebuild')
-rw-r--r--app-crypt/ophcrack/ophcrack-3.8.0.ebuild45
1 files changed, 24 insertions, 21 deletions
diff --git a/app-crypt/ophcrack/ophcrack-3.8.0.ebuild b/app-crypt/ophcrack/ophcrack-3.8.0.ebuild
index c35c0f3c154c..02782e377781 100644
--- a/app-crypt/ophcrack/ophcrack-3.8.0.ebuild
+++ b/app-crypt/ophcrack/ophcrack-3.8.0.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
-inherit eutils
+EAPI=7
+
+inherit desktop toolchain-funcs
DESCRIPTION="A time-memory-trade-off-cracker"
HOMEPAGE="http://ophcrack.sourceforge.net/"
@@ -13,32 +14,34 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="debug libressl qt5 +tables"
-CDEPEND="!libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:0= )
- net-libs/netwib
- qt5? ( dev-qt/qtcharts:5
- dev-qt/qtgui:5 )"
-DEPEND="app-arch/unzip
- virtual/pkgconfig
- ${CDEPEND}"
-RDEPEND="tables? ( app-crypt/ophcrack-tables )
- ${CDEPEND}"
-PATCHES=("${FILESDIR}/ophcrack-ar.patch")
+DEPEND="
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ net-libs/netwib
+ qt5? (
+ dev-qt/qtcharts:5
+ dev-qt/qtgui:5
+ )"
+RDEPEND="
+ ${DEPEND}
+ tables? ( app-crypt/ophcrack-tables )"
+BDEPEND="
+ app-arch/unzip
+ virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}"/ophcrack-ar.patch )
src_configure() {
+ tc-export AR
- local myconf
-
- myconf="$(use_enable debug)"
- myconf="${myconf} $(use_enable qt5 gui)"
-
- econf ${myconf}
+ econf \
+ $(use_enable debug) \
+ $(use_enable qt5 gui)
}
src_install() {
- emake install DESTDIR="${D}"
+ default
- cd "${S}"
newicon src/gui/pixmaps/os.xpm ophcrack.xpm
make_desktop_entry "${PN}" OphCrack ophcrack
}