summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/upx')
-rw-r--r--app-arch/upx/upx-4.0.1.ebuild7
1 files changed, 7 insertions, 0 deletions
diff --git a/app-arch/upx/upx-4.0.1.ebuild b/app-arch/upx/upx-4.0.1.ebuild
index 04a011030c35..1a9d20a8f767 100644
--- a/app-arch/upx/upx-4.0.1.ebuild
+++ b/app-arch/upx/upx-4.0.1.ebuild
@@ -17,6 +17,13 @@ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86"
RDEPEND="!app-arch/upx-bin"
BDEPEND="app-arch/xz-utils[extra-filters]"
+src_configure() {
+ local mycmakeargs=(
+ -DUPX_CONFIG_DISABLE_WERROR=ON
+ )
+ cmake_src_configure
+}
+
src_test() {
# Don't run tests in parallel, #878977
cmake_src_test -j1