summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/hardlink')
-rw-r--r--app-arch/hardlink/Manifest2
-rw-r--r--app-arch/hardlink/hardlink-0.2.0.ebuild40
-rw-r--r--app-arch/hardlink/hardlink-0.3.0.ebuild40
-rw-r--r--app-arch/hardlink/metadata.xml9
4 files changed, 91 insertions, 0 deletions
diff --git a/app-arch/hardlink/Manifest b/app-arch/hardlink/Manifest
new file mode 100644
index 000000000000..fabf2f18514c
--- /dev/null
+++ b/app-arch/hardlink/Manifest
@@ -0,0 +1,2 @@
+DIST hardlink_0.2.0.tar.gz 12478 SHA256 7dbacfaaaa6bcc090f75511b204b73ca8f9da7816c4e9ea384eee5261aaef8d1 SHA512 963fe90aa09e2bd548722b5c7f047fbd54fddf37967333e86251d7e5d1c646108ce90d78e7efeb8af6b9169b9a0bc5bc8b744afe1e813390f3e0bd535ce22005 WHIRLPOOL 81b4e8724ef5a3a4399546ed3340034babcb77f089599b6d941fba20b993fa5dc5e522805cdc5cb0a57d7481146d72e0b2d164a6a0ac3eccb69ede2ea707b4d7
+DIST hardlink_0.3.0.tar.xz 14440 SHA256 e8c93dfcb24aeb44a75281ed73757cb862cc63b225d565db1c270af9dbb7300f SHA512 22a8945ce5dac74b05bb1231959823aec0cd364d6db9ad808df4acf232d894170c006ac1e88509604ce1859d41bd4a5d91e2b12c8010aa7fc7e19a77922c4486 WHIRLPOOL dcc1aaf3c4e8ac89137d4bb33d03d14689b4d8b193654e66614a99f551977401c406f29a4d903d61f82b9db51402fa6b7e3eaf88c965ce5d0a22408d58b6677a
diff --git a/app-arch/hardlink/hardlink-0.2.0.ebuild b/app-arch/hardlink/hardlink-0.2.0.ebuild
new file mode 100644
index 000000000000..ce773df52154
--- /dev/null
+++ b/app-arch/hardlink/hardlink-0.2.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit toolchain-funcs
+
+DESCRIPTION="A tool which replaces copies of a file with hardlinks"
+HOMEPAGE="http://jak-linux.org/projects/hardlink/"
+SRC_URI="http://jak-linux.org/projects/${PN}/${PN}_${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~arm ppc ppc64 x86"
+IUSE=""
+
+RDEPEND="dev-libs/libpcre"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS="README ${T}/README.rsync"
+
+src_prepare() {
+ sed -i -e '/^CF/s:?=:+=:' -e '/^CF/s:-O2 -g::' Makefile || die
+
+ cat <<-EOF > "${T}"/README.rsync
+ http://hardlinkpy.googlecode.com/svn/trunk/hardlink.py has regex '^\..*\.\?{6,6}$'
+ for excluding rsync temporary files by default.
+
+ To accomplish same with this version, you can use following syntax:
+ # hardlink -x '^\..*\.\?{6,6}$'
+
+ This was discussed at http://bugs.gentoo.org/416613
+ EOF
+}
+
+src_compile() {
+ tc-export CC
+ emake
+}
diff --git a/app-arch/hardlink/hardlink-0.3.0.ebuild b/app-arch/hardlink/hardlink-0.3.0.ebuild
new file mode 100644
index 000000000000..d25e3834f15c
--- /dev/null
+++ b/app-arch/hardlink/hardlink-0.3.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit toolchain-funcs
+
+DESCRIPTION="A tool which replaces copies of a file with hardlinks"
+HOMEPAGE="http://jak-linux.org/projects/hardlink/"
+SRC_URI="http://jak-linux.org/projects/${PN}/${PN}_${PV}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND="dev-libs/libpcre"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS="README ${T}/README.rsync"
+
+src_prepare() {
+ sed -i -e '/^CF/s:?=:+=:' -e '/^CF/s:-O2 -g::' Makefile || die
+
+ cat <<-EOF > "${T}"/README.rsync
+ http://hardlinkpy.googlecode.com/svn/trunk/hardlink.py has regex '^\..*\.\?{6,6}$'
+ for excluding rsync temporary files by default.
+
+ To accomplish same with this version, you can use following syntax:
+ # hardlink -x '^\..*\.\?{6,6}$'
+
+ This was discussed at http://bugs.gentoo.org/416613
+ EOF
+}
+
+src_compile() {
+ tc-export CC
+ emake
+}
diff --git a/app-arch/hardlink/metadata.xml b/app-arch/hardlink/metadata.xml
new file mode 100644
index 000000000000..44539ce699c1
--- /dev/null
+++ b/app-arch/hardlink/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>shell-tools</herd>
+ <maintainer>
+ <email>robbat2@gentoo.org</email>
+ <name>Robin H. Johnson</name>
+ </maintainer>
+</pkgmetadata>