summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/openrc-settingsd')
-rw-r--r--app-admin/openrc-settingsd/Manifest1
-rw-r--r--app-admin/openrc-settingsd/openrc-settingsd-1.2.0.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/app-admin/openrc-settingsd/Manifest b/app-admin/openrc-settingsd/Manifest
index 11f89aa74fd8..d987b4525e14 100644
--- a/app-admin/openrc-settingsd/Manifest
+++ b/app-admin/openrc-settingsd/Manifest
@@ -1 +1,2 @@
DIST openrc-settingsd-v1.1.0.tar.bz2 41781 BLAKE2B 1a508c5751a3b2c734b533ebdf72d4c5fa97b67743caf5e47f06fc505a286e92167715e0ec706528a4e9a74d0aed9d78d6b6b2d542c1df3781d5bd76ff700b91 SHA512 f63aa624097a806094c51a6da8fc6f4962c3302ea0acf02be17744db9d5caf4cfd68294a8e8916e62eeeca722cadc571715b9751730f9d9cf1f9be66e93510f7
+DIST openrc-settingsd-v1.2.0.tar.bz2 41713 BLAKE2B e4630e934fc55549b3d81cc448adb35cb22cb99b898363a1113909a24acc0709d5693841a9c651b4ecf52044c3a45cc4b8207f9c9a3d0e1e8a4f85edefb23d65 SHA512 b1862e80454d3ca22d083f283f4ef3215dfad4da6d2aa495211fa31014c66fb6891ae87a3a1c6932944ed4c1e7100d247e80abc659f37868adcf5fce3b90385b
diff --git a/app-admin/openrc-settingsd/openrc-settingsd-1.2.0.ebuild b/app-admin/openrc-settingsd/openrc-settingsd-1.2.0.ebuild
new file mode 100644
index 000000000000..9152df573104
--- /dev/null
+++ b/app-admin/openrc-settingsd/openrc-settingsd-1.2.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="System settings D-Bus service for OpenRC"
+HOMEPAGE="https://gitlab.com/postmarketOS/openrc-settingsd/"
+SRC_URI="https://gitlab.com/postmarketOS/${PN}/-/archive/v${PV}/${PN}-v${PV}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="systemd"
+
+DEPEND="
+ >=dev-libs/glib-2.30:2
+ sys-apps/dbus
+ sys-auth/polkit
+ dev-libs/libdaemon:0=
+ sys-apps/openrc
+"
+RDEPEND="
+ ${DEPEND}
+ systemd? ( >=sys-apps/systemd-197 )
+ !systemd? ( sys-auth/nss-myhostname !sys-apps/systemd )
+"
+BDEPEND="
+ dev-util/gdbus-codegen
+ virtual/pkgconfig
+"
+
+S="${WORKDIR}/${PN}-v${PV}"
+
+src_configure() {
+ local emesonargs=(
+ -Dopenrc=enabled
+ -Denv-update=/usr/bin/env-update
+ -Dhostname-style=gentoo
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ if use systemd; then
+ # Avoid file collision with systemd
+ rm -vr "${ED}"/usr/share/{dbus-1,polkit-1} "${ED}"/etc/dbus-1 || die "rm failed"
+ fi
+}
+
+pkg_postinst() {
+ if use systemd; then
+ elog "You installed ${PN} with USE=systemd. In this mode,"
+ elog "${PN} will not start via simple dbus activation, so you"
+ elog "will have to manually enable it as an rc service:"
+ elog " # /etc/init.d/openrc-settingsd start"
+ elog " # rc-update add openrc-settingsd default"
+ fi
+}