summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/rq/Manifest1
-rw-r--r--dev-python/rq/rq-1.0.ebuild19
2 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/rq/Manifest b/dev-python/rq/Manifest
index 40dca80be02c..84fdbb34b297 100644
--- a/dev-python/rq/Manifest
+++ b/dev-python/rq/Manifest
@@ -1 +1,2 @@
DIST rq-0.13.0.tar.gz 45487 BLAKE2B 1985a097d419b50b19771a5f1c1526c8b8b3e9b960f7ecb2817cd731a9af0c37dd38e215a556d35ae8107cc93c3da9c023d4e73eda90e776d62a994d74f5bbda SHA512 f8cf5c3cf7360e0640a2ca97a42c85e67e59835317d04dc752008463224e073053c70ede17e179e1e8d287b3e4ed832971a0398636c49e2680f1183f0ebd2302
+DIST rq-1.0.tar.gz 45516 BLAKE2B 10af545640c757671d2da4691d06b03fe0b61c82351824a51f8f382bb0e7380312d6902ceff86bb5fbfe06ac3bedca3275394063e6576db33e78d20610083527 SHA512 eb3040c5c312123ff99158d504f5fea8377c382a1067d923db29a9087e7e0f7d5214ca1ab1df190d3e9872d6d00917c2435730c121dee1a4c410e65d2875d918
diff --git a/dev-python/rq/rq-1.0.ebuild b/dev-python/rq/rq-1.0.ebuild
new file mode 100644
index 000000000000..41b1969f2d48
--- /dev/null
+++ b/dev-python/rq/rq-1.0.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_5 python3_6 )
+inherit distutils-r1
+
+DESCRIPTION="simple, lightweight library for creating and processing background jobs"
+HOMEPAGE="https://github.com/rq/rq"
+SRC_URI="mirror://pypi/${PN:0:1}"/${PN}/${P}.tar.gz
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND=" >=dev-python/click-5.0[${PYTHON_USEDEP}]
+ >=dev-python/redis-py-3.0.0[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"