summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-puzzle/brainparty/brainparty-0.61.ebuild5
-rw-r--r--games-puzzle/brainparty/files/brainparty-0.61-gnu_cxx-hash.patch11
2 files changed, 14 insertions, 2 deletions
diff --git a/games-puzzle/brainparty/brainparty-0.61.ebuild b/games-puzzle/brainparty/brainparty-0.61.ebuild
index 3271d1a09dcc..9cc441ad80e8 100644
--- a/games-puzzle/brainparty/brainparty-0.61.ebuild
+++ b/games-puzzle/brainparty/brainparty-0.61.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -34,7 +34,8 @@ src_prepare() {
main.cpp || die
epatch \
"${FILESDIR}"/${P}-savegame.patch \
- "${FILESDIR}"/${P}-gcc49.patch
+ "${FILESDIR}"/${P}-gcc49.patch \
+ "${FILESDIR}"/${P}-gnu_cxx-hash.patch
}
diff --git a/games-puzzle/brainparty/files/brainparty-0.61-gnu_cxx-hash.patch b/games-puzzle/brainparty/files/brainparty-0.61-gnu_cxx-hash.patch
new file mode 100644
index 000000000000..8d933462673b
--- /dev/null
+++ b/games-puzzle/brainparty/files/brainparty-0.61-gnu_cxx-hash.patch
@@ -0,0 +1,11 @@
+--- a/WordList.h
++++ b/WordList.h
+@@ -35,7 +35,7 @@
+ };
+ }
+
+-typedef hash_set<string, hash<string> > string_hash_set;
++typedef hash_set<string, __gnu_cxx::hash<string> > string_hash_set;
+
+ class WordList {
+ private: