summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-libs/grantlee/grantlee-5.1.0.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/dev-libs/grantlee/grantlee-5.1.0.ebuild b/dev-libs/grantlee/grantlee-5.1.0.ebuild
index 553658e457e5..21f665921e53 100644
--- a/dev-libs/grantlee/grantlee-5.1.0.ebuild
+++ b/dev-libs/grantlee/grantlee-5.1.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -32,6 +32,12 @@ PATCHES=(
"${FILESDIR}/${PN}-5.1.0-slot.patch"
)
+src_prepare() {
+ cmake-utils_src_prepare
+ sed -e '/testfilters/d' \
+ -i templates/tests/CMakeLists.txt || die # bug 661900
+}
+
src_configure() {
local mycmakeargs=(
-DBUILD_TESTS=$(usex test)