summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-power/powerstat/Manifest1
-rw-r--r--sys-power/powerstat/metadata.xml22
-rw-r--r--sys-power/powerstat/powerstat-0.02.11.ebuild20
-rw-r--r--sys-power/powerstat/powerstat-9999.ebuild24
4 files changed, 67 insertions, 0 deletions
diff --git a/sys-power/powerstat/Manifest b/sys-power/powerstat/Manifest
new file mode 100644
index 000000000000..db3ea907cc0c
--- /dev/null
+++ b/sys-power/powerstat/Manifest
@@ -0,0 +1 @@
+DIST powerstat-0.02.11.tar.gz 57173 SHA256 198c472962cb14e5fcda18c0ef252bb57bdef743a84b10ad95f8a4aa2c7e17fb SHA512 ec1a00c0496997410d8a5d07e572d37ce1d7eee0fc37a6d9fdbcd9bf8bebe74cbde1f53d9b55d9bae48e8e1bc44ff61f29fed195d69499a8eed8007b67eacbe6 WHIRLPOOL cc1c2d7b050247cdaa9f765758f8a05b1ac37ef604f35977d8205d16def64c5f69026d4f044ba0a090ff8846e306ca3733b7617ddf0e5849a59527f38ada70bc
diff --git a/sys-power/powerstat/metadata.xml b/sys-power/powerstat/metadata.xml
new file mode 100644
index 000000000000..7e75f57b5d80
--- /dev/null
+++ b/sys-power/powerstat/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>spiderx@spiderx.dp.ua</email>
+ <name>Vladimir Pavljuchenkov</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription lang="en">
+ Powerstat measures the power consumption of a machine using the battery
+ stats or the Intel RAPL interface. The output is like vmstat but also
+ shows power consumption statistics. At the end of a run, powerstat will
+ calculate the average, standard deviation and min/max of the gathered data.
+ </longdescription>
+ <upstream>
+ <remote-id type="launchpad">powerstat</remote-id>
+ <remote-id type="github">ColinIanKing/powerstat</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sys-power/powerstat/powerstat-0.02.11.ebuild b/sys-power/powerstat/powerstat-0.02.11.ebuild
new file mode 100644
index 000000000000..fb6439448b61
--- /dev/null
+++ b/sys-power/powerstat/powerstat-0.02.11.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="Laptop power measuring tool"
+HOMEPAGE="https://launchpad.net/ubuntu/+source/${PN} https://github.com/ColinIanKing/${PN}"
+SRC_URI="https://github.com/ColinIanKing/${PN}/archive/V${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+src_compile() {
+ emake CC=$(tc-getCC)
+}
diff --git a/sys-power/powerstat/powerstat-9999.ebuild b/sys-power/powerstat/powerstat-9999.ebuild
new file mode 100644
index 000000000000..9179c43d4835
--- /dev/null
+++ b/sys-power/powerstat/powerstat-9999.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit git-r3 toolchain-funcs
+
+DESCRIPTION="Laptop power measuring tool"
+EGIT_REPO_URI=(
+ "git://kernel.ubuntu.com/cking/${PN}.git"
+ "https://github.com/ColinIanKing/${PN}.git"
+ )
+HOMEPAGE="https://launchpad.net/ubuntu/+source/${PN} https://github.com/ColinIanKing/${PN}"
+SRC_URI=""
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+src_compile() {
+ emake CC=$(tc-getCC)
+}