summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-crypt/moolticute/Manifest1
-rw-r--r--app-crypt/moolticute/moolticute-0.30.1.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/app-crypt/moolticute/Manifest b/app-crypt/moolticute/Manifest
index 360e41dc99d4..c8c0821d3333 100644
--- a/app-crypt/moolticute/Manifest
+++ b/app-crypt/moolticute/Manifest
@@ -1 +1,2 @@
DIST moolticute-0.18.1.tar.gz 5549370 BLAKE2B 11a1a40e799e54f18e44eacb6ded1892681932676328bfcf0dfc23d197fc418bbe5b726adee280125e974bdf0497e9148f60735e0f80785380ae1b2894d1b187 SHA512 166c2091e84bbe19fced593c97f195d958feb37556670a1e457a0532bf4df399dce214e89782cb8006db5eedad5b9d2c21e5dc9902137f5b2b17b96aa6780366
+DIST moolticute-0.30.1.tar.gz 5562456 BLAKE2B 104f4bd10edf4147d205fec69ec48eddf31150f898242819be25b83fa5f8ddcd51fd016aa2331b9b94fc8c60062745f0d06e5f0b4a30222c1cc44d54eccd6521 SHA512 463b549fbcdbdff3da51a0b781e7ff2c4ca33ebd22ff355b24f13db3c77b3f3fe38d3d97ff260829517d5d93c43b7d746ff58e3fca3d838f7e32de7066c5288a
diff --git a/app-crypt/moolticute/moolticute-0.30.1.ebuild b/app-crypt/moolticute/moolticute-0.30.1.ebuild
new file mode 100644
index 000000000000..9aac00ed7170
--- /dev/null
+++ b/app-crypt/moolticute/moolticute-0.30.1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/mooltipass/moolticute.git"
+ inherit git-r3
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/mooltipass/moolticute/archive/v${PV/_/-}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm"
+fi
+
+inherit gnome2-utils qmake-utils udev
+
+DESCRIPTION="Mooltipass crossplatform daemon/tools"
+HOMEPAGE="https://github.com/mooltipass/moolticute"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ >=dev-libs/libusb-1.0.20
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qttest:5
+ dev-qt/qtwebsockets:5
+ dev-qt/qtwidgets:5
+"
+DEPEND="${RDEPEND}
+ dev-qt/linguist-tools:5
+"
+
+S="${WORKDIR}/${P/_/-}"
+
+src_prepare() {
+ default
+
+ # Fill version.h with package version
+ if [[ ${PV} != 9999* ]]; then
+ sed -i "s/\"git\"/\"v${PV/_/-}\"/" src/version.h || die
+ fi
+}
+
+src_configure() {
+ eqmake5 PREFIX="/usr" Moolticute.pro
+}
+
+src_install() {
+ emake install INSTALL_ROOT="${D}"
+
+ udev_dorules "${FILESDIR}/50-mooltipass.rule"
+ newinitd "${FILESDIR}/moolticuted.init" moolticuted
+}
+
+pkg_postinst() {
+ udev_reload
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}