summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-util/pkgcheck/pkgcheck-0.10.13.ebuild31
1 files changed, 1 insertions, 30 deletions
diff --git a/dev-util/pkgcheck/pkgcheck-0.10.13.ebuild b/dev-util/pkgcheck/pkgcheck-0.10.13.ebuild
index a8ce557ca15d..e5703d13feb6 100644
--- a/dev-util/pkgcheck/pkgcheck-0.10.13.ebuild
+++ b/dev-util/pkgcheck/pkgcheck-0.10.13.ebuild
@@ -5,7 +5,7 @@ EAPI=8
PYTHON_COMPAT=( python3_{8..11} )
DISTUTILS_IN_SOURCE_BUILD=1
-inherit elisp-common distutils-r1 optfeature
+inherit distutils-r1 optfeature
if [[ ${PV} == *9999 ]] ; then
EGIT_REPO_URI="https://github.com/pkgcore/pkgcheck.git"
@@ -20,7 +20,6 @@ HOMEPAGE="https://github.com/pkgcore/pkgcheck"
LICENSE="BSD MIT"
SLOT="0"
-IUSE="emacs"
if [[ ${PV} == *9999 ]]; then
RDEPEND="
@@ -39,11 +38,6 @@ RDEPEND+="
dev-python/lxml[${PYTHON_USEDEP}]
dev-python/pathspec[${PYTHON_USEDEP}]
>=dev-python/tree-sitter-0.19.0[${PYTHON_USEDEP}]
- emacs? (
- >=app-editors/emacs-24.1:*
- app-emacs/ebuild-mode
- app-emacs/flycheck
- )
"
BDEPEND="
${RDEPEND}
@@ -54,22 +48,10 @@ BDEPEND="
)
"
-SITEFILE="50${PN}-gentoo.el"
-
distutils_enable_tests setup.py
export USE_SYSTEM_TREE_SITTER_BASH=1
-src_compile() {
- distutils-r1_src_compile
-
- if use emacs ; then
- pushd "${S}"/contrib/emacs >/dev/null || die
- elisp-compile *.el
- popd >/dev/null || die
- fi
-}
-
src_test() {
local -x PYTHONDONTWRITEBYTECODE=
distutils-r1_src_test
@@ -79,20 +61,9 @@ python_install_all() {
local DOCS=( NEWS.rst )
[[ ${PV} == *9999 ]] || doman man/*
distutils-r1_python_install_all
-
- if use emacs ; then
- elisp-install ${PN} "${S}"/contrib/emacs/*.el{,c}
- elisp-site-file-install "${FILESDIR}/${SITEFILE}"
- fi
}
pkg_postinst() {
- use emacs && elisp-site-regen
-
optfeature "Network check support" dev-python/requests
optfeature "Perl module version check support" dev-perl/Gentoo-PerlMod-Version
}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}