summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-sound/sidplay/sidplay-2.0.9.ebuild15
1 files changed, 7 insertions, 8 deletions
diff --git a/media-sound/sidplay/sidplay-2.0.9.ebuild b/media-sound/sidplay/sidplay-2.0.9.ebuild
index 4f38551f8ebd..982b4bfc55c9 100644
--- a/media-sound/sidplay/sidplay-2.0.9.ebuild
+++ b/media-sound/sidplay/sidplay-2.0.9.ebuild
@@ -1,8 +1,7 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=2
-inherit eutils
+EAPI=6
DESCRIPTION="C64 SID player"
HOMEPAGE="http://sidplay2.sourceforge.net/"
@@ -17,12 +16,12 @@ RDEPEND=">=media-libs/libsidplay-2.1"
DEPEND="${RDEPEND}
virtual/pkgconfig"
-src_prepare() {
- epatch "${FILESDIR}"/${P}-gcc43.patch \
- "${FILESDIR}"/${P}-gcc44.patch
-}
+PATCHES=(
+ "${FILESDIR}/${P}-gcc43.patch"
+ "${FILESDIR}/${P}-gcc44.patch"
+)
src_install () {
emake DESTDIR="${D}" install || die "emake install failed"
- dodoc TODO AUTHORS ChangeLog
+ default
}