summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-plugins/gkrellm-imonc/gkrellm-imonc-0.2-r1.ebuild11
1 files changed, 5 insertions, 6 deletions
diff --git a/x11-plugins/gkrellm-imonc/gkrellm-imonc-0.2-r1.ebuild b/x11-plugins/gkrellm-imonc/gkrellm-imonc-0.2-r1.ebuild
index 3ab0c71bc701..05fffe8d8853 100644
--- a/x11-plugins/gkrellm-imonc/gkrellm-imonc-0.2-r1.ebuild
+++ b/x11-plugins/gkrellm-imonc/gkrellm-imonc-0.2-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit gkrellm-plugin
+inherit gkrellm-plugin toolchain-funcs
DESCRIPTION="A GKrellM2 plugin to control a fli4l router"
SRC_URI="mirror://sourceforge/${PN}/${PN}-src-${PV}.tar.bz2"
@@ -15,13 +15,12 @@ SLOT="0"
KEYWORDS="~amd64 x86"
IUSE=""
-COMMON_DEPEND="app-admin/gkrellm[X]"
-DEPEND+=" ${COMMON_DEPEND}"
-RDEPEND+=" ${COMMON_DEPEND}"
+RDEPEND="app-admin/gkrellm:2[X]"
+DEPEND="${RDEPEND}"
S="${WORKDIR}/${PN}-src-${PV}"
-PATCHES=( "${FILESDIR}/${PN}-makefile.patch" )
+PATCHES=( "${FILESDIR}"/${PN}-makefile.patch )
src_compile() {
emake CC="$(tc-getCC)" LDFLAGS="${LDFLAGS}"