summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-libs/netcdf-cxx/Manifest1
-rw-r--r--sci-libs/netcdf-cxx/files/netcdf-cxx-4.2-config.patch28
-rw-r--r--sci-libs/netcdf-cxx/netcdf-cxx-4.2.1-r1.ebuild36
-rw-r--r--sci-libs/netcdf-cxx/netcdf-cxx-4.2.1.ebuild36
4 files changed, 0 insertions, 101 deletions
diff --git a/sci-libs/netcdf-cxx/Manifest b/sci-libs/netcdf-cxx/Manifest
index 35d2f0af935b..47c6186db67d 100644
--- a/sci-libs/netcdf-cxx/Manifest
+++ b/sci-libs/netcdf-cxx/Manifest
@@ -1,4 +1,3 @@
-DIST netcdf-cxx-4.2.1.tar.gz 456547 BLAKE2B e973f064ad40c0d0cb76766f3b1639d16ed7eaae73d8e55db011645fc0d4e6f8949a60aeb9d47a4f8e88b3c5b2d486d42442e417908a2194b8b9a5e720ba2ff5 SHA512 d51ab1cbda74db5f7b074799d2407d0214d1c920af780ae3bb7a47b3708e45f721be7eec61902e035968a9df5019a7b2b5a10f236f6bab4cb47a26e4e7867adb
DIST netcdf-cxx-4.2.tar.gz 703482 BLAKE2B a6727b7305204d2b53e6ee951c8165b03cd07f14e5d59a306445481272d0e10eb077e4bc62a2586c57652cb8273b9098ed77836f9023817d8a9e6ef51ac2cfe8 SHA512 347ddbc518ac2186868d69417342e5146e285fc3a88f7c55edc33063f5c9a6647af7e512a03b9b6a8f67a448b85a1edcdde5df707b893f6a1527821cfd78e643
DIST netcdf-cxx-4.3.0.tar.gz 985897 BLAKE2B 89cfd85764ff8fc730c7cb4187df21a4245cd932bcf86df4edf36eb7ae636906eaafc25cfcbb3dd58bc1d346edacd7f80daa3be9a544d5d777d32ad115cfd00f SHA512 8e77333c979513721209e6b3fde31c298e18a45d7ea08123056e8120469eb8c4024d71289fab2b9182ee19ee7b6ad22bd133525bef048a497ede4aa2e9017465
DIST netcdf-cxx-4.3.1.tar.gz 607679 BLAKE2B 68677ba72e66d351bf6d33a2584a3a1edd9da98b41ed66e3f51f8d3d358bfd84bad3e2e06403edf76d26b2c76807ae40859995d8817725e531a27680d04f2501 SHA512 404711eb80d5e78968c0f6cbdcb08855a2778d7fd94e7ee94bdc9d1cd72848ac3327613c6437a7634349f26bc463b950092a2999abb34ddab0a47ad185547d22
diff --git a/sci-libs/netcdf-cxx/files/netcdf-cxx-4.2-config.patch b/sci-libs/netcdf-cxx/files/netcdf-cxx-4.2-config.patch
deleted file mode 100644
index 50b6b478bdb1..000000000000
--- a/sci-libs/netcdf-cxx/files/netcdf-cxx-4.2-config.patch
+++ /dev/null
@@ -1,28 +0,0 @@
---- netcdf-cxx4-4.2.1/ncxx4-config.in.orig 2013-01-10 10:47:00.595224631 -0800
-+++ netcdf-cxx4-4.2.1/ncxx4-config.in 2013-01-10 10:49:22.856926765 -0800
-@@ -5,7 +5,7 @@
-
- prefix=@prefix@
- exec_prefix=${prefix}
--libdir=${exec_prefix}/lib
-+libdir=@libdir@
- includedir=${prefix}/include
-
- cc="@CC@"
-@@ -13,7 +13,7 @@
- fc="@FC@"
- cflags=" -I${includedir} @CPPFLAGS@"
- fflags="@FFLAGS@ @MOD_FLAG@${includedir}"
--libs="-L${libdir} @NC_LIBS@"
-+libs="-L${libdir} @NC_LIBS@ -lnetcdf"
- flibs="-L${libdir} @NC_FLIBS@"
- has_dap="@HAS_DAP@"
- has_nc2="@HAS_NC2@"
---- netcdf-cxx4-4.2.1/netcdf-cxx4.pc.in.orig 2013-01-10 10:46:50.995177250 -0800
-+++ netcdf-cxx4-4.2.1/netcdf-cxx4.pc.in 2013-01-10 10:49:45.030036161 -0800
-@@ -10,4 +10,4 @@
- Version: @PACKAGE_VERSION@
- Libs: -L${libdir} @NC_LIBS@
- Cflags: -I${includedir}
--
-+Requires: netcdf
diff --git a/sci-libs/netcdf-cxx/netcdf-cxx-4.2.1-r1.ebuild b/sci-libs/netcdf-cxx/netcdf-cxx-4.2.1-r1.ebuild
deleted file mode 100644
index fa311868cb0b..000000000000
--- a/sci-libs/netcdf-cxx/netcdf-cxx-4.2.1-r1.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit eutils ltprune
-
-MYP=${PN}4-${PV}
-
-DESCRIPTION="C++ library for netCDF"
-HOMEPAGE="https://www.unidata.ucar.edu/software/netcdf/"
-SRC_URI="https://github.com/Unidata/netcdf-cxx4/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="UCAR-Unidata"
-SLOT="0/1"
-KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
-IUSE="examples static-libs"
-
-RDEPEND=">=sci-libs/netcdf-4.2:=[hdf5]"
-DEPEND="${RDEPEND}"
-
-S="${WORKDIR}/${MYP}"
-
-PATCHES=(
- "${FILESDIR}/${PN}-4.2-config.patch"
-)
-
-src_configure() {
- econf $(use_enable static-libs static)
-}
-
-src_install() {
- default
- use examples && dodoc -r examples
- prune_libtool_files
-}
diff --git a/sci-libs/netcdf-cxx/netcdf-cxx-4.2.1.ebuild b/sci-libs/netcdf-cxx/netcdf-cxx-4.2.1.ebuild
deleted file mode 100644
index b1bb22728e01..000000000000
--- a/sci-libs/netcdf-cxx/netcdf-cxx-4.2.1.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit autotools-utils
-
-MYP=${PN}4-${PV}
-
-DESCRIPTION="C++ library for netCDF"
-HOMEPAGE="https://www.unidata.ucar.edu/software/netcdf/"
-SRC_URI="https://github.com/Unidata/netcdf-cxx4/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="UCAR-Unidata"
-SLOT="0/1"
-KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
-IUSE="examples static-libs"
-
-RDEPEND=">=sci-libs/netcdf-4.2:="
-DEPEND="${RDEPEND}"
-
-S="${WORKDIR}/${MYP}"
-
-PATCHES=( "${FILESDIR}"/${PN}-4.2-config.patch )
-
-src_install() {
- autotools-utils_src_install
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r examples
- fi
-}
-
-src_test() {
- autotools-utils_src_test -j1
-}