summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-misc/xkeyboard-config/Manifest1
-rw-r--r--x11-misc/xkeyboard-config/xkeyboard-config-2.37.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/x11-misc/xkeyboard-config/Manifest b/x11-misc/xkeyboard-config/Manifest
index 1a27319e27ee..3534fcb8e17b 100644
--- a/x11-misc/xkeyboard-config/Manifest
+++ b/x11-misc/xkeyboard-config/Manifest
@@ -1 +1,2 @@
DIST xkeyboard-config-2.36.tar.xz 880776 BLAKE2B 3ce6d9e5a1e763beb15614cd1b559ff6d56c2f6438b1c0680755a029ac90e48de4a939b1bcc0054a510cc0e08f6ffa6db98fecd4bf11e01510b151aa664425c3 SHA512 a81054ff6b7928a445a913b80fad995056559feff7bc1f4926657f171a102108b6e22958dc6c814ae2a25445f65c94485f13399628016f1358cf3840e235e3de
+DIST xkeyboard-config-2.37.tar.xz 879744 BLAKE2B 58cc62d48a857b0935bfe7415b4a28921d02218402ca0125e8644be04a14f897e357a224fed12f9a85c6d147b4fa659241004bf49ac16c19b7f5fceb2b6d3295 SHA512 3b2da77996d48bf7b6a5f5784bbcb62070ba6ab8eabb6f255d1addd7fa58080a329464010050e894c9acc901e42e3669333db2966140c78802efb8a86620ac0e
diff --git a/x11-misc/xkeyboard-config/xkeyboard-config-2.37.ebuild b/x11-misc/xkeyboard-config/xkeyboard-config-2.37.ebuild
new file mode 100644
index 000000000000..007071e3699d
--- /dev/null
+++ b/x11-misc/xkeyboard-config/xkeyboard-config-2.37.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..11} )
+inherit meson python-any-r1
+
+DESCRIPTION="X keyboard configuration database"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/XKeyboardConfig https://gitlab.freedesktop.org/xkeyboard-config/xkeyboard-config"
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://gitlab.freedesktop.org/xkeyboard-config/xkeyboard-config.git"
+ inherit git-r3
+else
+ SRC_URI="https://www.x.org/releases/individual/data/${PN}/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+DEPEND=""
+RDEPEND=""
+BDEPEND="
+ ${PYTHON_DEPS}
+ dev-lang/perl
+ dev-libs/libxslt
+ sys-devel/gettext
+"
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dxkb-base="${EPREFIX}/usr/share/X11/xkb"
+ -Dcompat-rules=true
+ )
+ meson_src_configure
+}