summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.25.13.ebuild71
-rw-r--r--dev-db/percona-server/files/percona-server-8.0.26.16-gcc-12.patch11
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.24.13.ebuild68
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.27.13.ebuild66
-rw-r--r--dev-python/drf-yasg/Manifest1
-rw-r--r--dev-python/drf-yasg/drf-yasg-1.20.0.ebuild31
-rw-r--r--dev-python/drf-yasg/metadata.xml14
-rw-r--r--dev-python/fusepy/Manifest1
-rw-r--r--dev-python/fusepy/fusepy-3.0.1.ebuild21
-rw-r--r--dev-python/fusepy/metadata.xml16
-rw-r--r--media-sound/denonavr-cli/Manifest1
-rw-r--r--media-sound/denonavr-cli/denonavr-cli-2.ebuild27
-rw-r--r--net-misc/dropbox-cli/Manifest1
-rw-r--r--net-misc/dropbox-cli/dropbox-cli-2020.03.04-r1.ebuild31
-rw-r--r--profiles/package.mask22
18 files changed, 259 insertions, 126 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index 638dc09fea88..63cee00150cd 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -1,2 +1,3 @@
DIST aws-cli-1.25.12.gh.tar.gz 2224456 BLAKE2B d6425983b09fc3942727108e188e184f48399388704ada03df1d65ddb9adffc9597a217b863766a862e96b59c03fdb3202e694289b54ee9298fe7e547639ecc3 SHA512 a77e0d082a8dacecadbd2fa6cc1143fa5148e075894565fe9a552e9d1a27fd068c72ae57eb5c628129bb024267111b76722cf2c40dc9f719db8d96232302b918
+DIST aws-cli-1.25.13.gh.tar.gz 2224352 BLAKE2B 0f6b94545f8504dcf6a458df28b39b3a909869033ccf04ad1ad3652e6606573002cbd3fed7f65756a140bac7d3b1ccddbc6fcc84391b194b3a987cf8534c4bdc SHA512 f494f9b31e91bb0e7446867efe4539f04ac91b12ad7f4db2f355d1a391ce7a8bd1d40f4afe04855d227414a7c2479ec6fdaf9a42f1959b28d205df48c2b4d723
DIST aws-cli-1.25.7.gh.tar.gz 2223153 BLAKE2B fcadda94fd721135f94b1538c4b27e41108064f6fd32f324d5436138e3d1b0ffcab53fcc545b01c461365d55c4bfa2a05d90e94c875c929a3227efae76452415 SHA512 194adacab0df87d8e4f0cdc71bb956bef6dc8b2de2e7e4416c9c079ff2b7c2bce7584ac1049428d0bcb134368b39c37c04bc5e6a8fc7540c44c64f3934ccaf21
diff --git a/app-admin/awscli/awscli-1.25.13.ebuild b/app-admin/awscli/awscli-1.25.13.ebuild
new file mode 100644
index 000000000000..4154af977ee6
--- /dev/null
+++ b/app-admin/awscli/awscli-1.25.13.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit bash-completion-r1 distutils-r1 multiprocessing
+
+MY_P=aws-cli-${PV}
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="
+ https://github.com/aws/aws-cli/
+ https://pypi.org/project/awscli/
+"
+SRC_URI="
+ https://github.com/aws/aws-cli/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+# botocore is x.(y+2).z
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 2)).$(ver_cut 3-)"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.6.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)" --forked
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}
diff --git a/dev-db/percona-server/files/percona-server-8.0.26.16-gcc-12.patch b/dev-db/percona-server/files/percona-server-8.0.26.16-gcc-12.patch
index f80b02ff2eb2..1780d7e478f5 100644
--- a/dev-db/percona-server/files/percona-server-8.0.26.16-gcc-12.patch
+++ b/dev-db/percona-server/files/percona-server-8.0.26.16-gcc-12.patch
@@ -1,4 +1,5 @@
https://bugs.gentoo.org/842168
+https://bugs.gentoo.org/853085
--- a/client/logger.cc
+++ b/client/logger.cc
@@ -27,6 +27,7 @@
@@ -19,3 +20,13 @@ https://bugs.gentoo.org/842168
#include <sstream>
#include <m_string.h>
+--- a/plugin/auth_ldap/src/connection.cc
++++ b/plugin/auth_ldap/src/connection.cc
+@@ -1,6 +1,7 @@
+ #include "plugin/auth_ldap/include/connection.h"
+
+ #include <iostream>
++#include <iterator>
+ #include <regex>
+
+ #include "plugin/auth_ldap/include/plugin_log.h"
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 1721b1808176..59885c8a4e3c 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -1,2 +1,3 @@
DIST boto3-1.24.12.gh.tar.gz 509573 BLAKE2B 5c9978cac1cbce0521dee6f2164652c4fca82b0bf20276e3f4e75960e0877ec0545ca50884daedde115bba117bea424da2ad2fe63e845a32a6f832a3ab5a5841 SHA512 dec940a6e97c51089933a66994b14882f31f2ed7959f966e1f9cd2e6a4a1bb40cc2c01d509ce7346ac345df30d0f164213034c0de97daf3053ba4ea51e5f7495
+DIST boto3-1.24.13.gh.tar.gz 510032 BLAKE2B 4d204f4b4e1dbe970d45e65eb04061193d1b21236b59f33994d03138e5a1f31fce2d27f7323d1a4da8b5f88d143e1dc51cdc73e19689e79722ae696453d314e3 SHA512 e8962339b1e5c72ace2d9980d7268bd09725b11b30425c32d649703089b32324ca442e597756a14a3d4be222c3628a8ccac4da2d7739cc237dfc29a8ea722818
DIST boto3-1.24.7.gh.tar.gz 508670 BLAKE2B d526f6a4dc4c6126c61ca7c9074b4341c742f84a6e95b38cd8a450fb74df379cee44513e1be6bc7cd0c8f728598d0ecfc06240120a8da71f75f86371498f5233 SHA512 4d57e38c18138b950f93a234132ac1d31c9a29ad00ca5e1298517d6b16ff2849802ce6cfeb8de390c2eb25086043d45e0276a7a563707595649ca1905367be52
diff --git a/dev-python/boto3/boto3-1.24.13.ebuild b/dev-python/boto3/boto3-1.24.13.ebuild
new file mode 100644
index 000000000000..6edcc751d54b
--- /dev/null
+++ b/dev-python/boto3/boto3-1.24.13.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.6.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)"
+}
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index be415875fa92..62b6e7328a3f 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -1,2 +1,3 @@
DIST botocore-1.27.12.tar.gz 9132872 BLAKE2B 74b74b5a5745cfacac066d5e087974fb58be5a600c7cfb2077d243044b8c429b1396d19e6790c0f754e42931085b115f74039b8c93da39593512d28021d6314a SHA512 767defae44ffb3b54b55625fd0f8a20c22a4a5f209a1397b1a27cfc2e36ac9e03cfdd25bc77bebc944613c5744dd7651e1b574674e8a992f219e172eee9210f5
+DIST botocore-1.27.13.tar.gz 9134638 BLAKE2B 471a46a4c4f14082ceb7030495a121ea90a6f67b6f802cbeb1394624513ff86deb7b90e3aa3e568dff42cd3280ea038565752eff69577231250b6542e6586e1f SHA512 6becb7cd6d2ea3b09012f7b168dcf7fd3386c19ee6003a4e8f4059e3b1ad2b281f5fdaab7abaafe6c34bccd547c8f8ef1bc253f5190d3e91127b1239ec8e307a
DIST botocore-1.27.7.tar.gz 9102259 BLAKE2B 094ec463531f1dfd54ff32d0f44ebc39cdc0a6d4c3e19b49a25e25d9d13acdcd26c782c1d4819ea4f1cb8954a858aa6e997411785678700b7ca03cd8844527b5 SHA512 d4a1327f4314279548af00fbc6da2f9fc5f25f704da3f6ddfa90773878f28ac9f03556b00fa4c0207ec2e952eb716aa98c1c22abffbd51d82dc55d9e4ceeca5c
diff --git a/dev-python/botocore/botocore-1.27.13.ebuild b/dev-python/botocore/botocore-1.27.13.ebuild
new file mode 100644
index 000000000000..830c713f6036
--- /dev/null
+++ b/dev-python/botocore/botocore-1.27.13.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="
+ https://github.com/boto/botocore/
+ https://pypi.org/project/botocore/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ <dev-python/jmespath-2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ )
+
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)"
+}
diff --git a/dev-python/drf-yasg/Manifest b/dev-python/drf-yasg/Manifest
deleted file mode 100644
index 67f94634e575..000000000000
--- a/dev-python/drf-yasg/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST drf-yasg-1.20.0.tar.gz 1800321 BLAKE2B 3db8b0b33c2919d4a331b06b1f6e324ce6e0e160c0454cb066e61cbf7bb580efadb5cd9624579492db3404edcc8e50753e63b6edae022842cd087b820779557d SHA512 b56cd00d7a09f197e95c0129e20e561ece783b4edb389b228027ab8768247ccba15db5768f52a3d5ac5a4c47faa7a447ed7eb9b22af2a21377a36dcb7e7b267f
diff --git a/dev-python/drf-yasg/drf-yasg-1.20.0.ebuild b/dev-python/drf-yasg/drf-yasg-1.20.0.ebuild
deleted file mode 100644
index d72f426f74b4..000000000000
--- a/dev-python/drf-yasg/drf-yasg-1.20.0.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-inherit distutils-r1
-
-DESCRIPTION="Automated generation of Swagger/OpenAPI 2.0 schemas from Django Rest framework"
-HOMEPAGE="https://github.com/axnsan12/drf-yasg"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="+validation"
-
-RDEPEND="
- >=dev-python/coreapi-2.3.3[${PYTHON_USEDEP}]
- >=dev-python/coreschema-0.0.4[${PYTHON_USEDEP}]
- >=dev-python/ruamel-yaml-0.15.34[${PYTHON_USEDEP}]
- >=dev-python/inflection-0.3.1[${PYTHON_USEDEP}]
- >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
- >=dev-python/uritemplate-3.0.0[${PYTHON_USEDEP}]
- dev-python/packaging
- >=dev-python/djangorestframework-3.8[${PYTHON_USEDEP}]
- >=dev-python/django-1.11.7[${PYTHON_USEDEP}]
- validation? ( >=dev-python/swagger-spec-validator-2.1.0[${PYTHON_USEDEP}] )
-"
-
-DEPEND="${RDEPEND}"
diff --git a/dev-python/drf-yasg/metadata.xml b/dev-python/drf-yasg/metadata.xml
deleted file mode 100644
index 872e1cf1181f..000000000000
--- a/dev-python/drf-yasg/metadata.xml
+++ /dev/null
@@ -1,14 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <!-- maintainer-needed -->
- <use>
- <flag name="validation">
- Enable swagger spec validation using swagger-spec-validator
- </flag>
- </use>
- <upstream>
- <remote-id type="pypi">drf-yasg</remote-id>
- <remote-id type="github">axnsan12/drf-yasg</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/dev-python/fusepy/Manifest b/dev-python/fusepy/Manifest
deleted file mode 100644
index 1654ec36983d..000000000000
--- a/dev-python/fusepy/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST fusepy-3.0.1.tar.gz 11519 BLAKE2B c76319b0d0b64a8dc674b803551f32352fed9a1e6e050110963a159259c3fed8fefbb63cfe6dda689738f07cb796c6b9da14e3070c4a1cf5b70892a6ebe52cc2 SHA512 f913dfd9f29412daa8239548c8ad8bcc64f8fc7be1425bf34cd40a5c4d22faae67c5d5575c187395d911f64ad0dda186614ada598b38b9557e18794639d43767
diff --git a/dev-python/fusepy/fusepy-3.0.1.ebuild b/dev-python/fusepy/fusepy-3.0.1.ebuild
deleted file mode 100644
index d8801526d83e..000000000000
--- a/dev-python/fusepy/fusepy-3.0.1.ebuild
+++ /dev/null
@@ -1,21 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7,8,9} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python FUSE bindings using ctypes"
-HOMEPAGE="https://github.com/fusepy/fusepy https://pypi.org/project/fusepy/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="ISC"
-KEYWORDS="~amd64 ~x86"
-SLOT="0"
-
-RDEPEND="
- >=sys-fs/fuse-2.9.7:0
- !dev-python/fuse-python
-"
diff --git a/dev-python/fusepy/metadata.xml b/dev-python/fusepy/metadata.xml
deleted file mode 100644
index d648eceddd2d..000000000000
--- a/dev-python/fusepy/metadata.xml
+++ /dev/null
@@ -1,16 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>python@gentoo.org</email>
- <name>Python</name>
- </maintainer>
- <longdescription>
- fusepy is a Python module that provides a simple interface to FUSE and
- MacFUSE. It's just one file and is implemented using ctypes.
- </longdescription>
- <upstream>
- <remote-id type="github">fusepy/fusepy</remote-id>
- <remote-id type="pypi">fusepy</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/media-sound/denonavr-cli/Manifest b/media-sound/denonavr-cli/Manifest
index 9bc5f41c0735..8ff81d24e1fe 100644
--- a/media-sound/denonavr-cli/Manifest
+++ b/media-sound/denonavr-cli/Manifest
@@ -1 +1,2 @@
DIST denonavr-cli-1.gh.tar.gz 3508 BLAKE2B e26ce26062f64f67630f07098c2d0bc4045a8f5f04ae8216b8dc7df25e0f80c1df8fb67c9992382d08e273c543f51956bc17d9ac160daf47d3756fbc7e1941cb SHA512 4f37689f3ab29ad199c183ef0c5ea8c83e8418993d6640acfacfa354382e5a97fcfa42e2ba0865c22037585216581ef6141ce39fd4fd2f296c6e4e62b97b6b84
+DIST denonavr-cli-2.gh.tar.gz 4102 BLAKE2B 1f17a642cd546d3a9fb77ee9d24a6c7c1622e8c0d6fd6f4d04ac1daa4b491908e3bc18efce4e827fbf6936b91929e68d32efe0c91aec260069817d6c0708eb9f SHA512 04354f5fdf46e179a82df3d539329fd6f00312c3d87fc78ecc40c85223c468c6bfc93092e835351857a1ca4fa149c5f209aa6a2d96caf518332dd7dc4aba334d
diff --git a/media-sound/denonavr-cli/denonavr-cli-2.ebuild b/media-sound/denonavr-cli/denonavr-cli-2.ebuild
new file mode 100644
index 000000000000..32f23f00f481
--- /dev/null
+++ b/media-sound/denonavr-cli/denonavr-cli-2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A simple CLI for Denon AV receivers"
+HOMEPAGE="
+ https://github.com/mgorny/denonavr-cli/
+ https://pypi.org/project/denonavr-cli/
+"
+SRC_URI="
+ https://github.com/mgorny/denonavr-cli/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/denonavr[${PYTHON_USEDEP}]
+"
diff --git a/net-misc/dropbox-cli/Manifest b/net-misc/dropbox-cli/Manifest
index 63a57f9688f6..c0b228a98864 100644
--- a/net-misc/dropbox-cli/Manifest
+++ b/net-misc/dropbox-cli/Manifest
@@ -1,2 +1 @@
-DIST dropbox-cli-2020.03.04.py.xz 14304 BLAKE2B 600378cbacd6e96c16e1c8464261b260f2d8919ef5f361c4f337386d3849294cf8557d44f1c5d4f5682eadb2f15885a16b0a8fa162929665e518801d23ec35cc SHA512 c6c8f2f3fb08818388f5ac812821a1530214ad18d58191b08092852aa953e2947871145b46a4df4debeb629a870e1182a47fd5a8bdf8b22144e686e19ede689a
DIST dropbox-cli-2022.py.xz 14288 BLAKE2B a90d347efcce5917179853afef346a6679dddbb33e146a936786c226ad519601f503d73eeb1d1e205be8bd11792aeedb90ff7046c770f079a47e75dea80efd99 SHA512 59bfbf3544a8407bbc232d87e57d8b27d4bbc108483af52e58c0badddde6ce2dfde2203403a8c5e8c95421fe8c4b73e75cec64def2699ae9bac31be965e98974
diff --git a/net-misc/dropbox-cli/dropbox-cli-2020.03.04-r1.ebuild b/net-misc/dropbox-cli/dropbox-cli-2020.03.04-r1.ebuild
deleted file mode 100644
index 44de1f5f0fb6..000000000000
--- a/net-misc/dropbox-cli/dropbox-cli-2020.03.04-r1.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-
-inherit python-r1 bash-completion-r1
-
-DESCRIPTION="Cli interface for dropbox (python), part of nautilus-dropbox"
-HOMEPAGE="https://www.dropbox.com/"
-SRC_URI="https://dev.gentoo.org/~grozin/${P}.py.xz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE=""
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND="net-misc/dropbox
- ${PYTHON_DEPS}
- dev-python/pygpgme[${PYTHON_USEDEP}]
- dev-python/pygobject:3[${PYTHON_USEDEP}]"
-
-S=${WORKDIR}
-
-src_install() {
- newbin ${P}.py ${PN}
- python_replicate_script "${D}"/usr/bin/${PN}
- newbashcomp "${FILESDIR}"/${PN}-19-completion ${PN}
-}
diff --git a/profiles/package.mask b/profiles/package.mask
index d7bdf346838c..d857b53a0165 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -33,6 +33,18 @@
#--- END OF EXAMPLES ---
+# Sam James <sam@gentoo.org> (2022-06-21)
+# Fails to build with GCC 12, upstream location is gone, no sign of activity,
+# and very few other distributions packaging this. Bug #841824.
+# Removal on 2022-07-21.
+app-backup/kfoldersync
+
+# Sam James <sam@gentoo.org> (2022-06-21)
+# Obsolete, no reverse dependencies, does not run test suite, and doesn't
+# support Python 3.10+. Use app-crypt/gpgme[python] instead.
+# Bugs #845807, #798372, #748531. Removal on 2022-07-21.
+dev-python/pygpgme
+
# Hans de Graaff <graaff@gentoo.org> (2022-06-19)
# Obsolete slot. Use a newer slot instead.
# Removal in 30 days.
@@ -285,16 +297,6 @@ dev-python/pypeg2
# Removal on 2022-06-22. bug #700944, bug #845834
dev-python/pytest-cache
-# Sam James <sam@gentoo.org> (2022-05-21)
-# No activity upstream since 2018, unmaintained upstream, does not support
-# Python 3.10+. Removal on 2022-06-21. bug #845726.
-dev-python/fusepy
-
-# Sam James <sam@gentoo.org> (2022-05-21)
-# Unmaintained in Gentoo, no recent activity upstream, and most importantly
-# does not yet support Python 3.10+. Removal on 2022-06-21. bugs #845720, #797850.
-dev-python/drf-yasg
-
# Hans de Graaff <graaff@gentoo.org> (2022-05-20)
# Unused slots of cucumber components that are no longer or were never
# used by current cucumber versions. Masked for removal in 30 days.