summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-admin/puppet-lint/Manifest2
-rw-r--r--app-admin/puppet-lint/puppet-lint-4.2.3.ebuild39
2 files changed, 41 insertions, 0 deletions
diff --git a/app-admin/puppet-lint/Manifest b/app-admin/puppet-lint/Manifest
index 35b4c1fc57c0..9b60d332f792 100644
--- a/app-admin/puppet-lint/Manifest
+++ b/app-admin/puppet-lint/Manifest
@@ -2,3 +2,5 @@ DIST puppet-lint-3.4.0.gem 83456 BLAKE2B fa6b274b3e6e84095fdaff6f024864dc301f0af
DIST puppet-lint-4.0.0.gem 80896 BLAKE2B 6e674deaec43c3b45e2c162ef3d09648bd3cdd589a3ae6ce92e21617633529705fe9999f4c6c361c3c1f041a3d25d1a03079f2f97705c01199253661bc9355dc SHA512 a23d316f60cb7d34c394bdaee0ad08070098d732210a92294a3d330cff7330aefe2be6bd9a60219d7538173c2f187c1ed427c6671a345f868286986164ea3a33
DIST puppet-lint-4.2.1.gem 81920 BLAKE2B 5e291e4c1743092be9935231280f04ce3affdc1d530180f26a6ace0535a15e11bc9b33dd89d8eeafb44ebc7cae16f2656e293a6e8e8fbc4fd2cfde896996d59a SHA512 d39a287d3ae0ecbf27254c289e73918b62b50bbf8f44f51248e5e8042b194c32facd1215d7b24ab768714aeb9ae58647964bdc8b8b4650d1cebe6e2e749d782c
DIST puppet-lint-4.2.2.gem 81920 BLAKE2B cad796866f323113a8c2aa5cf86b6187423f27186032ea76ebd1f158937c34f315d93de3d92b01acc0b160947b720bd987550c52aaa53a51f165396de776ec88 SHA512 e8a591e615db87dc2edc22fc4d53c03004e0227748896005d2252fab8b77193ecd30f9167702c6c4fd6551daaa0894789f3d9d50fb705eecaed4a22573a94afc
+DIST puppet-lint-4.2.3-pr181-fix-warnings.patch 5601 BLAKE2B a04fdf9d8627cc888924b4282a09e076d7e029eda008fc8da138a121a21e227cff45a54ddbe770a286a2a15e43d4402526a6201c805f6e574755a11a1d13d7d7 SHA512 15638f2d4a81c969aa77b51f2f147a1fba5544dd7e52f3127dc9949afaabbd161f815a22dc5091f19d3d16bc2be97bb50f455a3a67c503aff58e737288f80e49
+DIST puppet-lint-4.2.3.gem 81920 BLAKE2B ee98aaed336a4302c4d67d94c83f30f6fdfc111192b483f39a2c096f00daff2f7caf54bfa11c4b8217648a0ca68c6c8da5a4a6f2d0cab8efb6e2d7e814155780 SHA512 2f2192a48ed460371092ce99755b8cde55526ed96ee72d2a5b7989f7df7afb6abce5d3e8e7a0dca577b199bb380935e8734a92a53248697bb7195091da4cb9f6
diff --git a/app-admin/puppet-lint/puppet-lint-4.2.3.ebuild b/app-admin/puppet-lint/puppet-lint-4.2.3.ebuild
new file mode 100644
index 000000000000..b57aa7a47bc0
--- /dev/null
+++ b/app-admin/puppet-lint/puppet-lint-4.2.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_BINWRAP="puppet-lint"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A linter for puppet DSL"
+HOMEPAGE="https://github.com/puppetlabs/puppet-lint"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+PATCH_NAME="${PN}-4.2.3-pr181-fix-warnings.patch"
+SRC_URI+=" https://github.com/puppetlabs/puppet-lint/pull/181.patch -> ${PATCH_NAME} "
+
+PATCHES=(
+ "${DISTDIR}/${PATCH_NAME}"
+)
+
+ruby_add_bdepend "test? (
+ dev-ruby/rspec-its:1
+ dev-ruby/rspec-collection_matchers:1
+ dev-ruby/rspec-json_expectations )"
+
+all_ruby_prepare() {
+ # Skip acceptance tests due to unpackages puppet_litmus which in turn
+ # has a number of unpackaged dependencies.
+ rm -rf spec/acceptance || die
+ rm -f spec/spec_helper_acceptance.rb || die
+}