summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-lang/mmix/mmix-20160804.ebuild44
1 files changed, 0 insertions, 44 deletions
diff --git a/dev-lang/mmix/mmix-20160804.ebuild b/dev-lang/mmix/mmix-20160804.ebuild
deleted file mode 100644
index 95967668d8d0..000000000000
--- a/dev-lang/mmix/mmix-20160804.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit eutils toolchain-funcs
-
-DESCRIPTION="Donald Knuth's MMIX Assembler and Simulator"
-HOMEPAGE="https://www-cs-faculty.stanford.edu/~knuth/mmix.html http://mmix.cs.hm.edu"
-SRC_URI="http://mmix.cs.hm.edu/src/${P}.tgz"
-
-DEPEND="virtual/tex-base
- doc? ( dev-texlive/texlive-plaingeneric )"
-RDEPEND=""
-
-SLOT="0"
-LICENSE="${PN}"
-KEYWORDS="amd64 x86"
-IUSE="doc"
-
-S="${WORKDIR}"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-20110420-makefile.patch
- "${FILESDIR}"/${PN}-20131017-format-security.patch
-)
-
-src_compile() {
- export VARTEXFONTS=${T}/fonts
- emake all \
- CFLAGS="${CFLAGS}" \
- CC="$(tc-getCC)"
-
- if use doc ; then
- emake doc
- fi
-}
-
-src_install() {
- dobin ${PN} ${PN}al m${PN} mmotype abstime
- dodoc README ${PN}.1
-
- use doc && dodoc *.ps
-}