summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-libs/wlc/wlc-0.0.2.ebuild10
-rw-r--r--dev-libs/wlc/wlc-9999.ebuild10
2 files changed, 18 insertions, 2 deletions
diff --git a/dev-libs/wlc/wlc-0.0.2.ebuild b/dev-libs/wlc/wlc-0.0.2.ebuild
index 72f4ddd828b3..8917c648a1c3 100644
--- a/dev-libs/wlc/wlc-0.0.2.ebuild
+++ b/dev-libs/wlc/wlc-0.0.2.ebuild
@@ -6,7 +6,7 @@ EAPI=6
inherit cmake-utils
-DESCRIPTION="A helper library for Wayland compositors."
+DESCRIPTION="A helper library for Wayland compositors"
HOMEPAGE="https://github.com/Cloudef/wlc"
SRC_URI="https://github.com/Cloudef/wlc/releases/download/v${PV}/${P}.tar.bz2"
@@ -48,3 +48,11 @@ src_configure() {
cmake-utils_src_configure
}
+
+pkg_postinst() {
+ if use X && !has_version 'x11-base/xorg-server[wayland]'
+ then
+ elog "You have enabled wlc's X11 support. To use Xwayland, you must emerge"
+ elog "'x11-base/xorg-server[wayland]'."
+ fi
+}
diff --git a/dev-libs/wlc/wlc-9999.ebuild b/dev-libs/wlc/wlc-9999.ebuild
index 8af28d5b7c41..55443ba35d45 100644
--- a/dev-libs/wlc/wlc-9999.ebuild
+++ b/dev-libs/wlc/wlc-9999.ebuild
@@ -6,7 +6,7 @@ EAPI=6
inherit git-r3 cmake-utils
-DESCRIPTION="A helper library for Wayland compositors."
+DESCRIPTION="A helper library for Wayland compositors"
HOMEPAGE="https://github.com/Cloudef/wlc"
EGIT_REPO_URI="https://github.com/Cloudef/wlc.git"
@@ -48,3 +48,11 @@ src_configure() {
cmake-utils_src_configure
}
+
+pkg_postinst() {
+ if use X && !has_version 'x11-base/xorg-server[wayland]'
+ then
+ elog "You have enabled wlc's X11 support. To use Xwayland, you must emerge"
+ elog "'x11-base/xorg-server[wayland]'."
+ fi
+}