summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-text/evince/Manifest1
-rw-r--r--app-text/evince/evince-3.30.2.ebuild107
-rw-r--r--app-text/evince/files/3.30.2-internal-synctex.patch28
-rw-r--r--app-text/evince/metadata.xml1
-rw-r--r--profiles/arch/arm64/package.use.mask4
-rw-r--r--profiles/arch/ia64/package.use.mask1
-rw-r--r--profiles/package.mask1
7 files changed, 143 insertions, 0 deletions
diff --git a/app-text/evince/Manifest b/app-text/evince/Manifest
index 5694a99e25d9..a5fbfa85e111 100644
--- a/app-text/evince/Manifest
+++ b/app-text/evince/Manifest
@@ -1 +1,2 @@
DIST evince-3.28.5.tar.xz 2196432 BLAKE2B 992e37ad3cb82934efbdcd83afa89dc7589104045e828c6516650ee0a3fc89b99dff3fe0a723691e95adba9a5cf767a95ec18690697df15310437c7980ccbf55 SHA512 42fcf1396546f62910966b31bc657e5d3532a6bf32e87590b057efded1597de5765ed5c17ae98208a5dafca54da9c8e81f451e4133df656aaf4a9966da457bc3
+DIST evince-3.30.2.tar.xz 2288868 BLAKE2B dd0423b7ec51daf897bfbc45afb298f9ee23b28ada3dfe5d5d2808b4515bdc7077a7e0ae46541876bb2fbfd8aa9ec44abc7aabcb3cb10b6e52912f0ac1358eeb SHA512 dfffcf15547d0720bd2379054d7b9bee02f8bea7113562162cbab62d77cf84c04f70dcc87a3e6b1ba62db38783df8f481d801854d8f0767f60e9cfabd9efc646
diff --git a/app-text/evince/evince-3.30.2.ebuild b/app-text/evince/evince-3.30.2.ebuild
new file mode 100644
index 000000000000..c6623539c8a6
--- /dev/null
+++ b/app-text/evince/evince-3.30.2.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+GNOME2_EAUTORECONF="yes"
+
+inherit gnome2 systemd
+
+DESCRIPTION="Simple document viewer for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Evince"
+
+LICENSE="GPL-2+ CC-BY-SA-3.0"
+# subslot = evd3.(suffix of libevdocument3)-evv3.(suffix of libevview3)
+SLOT="0/evd3.4-evv3.3"
+IUSE="djvu dvi gstreamer gnome gnome-keyring +introspection nautilus nsplugin postscript spell t1lib tiff xps"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x64-solaris"
+
+# atk used in libview
+# bundles unarr
+COMMON_DEPEND="
+ dev-libs/atk
+ >=dev-libs/glib-2.36:2[dbus]
+ >=dev-libs/libxml2-2.5:2
+ sys-libs/zlib:=
+ >=x11-libs/gdk-pixbuf-2.36.5:2
+ >=x11-libs/gtk+-3.16.0:3[introspection?]
+ gnome-base/gsettings-desktop-schemas
+ >=x11-libs/cairo-1.10:=
+ >=app-text/poppler-0.33[cairo]
+ >=app-arch/libarchive-3.2.0
+ djvu? ( >=app-text/djvu-3.5.22:= )
+ dvi? (
+ virtual/tex-base
+ dev-libs/kpathsea:=
+ t1lib? ( >=media-libs/t1lib-5:= ) )
+ gstreamer? (
+ media-libs/gstreamer:1.0
+ media-libs/gst-plugins-base:1.0
+ media-libs/gst-plugins-good:1.0 )
+ gnome? ( gnome-base/gnome-desktop:3= )
+ gnome-keyring? ( >=app-crypt/libsecret-0.5 )
+ introspection? ( >=dev-libs/gobject-introspection-1:= )
+ nautilus? ( >=gnome-base/nautilus-2.91.4 )
+ postscript? ( >=app-text/libspectre-0.2:= )
+ spell? ( >=app-text/gspell-1.6.0:= )
+ tiff? ( >=media-libs/tiff-3.6:0= )
+ xps? ( >=app-text/libgxps-0.2.1:= )
+"
+RDEPEND="${COMMON_DEPEND}
+ gnome-base/gvfs
+ gnome-base/librsvg
+ || (
+ >=x11-themes/adwaita-icon-theme-2.17.1
+ >=x11-themes/hicolor-icon-theme-0.10 )
+"
+DEPEND="${COMMON_DEPEND}
+ app-text/docbook-xml-dtd:4.3
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ >=dev-util/gtk-doc-am-1.13
+ >=dev-util/intltool-0.35
+ dev-util/itstool
+ sys-devel/gettext
+ virtual/pkgconfig
+ app-text/yelp-tools
+"
+# eautoreconf needs:
+# app-text/yelp-tools
+
+PATCHES=(
+ "${FILESDIR}"/${PV}-internal-synctex.patch # don't automagically link to synctex from texlive-core - always use internal copy of this small parser for now; requires eautoreconf
+)
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Do not depend on adwaita-icon-theme, bug #326855, #391859
+ # https://bugs.freedesktop.org/show_bug.cgi?id=29942
+ sed -e 's/adwaita-icon-theme >= $ADWAITA_ICON_THEME_REQUIRED//g' \
+ -i configure || die "sed failed"
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ --enable-pdf \
+ --enable-comics \
+ --enable-thumbnailer \
+ --with-platform=gnome \
+ --enable-dbus \
+ $(use_enable djvu) \
+ $(use_enable dvi) \
+ $(use_enable gstreamer multimedia) \
+ $(use_enable gnome libgnome-desktop) \
+ $(use_with gnome-keyring keyring) \
+ $(use_enable introspection) \
+ $(use_enable nautilus) \
+ $(use_enable nsplugin browser-plugin) \
+ $(use_enable postscript ps) \
+ $(use_with spell gspell) \
+ $(use_enable t1lib) \
+ $(use_enable tiff) \
+ $(use_enable xps) \
+ BROWSER_PLUGIN_DIR="${EPREFIX}"/usr/$(get_libdir)/nsbrowser/plugins \
+ --with-systemduserunitdir="$(systemd_get_userunitdir)"
+}
diff --git a/app-text/evince/files/3.30.2-internal-synctex.patch b/app-text/evince/files/3.30.2-internal-synctex.patch
new file mode 100644
index 000000000000..16ef50ecd60f
--- /dev/null
+++ b/app-text/evince/files/3.30.2-internal-synctex.patch
@@ -0,0 +1,28 @@
+From a4a831f998d513c6d01394d9b106aa42faf60dd3 Mon Sep 17 00:00:00 2001
+From: Mart Raudsepp <leio@gentoo.org>
+Date: Sat, 23 Feb 2019 21:05:28 +0200
+Subject: [PATCH] build: always use internal synctex instead of automagically
+
+We don't have a separate synctex package and would have to pull in
+all of texlive-core; so instead of fixing the automagic use of it,
+just remove support for external synctex, as that's easier.
+---
+ configure.ac | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index 13bdd600..e5334319 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -539,7 +539,7 @@ GOBJECT_INTROSPECTION_CHECK([1.0])
+
+ dnl ================== libsynctex ===========================================
+
+-PKG_CHECK_MODULES(SYNCTEX, [synctex >= $SYNCTEX_REQUIRED], has_synctex=system, has_synctex=internal)
++has_synctex=internal
+
+ dnl not found? use internal code copy.
+ if test "x$has_synctex" = "xinternal"; then
+--
+2.17.0
+
diff --git a/app-text/evince/metadata.xml b/app-text/evince/metadata.xml
index 464a13181670..12e56453922c 100644
--- a/app-text/evince/metadata.xml
+++ b/app-text/evince/metadata.xml
@@ -9,6 +9,7 @@
<flag name="dvi">Enable the built-in DVI viewer</flag>
<flag name="nautilus">Enable property page extension in <pkg>gnome-base/nautilus</pkg></flag>
<flag name="postscript" restrict="&gt;=app-text/evince-3.26">Enable support for PostScript and Adobe Illustrator documents with <pkg>app-text/libspectre</pkg></flag>
+ <flag name="spell">Enable inline spell check for annotations via <pkg>app-text/gspell</pkg></flag>
<flag name="t1lib">Enable the Type-1 fonts for the built-in DVI viewer
(<pkg>media-libs/t1lib</pkg>)</flag>
<flag name="xps">Enable XPS viewer using <pkg>app-text/libgxps</pkg></flag>
diff --git a/profiles/arch/arm64/package.use.mask b/profiles/arch/arm64/package.use.mask
index ea353381a6e4..54d30299be51 100644
--- a/profiles/arch/arm64/package.use.mask
+++ b/profiles/arch/arm64/package.use.mask
@@ -1,6 +1,10 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
+# Mart Raudsepp <leio@gentoo.org> (23 Feb 2019)
+# app-text/gspell not keyworded yet
+app-text/evince spell
+
# Davide Pesavento <pesa@gentoo.org> (27 Dec 2018)
# The corresponding Qt5 modules are not keyworded on arm64, and we don't want to
# keyword them solely because of PyQt5 while there are no other in-tree users.
diff --git a/profiles/arch/ia64/package.use.mask b/profiles/arch/ia64/package.use.mask
index 9ff4314238c0..335bbb7b5e0f 100644
--- a/profiles/arch/ia64/package.use.mask
+++ b/profiles/arch/ia64/package.use.mask
@@ -136,6 +136,7 @@ media-sound/rhythmbox upnp-av
# Alexandre Rostovtsev <tetromino@gentoo.org> (28 Jun 2016)
# Missing keywords on app-text/gspell - bug #587368
>=app-editors/gedit-3.20 spell
+>=app-text/evince-3.30 spell
# Justin Lecher <jlec@gentoo.org> (22 Feb 2016)
# Missing test deps keyword #575366
diff --git a/profiles/package.mask b/profiles/package.mask
index 92fd751d9540..fff1a3b3dd9f 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -40,6 +40,7 @@
>=gnome-extra/gnome-clocks-3.30.1
=gnome-base/gnome-control-center-3.26.2-r2
=gnome-extra/gnome-contacts-3.30.2
+=app-text/evince-3.30.2
# Michał Górny <mgorny@gentoo.org> (13 Feb 2019)
# Release candidate, masked for testing.