summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-shells/rrs/rrs-1.70-r2.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/app-shells/rrs/rrs-1.70-r2.ebuild b/app-shells/rrs/rrs-1.70-r2.ebuild
new file mode 100644
index 000000000000..99787758d34b
--- /dev/null
+++ b/app-shells/rrs/rrs-1.70-r2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="Reverse Remote Shell"
+HOMEPAGE="http://freecode.com/projects/rrs"
+SRC_URI="http://www.cycom.se/uploads/36/19/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="ssl"
+
+DEPEND="ssl? ( dev-libs/openssl:0= )"
+RDEPEND="${DEPEND}"
+
+PATCH=( "${FILESDIR}"/"${P}"-asneeded.patch)
+
+DOCS=( CHANGES README )
+
+src_prepare() {
+ default
+ sed -i -e "s#-s ##g" Makefile || die
+}
+
+src_compile() {
+ local target=""
+ use ssl || target="-nossl"
+
+ emake generic${target} CFLAGS="${CFLAGS}" LDEXTRA="${LDFLAGS}" CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin "${PN}"
+ doman "${PN}.1"
+ einstalldocs
+}