summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/jsonschema/Manifest1
-rw-r--r--dev-python/jsonschema/jsonschema-3.2.0.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/jsonschema/Manifest b/dev-python/jsonschema/Manifest
index d6c1ad4aee28..f4bd0008343a 100644
--- a/dev-python/jsonschema/Manifest
+++ b/dev-python/jsonschema/Manifest
@@ -3,3 +3,4 @@ DIST jsonschema-2.4.0.tar.gz 48293 BLAKE2B a3e4ddece8550dde833fb447aefe1e22db6e9
DIST jsonschema-2.5.1.tar.gz 50855 BLAKE2B 552c8878aff8f67db6011abfcbda73efac82b557c2e7d0ed7fca755e51ab263816931e8c6e69ea43356257d25efabedc5bac135d1477534184d3783714bf2b8f SHA512 9e8f6ce16504b7ae7ef1ceb44ecb07eab85923e40967bd8e502b9fa779e772b547db90f56ca951d06591b951e7240db1071e909ac75543d42f6f2495f6de3298
DIST jsonschema-2.6.0.tar.gz 53252 BLAKE2B 38d2d1d9f91e923e66aa44fede2597b129813b18b39133da1935758dc651a0e567515e8b97bbd0cb4f0a2cb652c635446aa3dd4026066dc3d996e32a33495af5 SHA512 03f916abd023b32fbe60f91718d6f2f94d8834bd1bd8ec85ab02f591a145161275c2cde25b037c4d2e94703b870159feb776d3556f011e4c394d2e20ab897b0b
DIST jsonschema-3.0.1.tar.gz 120834 BLAKE2B f99d77847a697bb28bac39b7b9a2c6c80cf93eb09a5d585e1f734ebe7d1bdb732b8fcd0c945106ac55c6d64a236def0e1d803a18a2df5e27322a2452ce99a55d SHA512 564e7385728b15387cd44c06cf50c36342fe4c6f497d208ce3d611d1659023e95ff032b2609a786cd9610bd915f878d138eef47913f18cc56eaae0651eb6efe8
+DIST jsonschema-3.2.0.tar.gz 167226 BLAKE2B f89a8198f6b7b4dd56b0320ddecdd834423cbeaf49fbbd1563007da61004322b92e25856ecc17b4d02e2162b2359ec5d7601826fe42cfcb7683ae16cf2baeb39 SHA512 acbb4cec730a8cdab9f070593ed896064fbe082d464ec362adc952e4985e9eaa12ad0f2d55a04018ffdaf675e54037999a7219533dad6b84bf609f5dfe21bbab
diff --git a/dev-python/jsonschema/jsonschema-3.2.0.ebuild b/dev-python/jsonschema/jsonschema-3.2.0.ebuild
new file mode 100644
index 000000000000..8b7153a6d529
--- /dev/null
+++ b/dev-python/jsonschema/jsonschema-3.2.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
+
+inherit distutils-r1
+
+DESCRIPTION="An implementation of JSON-Schema validation for Python"
+HOMEPAGE="https://pypi.org/project/jsonschema/ https://github.com/Julian/jsonschema"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+BDEPEND="
+ dev-python/attrs[${PYTHON_USEDEP}]
+ dev-python/pyrsistent[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/importlib_metadata[${PYTHON_USEDEP}]
+ ' python{2_7,3_{5,6,7}} pypy{,3})
+ $(python_gen_cond_dep \
+ 'dev-python/functools32[${PYTHON_USEDEP}]' -2)
+ test? ( dev-python/twisted[${PYTHON_USEDEP}] )
+"
+
+RDEPEND="${BDEPEND}
+ dev-python/idna[${PYTHON_USEDEP}]
+ >=dev-python/jsonpointer-1.13[${PYTHON_USEDEP}]
+ dev-python/rfc3987[${PYTHON_USEDEP}]
+ dev-python/strict-rfc3339[${PYTHON_USEDEP}]
+ dev-python/webcolors[${PYTHON_USEDEP}]
+ dev-python/rfc3986-validator[${PYTHON_USEDEP}]
+ dev-python/rfc3339-validator[${PYTHON_USEDEP}]
+"
+
+RESTRICT="!test? ( test )"
+
+distutils_enable_tests unittest
+
+python_prepare_all() {
+ # avoid a setuptools_scm dependency
+ sed -i "s:use_scm_version=True:version='${PV}':" setup.py || die
+
+ distutils-r1_python_prepare_all
+}