summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-apps/help2man/Manifest1
-rw-r--r--sys-apps/help2man/help2man-1.47.16.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/sys-apps/help2man/Manifest b/sys-apps/help2man/Manifest
index 17503d824eb8..101f2af2346d 100644
--- a/sys-apps/help2man/Manifest
+++ b/sys-apps/help2man/Manifest
@@ -2,3 +2,4 @@ DIST help2man-1.47.10.tar.xz 202176 BLAKE2B 57c19072b1fb696b8ae1fc269d4c44672e69
DIST help2man-1.47.13.tar.xz 202480 BLAKE2B 0c9e854a29ab563b7bc86d4873b2669c82bbd9226d3940ddf60fcbf8bfc48197013c7cde5b55e47e6463d26e1b3512a24bb9591a77009f47992b2a3df9bde198 SHA512 7bf4c75a42c103dd8413a94505f383c6e2b215f9a4cc506e11935acc7f108caad01a5fa489ee157ebef5fa02299145592f65cc828fc016417af557382975d57a
DIST help2man-1.47.14.tar.xz 202732 BLAKE2B 73d84774618e44d77d609f1ac562065f651c5ba5ab13d700c8ccdd5abcfda229f89067babceb6fec327663fce744748419ee7204defdcfcc7b631b0720bf00fa SHA512 f3ff59e83e89ff0ed2bf863557c41f25ba79b0398f82cd0e7df459f3c3d2832a48047ff401a5556c3d7d722e48956393a4b70f61e79368a7621621e1834db862
DIST help2man-1.47.15.tar.xz 202776 BLAKE2B 3f06bc254fc8e0e8884d9b8bd63b53f23ea4f9a9e1d16f7f7f2ba83ee052f35a85489ffad7b59bb41277ef68b22caa35790513115d5af43fb09cc8d5cdf4ebb0 SHA512 2ab835610545f37eef2d77887371378decbac622196426a3444c5fb495596371d0151a92c79d3e3040e93acf3dbeefbc431dac1e76a370fdb5063b43192545ad
+DIST help2man-1.47.16.tar.xz 203036 BLAKE2B 8e06c2c2e90adfc2ab8345908516b15ae50b02a7a9554d5d9beee4373b71c131aeaa0c148b9a988c531bbfe2149c25069af56a79101a4248b6c1adfeb734a132 SHA512 b427e60a9e3d2e805caf1ae84c337b09c7ca6f92b7ff14771f946c4a1bf7adf177df99b9c1c223ad76df99756005ababf5b548ff8e08d4746702ff7f8150b544
diff --git a/sys-apps/help2man/help2man-1.47.16.ebuild b/sys-apps/help2man/help2man-1.47.16.ebuild
new file mode 100644
index 000000000000..79ed067d1855
--- /dev/null
+++ b/sys-apps/help2man/help2man-1.47.16.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="GNU utility to convert program --help output to a man page"
+HOMEPAGE="https://www.gnu.org/software/help2man/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="nls"
+
+RDEPEND="dev-lang/perl
+ nls? ( dev-perl/Locale-gettext )"
+DEPEND="${RDEPEND}"
+
+DOCS=( debian/changelog NEWS README THANKS ) #385753
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.46.1-linguas.patch
+)
+
+src_prepare() {
+ if [[ ${CHOST} == *-darwin* ]] ; then
+ sed -i \
+ -e 's/-shared/-bundle/' \
+ Makefile.in || die
+ fi
+ default
+}
+
+src_configure() {
+ # Disable gettext requirement as the release includes the gmo files #555018
+ local myeconfargs=(
+ ac_cv_path_MSGFMT=$(type -P false)
+ $(use_enable nls)
+ )
+ econf "${myeconfargs[@]}"
+}