summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ros/tf2_sensor_msgs/tf2_sensor_msgs-0.7.2.ebuild9
-rw-r--r--dev-ros/tf2_sensor_msgs/tf2_sensor_msgs-9999.ebuild11
2 files changed, 11 insertions, 9 deletions
diff --git a/dev-ros/tf2_sensor_msgs/tf2_sensor_msgs-0.7.2.ebuild b/dev-ros/tf2_sensor_msgs/tf2_sensor_msgs-0.7.2.ebuild
index 22bff365cb75..d948377cc829 100644
--- a/dev-ros/tf2_sensor_msgs/tf2_sensor_msgs-0.7.2.ebuild
+++ b/dev-ros/tf2_sensor_msgs/tf2_sensor_msgs-0.7.2.ebuild
@@ -1,11 +1,10 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
ROS_REPO_URI="https://github.com/ros/geometry2"
KEYWORDS="~amd64 ~arm"
ROS_SUBDIR=${PN}
-PYTHON_COMPAT=( python2_7 )
inherit ros-catkin
@@ -19,8 +18,10 @@ RDEPEND="
dev-ros/tf2
dev-ros/rospy[${PYTHON_USEDEP}]
dev-python/python_orocos_kdl[${PYTHON_USEDEP}]
- dev-ros/sensor_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP},${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
"
DEPEND="${RDEPEND}
test? ( dev-ros/rostest[${PYTHON_USEDEP}] )
- dev-ros/cmake_modules"
+ dev-ros/cmake_modules
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"
diff --git a/dev-ros/tf2_sensor_msgs/tf2_sensor_msgs-9999.ebuild b/dev-ros/tf2_sensor_msgs/tf2_sensor_msgs-9999.ebuild
index 9d28f70aecb0..d948377cc829 100644
--- a/dev-ros/tf2_sensor_msgs/tf2_sensor_msgs-9999.ebuild
+++ b/dev-ros/tf2_sensor_msgs/tf2_sensor_msgs-9999.ebuild
@@ -1,11 +1,10 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
ROS_REPO_URI="https://github.com/ros/geometry2"
KEYWORDS="~amd64 ~arm"
ROS_SUBDIR=${PN}
-PYTHON_COMPAT=( python2_7 )
inherit ros-catkin
@@ -19,8 +18,10 @@ RDEPEND="
dev-ros/tf2
dev-ros/rospy[${PYTHON_USEDEP}]
dev-python/python_orocos_kdl[${PYTHON_USEDEP}]
- dev-ros/sensor_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP},${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
"
DEPEND="${RDEPEND}
test? ( dev-ros/rostest[${PYTHON_USEDEP}] )
- dev-ros/cmake_modules"
+ dev-ros/cmake_modules
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"