summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-build/libtool/Manifest1
-rw-r--r--dev-build/libtool/libtool-2.5.3.ebuild151
-rw-r--r--dev-libs/libltdl/Manifest1
-rw-r--r--dev-libs/libltdl/libltdl-2.5.3.ebuild48
4 files changed, 201 insertions, 0 deletions
diff --git a/dev-build/libtool/Manifest b/dev-build/libtool/Manifest
index d6ef406bec42..77cc70dd8f4f 100644
--- a/dev-build/libtool/Manifest
+++ b/dev-build/libtool/Manifest
@@ -2,3 +2,4 @@ DIST libtool-2.4.7.tar.xz 1016040 BLAKE2B 5e022586337637dd634bd40578ad944bec6e3b
DIST libtool-2.5.0.tar.xz 1032148 BLAKE2B a166423dae1000eb0a8d17f3872ed55b3338444ac61f51752f43a5886bc22fd233e060c7f4c8c7fa093bf50e589f03b755c628199534ef7b8a41935e1bf9d887 SHA512 7b426fe9550a7899de93c372d2c355867be02f7bb39f2b1de06ff30cb34c81bf89759c835bdb23081cef60bfeb39b786ed90bac43e7300956fd8ee1f7dc0a609
DIST libtool-2.5.1.tar.xz 1043544 BLAKE2B ae1e45c9d56a94980549476ed5abb7d617491360ff23ce88da9e884630280004152a9f5a96267be710930f14917bf7b00ab212acd4c65ceba1e201d2f01809e0 SHA512 ac0a6a8570ff81099585f6c3bf5a8f94851457a068b808e505422276a22638b1912a81f94e185bc2f8661b7abe2f2b2482b1af2cf42307787cbbd71d1b1612da
DIST libtool-2.5.2.tar.xz 1046372 BLAKE2B 12e3d1f948f64031519ad5619573593b2518ec63cb8e3d69487a4b6104f5ee385c2123d3163c036fe10ca7214ba7558b6bd7fb56d22f1e249945a50091e18862 SHA512 cd6eb8ea470dd5bbfdfcfb06f31b36c84962f09c7155ca8175bc340b0a0289ca85dc9ea6e49c02e6876630913031739ef71dae231bc76c44f0c24e1be09d8cee
+DIST libtool-2.5.3.tar.xz 1050076 BLAKE2B e7bc3421d2273851f894583b879c897239bddaef00dc335176f00ce971d3c77e4d4304ae3b1d1b97d4b6b1b4fd9859ddc0eb5dcadac2e0de959b68cae973f726 SHA512 7a2b86716b2cbefcd45bda7f65af81fcb0aaa3dce96b09f417d6b94721a4dd9e72a9552862783d998ddf785e509315bb49f65c464dbc949d58e36f0960cf9b1b
diff --git a/dev-build/libtool/libtool-2.5.3.ebuild b/dev-build/libtool/libtool-2.5.3.ebuild
new file mode 100644
index 000000000000..2ede106e25c8
--- /dev/null
+++ b/dev-build/libtool/libtool-2.5.3.ebuild
@@ -0,0 +1,151 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Please bump with dev-libs/libltdl.
+
+# bug #225559
+LIBTOOLIZE="true"
+WANT_LIBTOOL="none"
+inherit autotools flag-o-matic prefix multiprocessing
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://git.savannah.gnu.org/git/libtool.git"
+ inherit git-r3
+elif false && ! [[ $(( $(ver_cut 2) % 2 )) -eq 0 ]] ; then
+ SRC_URI="https://alpha.gnu.org/gnu/${PN}/${P}.tar.xz"
+else
+ SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
+ #KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+fi
+
+DESCRIPTION="A shared library tool for developers"
+HOMEPAGE="https://www.gnu.org/software/libtool/"
+
+LICENSE="GPL-2"
+SLOT="2"
+IUSE="vanilla"
+
+# Pull in libltdl directly until we convert packages to the new dep.
+RDEPEND="
+ sys-devel/gnuconfig
+ >=dev-build/autoconf-2.69:*
+ >=dev-build/automake-1.13:*
+"
+DEPEND="${RDEPEND}"
+[[ ${PV} == *9999 ]] && BDEPEND="sys-apps/help2man"
+
+# Note that we have more patches in https://gitweb.gentoo.org/proj/elt-patches.git/
+# for package builds. The patches here are just those which are definitely fine
+# for the system-wide libtool installation as well.
+PATCHES=(
+ # bug #109105
+ "${FILESDIR}"/${PN}-2.4.3-use-linux-version-in-fbsd.patch
+ # bug #581314
+ "${FILESDIR}"/${PN}-2.4.6-ppc64le.patch
+
+ "${FILESDIR}"/${PN}-2.2.6a-darwin-module-bundle.patch
+ "${FILESDIR}"/${PN}-2.4.6-darwin-use-linux-version.patch
+)
+
+src_prepare() {
+ if [[ ${PV} == *9999 ]] ; then
+ eapply "${FILESDIR}"/${PN}-2.4.6-pthread.patch # bug #650876
+ ./bootstrap || die
+ else
+ PATCHES+=(
+ "${FILESDIR}"/${PN}-2.4.6-pthread_bootstrapped.patch # bug #650876
+ )
+ fi
+
+ # WARNING: File build-aux/ltmain.sh is read-only; trying to patch anyway
+ chmod +w build-aux/ltmain.sh || die
+
+ if use vanilla ; then
+ eapply_user
+ return 0
+ else
+ default
+ fi
+
+ if use prefix ; then
+ # seems that libtool has to know about EPREFIX a little bit
+ # better, since it fails to find prefix paths to search libs
+ # from, resulting in some packages building static only, since
+ # libtool is fooled into thinking that libraries are unavailable
+ # (argh...). This could also be fixed by making the gcc wrapper
+ # return the correct result for -print-search-dirs (doesn't
+ # include prefix dirs ...).
+ eapply "${FILESDIR}"/${PN}-2.2.10-eprefix.patch
+ eprefixify m4/libtool.m4
+ fi
+
+ pushd libltdl >/dev/null || die
+ AT_NOELIBTOOLIZE=yes eautoreconf
+ popd >/dev/null || die
+ AT_NOELIBTOOLIZE=yes eautoreconf
+
+ # Make sure timestamps don't trigger a rebuild of man pages. #556512
+ if [[ ${PV} != *9999 ]] ; then
+ touch doc/*.1 || die
+ export HELP2MAN=true
+ fi
+}
+
+src_configure() {
+ # the libtool script uses bash code in it and at configure time, tries
+ # to find a bash shell. if /bin/sh is bash, it uses that. this can
+ # cause problems for people who switch /bin/sh on the fly to other
+ # shells, so just force libtool to use /bin/bash all the time.
+ # Do not bother hardcoding the full path to sed.
+ # Just rely on $PATH. bug #574550
+ export CONFIG_SHELL="${EPREFIX}"/bin/bash
+ export ac_cv_path_SED="sed"
+ export ac_cv_path_EGREP="grep -E"
+ export ac_cv_path_EGREP_TRADITIONAL="grep -E"
+ export ac_cv_path_FGREP="grep -F"
+ export ac_cv_path_GREP="grep"
+ export ac_cv_path_lt_DD="dd"
+
+ local myeconfargs=(
+ # Split into dev-libs/libltdl
+ --disable-ltdl-install
+
+ # Tests break otherwise (when porting to EAPI 8)
+ # https://lists.gnu.org/archive/html/bug-libtool/2014-10/msg00013.html
+ --enable-static
+ )
+
+ [[ ${CHOST} == *-darwin* ]] && myeconfargs+=( "--program-prefix=g" )
+
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+src_test() {
+ (
+ # The testsuite is sensitive to warnings, expects static
+ # archives to really be archives (not compiler IR), etc.
+ strip-flags
+ filter-flags -fno-semantic-interposition
+ filter-flags '-Wstrict-aliasing=*' '-Werror=*'
+ filter-lto
+
+ emake -Onone check \
+ CFLAGS="${CFLAGS}" \
+ CXXFLAGS="${CXXFLAGS}" \
+ FFLAGS="${FFLAGS}" \
+ FCFLAGS="${FCFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ TESTSUITEFLAGS="--jobs=$(get_makeopts_jobs)"
+ )
+}
+
+src_install() {
+ default
+
+ local x
+ while read -d $'\0' -r x ; do
+ ln -sf "${EPREFIX}"/usr/share/gnuconfig/${x##*/} "${x}" || die
+ done < <(find "${ED}" '(' -name config.guess -o -name config.sub ')' -print0)
+}
diff --git a/dev-libs/libltdl/Manifest b/dev-libs/libltdl/Manifest
index d6ef406bec42..77cc70dd8f4f 100644
--- a/dev-libs/libltdl/Manifest
+++ b/dev-libs/libltdl/Manifest
@@ -2,3 +2,4 @@ DIST libtool-2.4.7.tar.xz 1016040 BLAKE2B 5e022586337637dd634bd40578ad944bec6e3b
DIST libtool-2.5.0.tar.xz 1032148 BLAKE2B a166423dae1000eb0a8d17f3872ed55b3338444ac61f51752f43a5886bc22fd233e060c7f4c8c7fa093bf50e589f03b755c628199534ef7b8a41935e1bf9d887 SHA512 7b426fe9550a7899de93c372d2c355867be02f7bb39f2b1de06ff30cb34c81bf89759c835bdb23081cef60bfeb39b786ed90bac43e7300956fd8ee1f7dc0a609
DIST libtool-2.5.1.tar.xz 1043544 BLAKE2B ae1e45c9d56a94980549476ed5abb7d617491360ff23ce88da9e884630280004152a9f5a96267be710930f14917bf7b00ab212acd4c65ceba1e201d2f01809e0 SHA512 ac0a6a8570ff81099585f6c3bf5a8f94851457a068b808e505422276a22638b1912a81f94e185bc2f8661b7abe2f2b2482b1af2cf42307787cbbd71d1b1612da
DIST libtool-2.5.2.tar.xz 1046372 BLAKE2B 12e3d1f948f64031519ad5619573593b2518ec63cb8e3d69487a4b6104f5ee385c2123d3163c036fe10ca7214ba7558b6bd7fb56d22f1e249945a50091e18862 SHA512 cd6eb8ea470dd5bbfdfcfb06f31b36c84962f09c7155ca8175bc340b0a0289ca85dc9ea6e49c02e6876630913031739ef71dae231bc76c44f0c24e1be09d8cee
+DIST libtool-2.5.3.tar.xz 1050076 BLAKE2B e7bc3421d2273851f894583b879c897239bddaef00dc335176f00ce971d3c77e4d4304ae3b1d1b97d4b6b1b4fd9859ddc0eb5dcadac2e0de959b68cae973f726 SHA512 7a2b86716b2cbefcd45bda7f65af81fcb0aaa3dce96b09f417d6b94721a4dd9e72a9552862783d998ddf785e509315bb49f65c464dbc949d58e36f0960cf9b1b
diff --git a/dev-libs/libltdl/libltdl-2.5.3.ebuild b/dev-libs/libltdl/libltdl-2.5.3.ebuild
new file mode 100644
index 000000000000..e6abc36daf5a
--- /dev/null
+++ b/dev-libs/libltdl/libltdl-2.5.3.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Please bump with dev-build/libtool.
+
+inherit multilib-minimal flag-o-matic
+
+MY_P="libtool-${PV}"
+
+DESCRIPTION="A shared library tool for developers"
+HOMEPAGE="https://www.gnu.org/software/libtool/"
+if false && ! [[ $(( $(ver_cut 2) % 2 )) -eq 0 ]] ; then
+ SRC_URI="https://alpha.gnu.org/gnu/libtool/${MY_P}.tar.xz"
+else
+ SRC_URI="mirror://gnu/libtool/${MY_P}.tar.xz"
+ #KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+fi
+
+S="${WORKDIR}"/${MY_P}/libltdl
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="static-libs"
+# libltdl doesn't have a testsuite. Don't bother trying.
+RESTRICT="test"
+
+BDEPEND="app-arch/xz-utils"
+
+multilib_src_configure() {
+ # bug #907427
+ filter-lto
+
+ append-lfs-flags
+ ECONF_SOURCE="${S}" \
+ econf \
+ --enable-ltdl-install \
+ $(use_enable static-libs static)
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" install
+
+ # While the libltdl.la file is not used directly, the m4 ltdl logic
+ # keys off of its existence when searching for ltdl support. # bug #293921
+ #use static-libs || find "${D}" -name libltdl.la -delete
+}