summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/pylint/files/pylint-2.3.1-sphinx-theme.patch14
-rw-r--r--dev-python/pylint/pylint-2.3.1.ebuild4
2 files changed, 18 insertions, 0 deletions
diff --git a/dev-python/pylint/files/pylint-2.3.1-sphinx-theme.patch b/dev-python/pylint/files/pylint-2.3.1-sphinx-theme.patch
new file mode 100644
index 000000000000..9353a90957f3
--- /dev/null
+++ b/dev-python/pylint/files/pylint-2.3.1-sphinx-theme.patch
@@ -0,0 +1,14 @@
+It's not worth introducing a new dependency for a mere sphinx theme...
+diff --git a/doc/conf.py b/doc/conf.py
+index ada9ec49..2bd66593 100644
+--- a/doc/conf.py
++++ b/doc/conf.py
+@@ -99,7 +99,7 @@ pygments_style = 'sphinx'
+
+ # The theme to use for HTML and HTML Help pages. See the documentation for
+ # a list of builtin themes.
+-html_theme = 'python_docs_theme'
++html_theme = 'nature'
+
+ # Theme options are theme-specific and customize the look and feel of a theme
+ # further. For a list of options available for each theme, see the
diff --git a/dev-python/pylint/pylint-2.3.1.ebuild b/dev-python/pylint/pylint-2.3.1.ebuild
index db307294d859..a9f24be3a26e 100644
--- a/dev-python/pylint/pylint-2.3.1.ebuild
+++ b/dev-python/pylint/pylint-2.3.1.ebuild
@@ -31,6 +31,10 @@ DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]
)"
+PATCHES=(
+ "${FILESDIR}/${PN}-2.3.1-sphinx-theme.patch"
+)
+
python_compile_all() {
# selection of straight html triggers a trivial annoying bug, we skirt it
use doc && PYTHONPATH="${S}" emake -e -C doc singlehtml