summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-lua/luaevent/luaevent-0.4.6-r100.ebuild60
-rw-r--r--profiles/package.mask1
2 files changed, 61 insertions, 0 deletions
diff --git a/dev-lua/luaevent/luaevent-0.4.6-r100.ebuild b/dev-lua/luaevent/luaevent-0.4.6-r100.ebuild
new file mode 100644
index 000000000000..b5d3f6052466
--- /dev/null
+++ b/dev-lua/luaevent/luaevent-0.4.6-r100.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+LUA_COMPAT=( lua5-{1..3} luajit )
+
+inherit lua toolchain-funcs
+
+DESCRIPTION="Binding of libevent for Lua"
+HOMEPAGE="http://luaforge.net/projects/luaevent"
+SRC_URI="https://github.com/harningt/luaevent/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="dev-libs/libevent:0="
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+
+ local mysedargs=(
+ -e "'s/CFLAGS =/CFLAGS +=/'"
+ -e "'s/LDFLAGS =/LDFLAGS +=/'"
+ -e "'s:-I\$(LUA_INC_DIR):\$(LUA_INC_DIR):'"
+ -i Makefile
+ )
+
+ eval sed ${mysedargs[@]} || die
+}
+
+lua_src_compile() {
+ tc-export CC
+
+ emake LUA_INC_DIR="$(lua_get_CFLAGS)"
+}
+
+src_compile() {
+ lua_foreach_impl lua_src_compile
+}
+
+lua_src_install() {
+ local myemakeargs=(
+ DESTDIR="${ED}"
+ INSTALL_DIR_BIN="$(lua_get_cmod_dir)"
+ INSTALL_DIR_LUA="$(lua_get_lmod_dir)"
+ LUA_INC_DIR="$(lua_get_CFLAGS)"
+ )
+
+ emake ${myemakeargs[@]} install
+}
+
+src_install() {
+ lua_foreach_impl lua_src_install
+}
diff --git a/profiles/package.mask b/profiles/package.mask
index 103cac3f048c..423c356d83dd 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -347,6 +347,7 @@ dev-lua/luacrypto
>=app-misc/worker-3.8.3-r100
=dev-libs/efl-1.25.1-r10
>=dev-lua/lua-zlib-1.2-r100
+>=dev-lua/luaevent-0.4.6-r100
>=dev-lua/luv-1.32.0.0-r100
>=dev-lua/luadbi-0.7.2-r100
>=dev-lua/lutok-0.4-r10