summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/hiredis/Manifest1
-rw-r--r--dev-python/hiredis/hiredis-2.2.3.ebuild45
2 files changed, 0 insertions, 46 deletions
diff --git a/dev-python/hiredis/Manifest b/dev-python/hiredis/Manifest
index a3fb3e85b483..247154493dad 100644
--- a/dev-python/hiredis/Manifest
+++ b/dev-python/hiredis/Manifest
@@ -1,2 +1 @@
-DIST hiredis-py-2.2.3.gh.tar.gz 18214 BLAKE2B cdac5e9790c88657c75be721c4dbc91174a0eb38cdd790076b3ec1f009d43c7aef300bfa7381a10061749cb3bec02d4a488e732f550bea4c62893aabfc0c3222 SHA512 e85032869b6bbbc30f991d83d67a710c04998645517b1ddcfd801ff37bd28f0576a5bdc2986f3526f72da8448986714a79b42a0ab1a5cc6b6bab24f3d98fdce9
DIST hiredis-py-2.3.0.gh.tar.gz 18179 BLAKE2B d87460d3ea75f81f9017a837f44281e7733104e5772ed53dc9471eb18a38b0a9e1298ddb3c78b8d3c5ab7a8e1f71e966bbaa10e06969321e7940b8965ac56b2f SHA512 4e72f71719e9616913e5ed6dc9d2e01ad91d44715231c1eda1a1c6570d75c00be634093712444fc9a86bc6843278ab34c33c7362ffd5b8171f4ff775aaf0c4bd
diff --git a/dev-python/hiredis/hiredis-2.2.3.ebuild b/dev-python/hiredis/hiredis-2.2.3.ebuild
deleted file mode 100644
index 6a9f11837121..000000000000
--- a/dev-python/hiredis/hiredis-2.2.3.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_EXT=1
-DISTUTILS_USE_PEP517="setuptools"
-PYTHON_COMPAT=( python3_{10..12} pypy3 )
-
-inherit distutils-r1
-
-MY_P=hiredis-py-${PV}
-DESCRIPTION="Python extension that wraps hiredis"
-HOMEPAGE="
- https://github.com/redis/hiredis-py/
- https://pypi.org/project/hiredis/
-"
-SRC_URI="
- https://github.com/redis/hiredis-py/archive/v${PV}.tar.gz
- -> ${MY_P}.gh.tar.gz
-"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~ppc ~ppc64 ~riscv ~sparc x86"
-
-DEPEND="
- >=dev-libs/hiredis-1.0.0:=
-"
-RDEPEND="
- ${DEPEND}
-"
-
-PATCHES=(
- "${FILESDIR}"/hiredis-2.2.2-system-libs.patch
-)
-
-distutils_enable_tests pytest
-
-python_test() {
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- rm -rf hiredis || die
- epytest
-}