summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-fps/quake1-teamfortress/quake1-teamfortress-2.9-r1.ebuild (renamed from games-fps/quake1-teamfortress/quake1-teamfortress-2.9.ebuild)28
1 files changed, 13 insertions, 15 deletions
diff --git a/games-fps/quake1-teamfortress/quake1-teamfortress-2.9.ebuild b/games-fps/quake1-teamfortress/quake1-teamfortress-2.9-r1.ebuild
index 19e52511fc51..92573dc42b6e 100644
--- a/games-fps/quake1-teamfortress/quake1-teamfortress-2.9.ebuild
+++ b/games-fps/quake1-teamfortress/quake1-teamfortress-2.9-r1.ebuild
@@ -1,37 +1,35 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit eutils games
+EAPI=7
+
+inherit edos2unix
DESCRIPTION="The classic Team Fortress Quake World mod"
HOMEPAGE="http://www.planetfortress.com/teamfortress/"
SRC_URI="mirror://gentoo/tf28.zip
mirror://gentoo/tf29qw.zip"
+S="${WORKDIR}"
LICENSE="quake1-teamfortress"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND=""
-DEPEND="app-arch/unzip"
-S=${WORKDIR}
+BDEPEND="app-arch/unzip"
src_unpack() {
- echo ">>> Unpacking tf28.zip to ${PWD}"
+ elog "Unpacking tf28.zip to ${PWD}"
unzip -qoL "${DISTDIR}"/tf28.zip || die "unpacking tf28.zip failed"
- cd fortress
- echo ">>> Unpacking tf29qw.zip to ${PWD}"
+
+ cd fortress || die
+ elog "Unpacking tf29qw.zip to ${PWD}"
unzip -qoL "${DISTDIR}"/tf29qw.zip || die "unpacking tf29qw.zip failed"
- edos2unix $(find . -name '*.txt' -o -name '*.cfg')
- mv server.cfg server.example.cfg
+ edos2unix $(find . -name '*.txt' -o -name '*.cfg' || die)
+ mv server.cfg server.example.cfg || die
}
src_install() {
- insinto "${GAMES_DATADIR}/quake1"
+ insinto /usr/share/quake1
doins -r *
- prepgamesdirs
}