summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-biology/maqview/files/maqview-0.2.5-gcc14-build-fix.patch12
-rw-r--r--sci-biology/maqview/maqview-0.2.5-r5.ebuild (renamed from sci-biology/maqview/maqview-0.2.5-r4.ebuild)5
2 files changed, 15 insertions, 2 deletions
diff --git a/sci-biology/maqview/files/maqview-0.2.5-gcc14-build-fix.patch b/sci-biology/maqview/files/maqview-0.2.5-gcc14-build-fix.patch
new file mode 100644
index 000000000000..8f973f38a272
--- /dev/null
+++ b/sci-biology/maqview/files/maqview-0.2.5-gcc14-build-fix.patch
@@ -0,0 +1,12 @@
+Bug: https://bugs.gentoo.org/930767
+--- a/socket_view.c
++++ b/socket_view.c
+@@ -267,7 +267,7 @@ int service_core(ViewServer *server, int sock){
+
+ int runViewServer(ViewServer *server){
+ int i, sock, state;
+- size_t size;
++ socklen_t size;
+ fd_set active_fd_set, read_fd_set;
+ struct timeval timeout;
+ struct sockaddr_in clientname;
diff --git a/sci-biology/maqview/maqview-0.2.5-r4.ebuild b/sci-biology/maqview/maqview-0.2.5-r5.ebuild
index 80cf5c0f9410..479d0c01af91 100644
--- a/sci-biology/maqview/maqview-0.2.5-r4.ebuild
+++ b/sci-biology/maqview/maqview-0.2.5-r5.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -6,7 +6,7 @@ EAPI=8
inherit autotools
DESCRIPTION="GUI for sci-biology/maq, a short read mapping assembler"
-HOMEPAGE="http://maq.sourceforge.net/"
+HOMEPAGE="https://maq.sourceforge.net/"
SRC_URI="mirror://sourceforge/maq/${P}.tar.gz"
S="${WORKDIR}/${PN}"
@@ -24,6 +24,7 @@ PATCHES=(
"${FILESDIR}"/${PV}-ldflags.patch
"${FILESDIR}"/${PV}-zlib.patch
"${FILESDIR}"/${P}-gcc4.7.patch
+ "${FILESDIR}"/${P}-gcc14-build-fix.patch
)
src_prepare() {