summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-libs/libinput/Manifest1
-rw-r--r--dev-libs/libinput/libinput-1.6.2.ebuild56
-rw-r--r--dev-libs/libuv/Manifest1
-rw-r--r--dev-libs/libuv/libuv-1.11.0.ebuild46
-rw-r--r--eclass/mysql-multilib-r1.eclass2
-rw-r--r--eclass/mysql-multilib.eclass10
-rw-r--r--eclass/mysql-v2.eclass2
-rw-r--r--net-libs/nodejs/Manifest2
-rw-r--r--net-libs/nodejs/nodejs-6.10.0.ebuild194
-rw-r--r--net-libs/nodejs/nodejs-7.6.0.ebuild195
-rw-r--r--net-misc/putty/Manifest1
-rw-r--r--net-misc/putty/putty-0.68.ebuild91
-rw-r--r--net-misc/putty/putty-9999.ebuild11
-rw-r--r--profiles/arch/x86/use.stable.mask4
14 files changed, 602 insertions, 14 deletions
diff --git a/dev-libs/libinput/Manifest b/dev-libs/libinput/Manifest
index 9378439bd9e4..8fa57546110e 100644
--- a/dev-libs/libinput/Manifest
+++ b/dev-libs/libinput/Manifest
@@ -2,3 +2,4 @@ DIST libinput-1.4.2.tar.xz 900776 SHA256 8c38826a785594811bef6a9daadbfa2e172e3f0
DIST libinput-1.5.4.tar.xz 927448 SHA256 6f9ad1ede468bd54ec4469b8a4eb93a6f62f7fe6480c7a43e36c5d58cc2822b7 SHA512 114f436806fd27ece2b19577eefd3f6299cc88612f8437fd07ba1862c0bf4347ac5cc09fad9f798a5e242abd176cfb271fa52af04b0ef88da3210a96fd57a086 WHIRLPOOL d7c2ffd8212c4808641b65f553ea6c1553188a30279f8e3491767a8ba159d42dbd30a0cebc3a727542a83cf216c17d1b5f1504dc8fbb4f7b5664aac35b8032dc
DIST libinput-1.6.0.tar.xz 927656 SHA256 b7534f518d735c643aedca2fb4694683dfddc8d0600cfb628c87a18e65255832 SHA512 0e52f70fc5b1aa1e9c0621770ba2530f1652611aff1a557ac8083559e22293942d7c468f9bafe9e97e4f71e71df6f3828f9949d8897bea26982045340e3edc92 WHIRLPOOL b41858d727eb27dbcd4025212731fe93e3970f7d36e8654bc5b121b3a6a3d6c1ca6117750d02b54db908d118d1b84a0eec5581b88a517635ffece5fb1378dae2
DIST libinput-1.6.1.tar.xz 926988 SHA256 9d816f13eee63bcca0e9c3bb652c52ab55f39be4d1b90b54e4bfd1dc92ef55a8 SHA512 b18fdbfa58c14d6a5d183da3c1097d31f7dd9cce41ea69ddfa0bbd1bf8572aaa8e1ecaacdc30e3cc5e21cd320ea106ec86800a24e8f571bce61a02ddc7d43511 WHIRLPOOL bf7ca3c5968827fd73592f56d1e3a1c7897b1bd12fc431e98550ad36aa147f4c39ccb41092ef84d0cb739960c53bfa1b3a62cf7f30fdf7a77da90ba91e6db96e
+DIST libinput-1.6.2.tar.xz 929180 SHA256 96fc0e0b24a96042b16e561201979dfa4a3f00a642538195c62f72b79f4084fa SHA512 f1e1436ec4259ebddf93a50fe4d39a52713efd246a39a072b44bf296a413bdadbb789d6a4f0107ed3eb37afe34a37a43c9e75dcf814462385011eff2d3f42db7 WHIRLPOOL e9ed43ab8efb5b984a8c431e82880a691f7c94577a7a3789cf1e52c82f8aeee70d56474895a349f286f4d7fc845be8302ca7432b8e4801a6233fbe96b0078db3
diff --git a/dev-libs/libinput/libinput-1.6.2.ebuild b/dev-libs/libinput/libinput-1.6.2.ebuild
new file mode 100644
index 000000000000..e60d639e4f92
--- /dev/null
+++ b/dev-libs/libinput/libinput-1.6.2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit udev
+
+DESCRIPTION="Library to handle input devices in Wayland"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/libinput/"
+SRC_URI="https://www.freedesktop.org/software/${PN}/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0/10"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="input_devices_wacom test"
+# Tests require write access to udev rules directory which is a no-no for live system.
+# Other tests are just about logs, exported symbols and autotest of the test library.
+RESTRICT="test"
+
+RDEPEND="
+ input_devices_wacom? ( >=dev-libs/libwacom-0.20 )
+ >=dev-libs/libevdev-0.4
+ >=sys-libs/mtdev-1.1
+ virtual/libudev
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+# test? (
+# >=dev-libs/check-0.9.10
+# dev-util/valgrind
+# sys-libs/libunwind )
+
+src_prepare() {
+ default
+ # Doc handling in kinda strange but everything
+ # is available in the tarball already.
+ sed -e 's/^\(SUBDIRS =.*\)doc\(.*\)$/\1\2/' \
+ -i Makefile.am Makefile.in || die
+}
+
+src_configure() {
+ # gui can be built but will not be installed
+ # building documentation silently fails with graphviz syntax errors
+ econf \
+ --disable-documentation \
+ --disable-event-gui \
+ $(use_enable input_devices_wacom libwacom) \
+ $(use_enable test tests) \
+ --with-udev-dir="$(get_udevdir)"
+}
+
+src_install() {
+ emake install DESTDIR="${D}"
+ dodoc -r doc/html
+ find "${ED}" \( -name "*.a" -o -name "*.la" \) -delete || die
+}
diff --git a/dev-libs/libuv/Manifest b/dev-libs/libuv/Manifest
index 32c1bdb2e288..7a03e7213a96 100644
--- a/dev-libs/libuv/Manifest
+++ b/dev-libs/libuv/Manifest
@@ -1 +1,2 @@
DIST libuv-1.10.2.tar.gz 1074184 SHA256 2d740a2adea0f1a19058626f55a076ac41a4ac1f95d4e57cae0c8a634a6cd63b SHA512 5d9a7c483c3504e10e17c29297d72dee1572dc657d261229cc68efe63cb3abb59f7e7768885ce3eb06f22691e73323158c06dcce29000c81e35ff9888853f080 WHIRLPOOL 19948da35acc1252de9633dbd30cb951eb07bf51c0f63b65d8716b87d9cbf7184814e1e44363e40bc8e55976256812eaef0583f0ab2f0d3a6ae0068e7349f034
+DIST libuv-1.11.0.tar.gz 1083067 SHA256 6ec7eec6ecc24b1a8ffedebedb2fe9313fffb5410de89aaf784dd01080411c7a SHA512 fb0415d62a32cfc658bad6c849263ac236d27e9188fac603467173a5ae34fb3ad3e3bfd333e543ebd98b4fd59e0a58a93275e830c4365c058b62bb0c2c802732 WHIRLPOOL d32f729872be6fd5dcdcb95dfc613a4389789fea1bf79614c72470d35e7bd7e48b7804485eb4fc0e6c577d4b00bcdbd86c243b7a103056b5b73aa25d5cbc3adb
diff --git a/dev-libs/libuv/libuv-1.11.0.ebuild b/dev-libs/libuv/libuv-1.11.0.ebuild
new file mode 100644
index 000000000000..04db667401a2
--- /dev/null
+++ b/dev-libs/libuv/libuv-1.11.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools eutils multilib-minimal
+
+DESCRIPTION="Cross-platform asychronous I/O"
+HOMEPAGE="https://github.com/libuv/libuv"
+SRC_URI="https://github.com/libuv/libuv/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD BSD-2 ISC MIT"
+SLOT="0/1"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="static-libs"
+RESTRICT="test"
+
+DEPEND="sys-devel/libtool
+ virtual/pkgconfig[${MULTILIB_USEDEP}]"
+
+src_prepare() {
+ default
+
+ echo "m4_define([UV_EXTRA_AUTOMAKE_FLAGS], [serial-tests])" \
+ > m4/libuv-extra-automake-flags.m4 || die
+
+ eautoreconf
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ cc_cv_cflags__g=no \
+ $(use_enable static-libs static)
+}
+
+multilib_src_test() {
+ mkdir "${BUILD_DIR}"/test || die
+ cp -pPR "${S}"/test/fixtures "${BUILD_DIR}"/test/fixtures || die
+ default
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ prune_libtool_files
+}
diff --git a/eclass/mysql-multilib-r1.eclass b/eclass/mysql-multilib-r1.eclass
index b787542745d7..38fcc7c0ecf8 100644
--- a/eclass/mysql-multilib-r1.eclass
+++ b/eclass/mysql-multilib-r1.eclass
@@ -785,7 +785,7 @@ mysql-multilib-r1_pkg_config() {
mysql_init_vars
[[ -z "${MY_DATADIR}" ]] && die "Sorry, unable to find MY_DATADIR"
- if ! built_with_use ${CATEGORY}/${PN} server ; then
+ if [[ ! -x "${EROOT}/usr/sbin/mysqld" ]] ; then
die "Minimal builds do NOT include the MySQL server"
fi
diff --git a/eclass/mysql-multilib.eclass b/eclass/mysql-multilib.eclass
index b2e7dffa09ad..b19b0fa522e3 100644
--- a/eclass/mysql-multilib.eclass
+++ b/eclass/mysql-multilib.eclass
@@ -943,14 +943,8 @@ mysql-multilib_pkg_config() {
mysql_init_vars
[[ -z "${MY_DATADIR}" ]] && die "Sorry, unable to find MY_DATADIR"
- if [[ ${HAS_TOOLS_PATCH} ]] ; then
- if ! built_with_use ${CATEGORY}/${PN} server ; then
- die "Minimal builds do NOT include the MySQL server"
- fi
- else
- if built_with_use ${CATEGORY}/${PN} minimal ; then
- die "Minimal builds do NOT include the MySQL server"
- fi
+ if [[ ! -x "${EROOT}/usr/sbin/mysqld" ]] ; then
+ die "Minimal builds do NOT include the MySQL server"
fi
if [[ ( -n "${MY_DATADIR}" ) && ( "${MY_DATADIR}" != "${old_MY_DATADIR}" ) ]]; then
diff --git a/eclass/mysql-v2.eclass b/eclass/mysql-v2.eclass
index 556d37eba6ef..ddb28654b498 100644
--- a/eclass/mysql-v2.eclass
+++ b/eclass/mysql-v2.eclass
@@ -699,7 +699,7 @@ mysql-v2_pkg_config() {
[[ -z "${MY_DATADIR}" ]] && die "Sorry, unable to find MY_DATADIR"
- if built_with_use ${CATEGORY}/${PN} minimal ; then
+ if [[ ! -x "${EROOT}/usr/sbin/mysqld" ]] ; then
die "Minimal builds do NOT include the MySQL server"
fi
diff --git a/net-libs/nodejs/Manifest b/net-libs/nodejs/Manifest
index 6f18e0ba632c..2e1fd739ee5d 100644
--- a/net-libs/nodejs/Manifest
+++ b/net-libs/nodejs/Manifest
@@ -2,6 +2,7 @@ DIST node-v0.12.10.tar.gz 19572955 SHA256 edbd3710512ec7518a3de4cabf9bfee6d12f27
DIST node-v0.12.17.tar.gz 19938029 SHA256 ddea5e253812f167608fbdda6ff29ffc30dc6f669cf2f6e4249938d28b9cd44d SHA512 86c22b17f57018083b07096beeca10e6dfa7569b3d1a25a3b12dd82796db3c9536e6136e0dd0ff62b4de116413f3722b36ce396faa46d8640f80ab09ccfcbca7 WHIRLPOOL 5fba1f95de0a7dbda7e7649bc0f8553cd8595eb87cd27062efbdc59a54673e7e1e6f80191abede683a686043a81d82b76e141aa765b98e3dc39e015aca98e41f
DIST node-v4.6.0.tar.xz 13295184 SHA256 42910dbd34e49bfc40580e06753947c30d31101455a38e9f0343a23d67c0c694 SHA512 d3e79f7e361af888955f311818c0d0401a29fd99a86fa125924b3f7891f209f84f4f662dba071c9bdbb3d11a3b3097274d95bdc4a51143a2e816400ff71b041f WHIRLPOOL 011d1de801b87be413b7838e0b0ea216909bbe4a2d88a5045536d65d3b85cca64f9e94923859a65d8b6ed1fcbbf34a9463c7a8fc036ba1f0b902f8b4a07b83ac
DIST node-v4.6.1.tar.xz 13295568 SHA256 fe2a85df8758001878abb5bbaf17a6b6cdc12b3e465b1d3bace83b37fdf0345a SHA512 4eb2acbe13ee2373922420e3238be63d2108dacba640438bddbdea12ec2de9c655f33db611e4c0654b66bf4fdb844a7b6554a823aac73171b17599096856abdb WHIRLPOOL a6d21cce7ab8c430528682f78a6e6492f753c87949b7b1bdc15dc02911559cd89deb45329c2ba32da57b776dd4feaabec8a3e7a59a78094cfb079261b6475c76
+DIST node-v6.10.0.tar.xz 15745784 SHA256 f65d5d4b7253ee29f3ba4edabd3473845075e43569bceea4267e7bf3e00ebb96 SHA512 535f5caf028b7dd132d869ac9cb71951983ddde1de27ef1f960b7b55545c22fee0d1a5fec12de52c816d99f4c727732798e20771a339ae7df630b3833cbcde9e WHIRLPOOL 1b8c2435f71c61d322ff6b543c7afff84588a6371530e5a878068149d17c09fa673799449cf701d36e864fe3740c5108d45ca27198215794fa42934fe5bdb219
DIST node-v6.9.4.tar.xz 15519264 SHA256 c51d7c61db40455d57428abcadc7eb0f0a08a8878cb1d8ea3c1e211c54532c35 SHA512 86d3e2889031c2b50c021bd3fd63194c2c22c44291d51dff1b5e1652b01853c09d2880c2f58fdad062e3e2a3f637a3f0d78dac66b835b676790cf272e64f8dce WHIRLPOOL d1bcf488ed1aae7959303b988c9467fc5d0930166c7bfe0e441392763e19f788496971c07560a9f62586bbb2be7ce741ece8346140d665d29593b9b8f649b002
DIST node-v6.9.5.tar.xz 15521472 SHA256 d7fed1a354b29503f3e176d7fdb90b1a9de248e0ce9b3eb56cc26bb1f3d5b6b3 SHA512 d13cebccf0d0b422c735a5e3981fa430f6537c2bdb4569c9fe256c07d1e833524b60645746fe5a7957c7e49ca4df434aa4ed72ee392b14d1cf9693c49e27b063 WHIRLPOOL 2c08015b06d0b1bc34fb1869f7c2b327b42aff61ff205ec2e8db646a60633bfdaa4ea11da0dbf5832640db0d0bb03e298e1c6f0a38b444139c0042984a1606b1
DIST node-v7.0.0.tar.xz 16296516 SHA256 e16c3c76c2d6756bbfd711189cbdaf5676049b443e6817007bb537f243ca899a SHA512 775b3a786ca6975b1913f048ea9a969e674d6d8ca58094557fe21e7c821e10f8d4bd8d484ca3617b553587449020ecf1d3d8c8d912c46725bab7f7561c2fbdda WHIRLPOOL e9068c49181151ebcf1dd75f5ecb8ee87b89abc7695cb9158bbfa701de9344bc5c2b59b5363d5be4a65bb4df1c37b8f6285b6c584f43ad3f933628a7e175ff1f
@@ -9,3 +10,4 @@ DIST node-v7.2.0.tar.xz 16407484 SHA256 486d4db7ef659521ad2fafefca877638da07bef6
DIST node-v7.3.0.tar.xz 16434356 SHA256 dde8f6c800ac8049016d86b91ba5aeb6ddb35cb747cd74756dc05cf9fbe16b81 SHA512 97961c68d097d71ff5030e04526935921af498acba7e9081cd8699c624d4df9b9ce9992c29fe224387a26a53727dcc2181b63841e75e69808295b259bd6da1f1 WHIRLPOOL 7ec8be0b169e3361896296cfe08b9fda8a0e467c479f6305ec255fc26ad1b346bd05b7397f0a18910d5d4999016db3d406914db4b9e19e5f85dfa5a52ac7f245
DIST node-v7.4.0.tar.xz 16611356 SHA256 9f15b916f8677ec1615c46bdd6d2208ed1b24fad26384f9ac249f5b09d31c32b SHA512 50167c85cae41720412b8de627f7f6a9b351e80823aafe23d96bc8d37c96a25ad635abc46af481d1817cec89bf0bec0e059964434d585f59ad22f99af820c67d WHIRLPOOL a56dc105ef768f044f68181b186d7e907dbdc3238006f28cb677d62ced69f7430a02a2a2b9d026895dafd3f185aa50dec221a6ca76de37b84f8792ea8ae97a58
DIST node-v7.5.0.tar.xz 16539384 SHA256 f99ee74647fe223eb03f2dd1dc6acdc14d9a881621376c848236c8d2ac8afd03 SHA512 ae903445d27b487200eaf95ef12ac56d84ae76efa0195a533bede33d9248489b3fd71db064969b3ea8505a5a013cce67787350d7633a6e57ea05d5fd33582ac8 WHIRLPOOL 03f1f7c1e54d620650705ba9fe6f4f556dcdbb8269f2db4192d793feee7c85bd07d7be3ad331b8442b438930387a1036d2d772262837c3b659aa19309d041c62
+DIST node-v7.6.0.tar.xz 16635292 SHA256 6ff9042696fff0b49647f5864e71cb495e554e4f66e61443494210f5e16ab4a9 SHA512 17bf7353f19a6bba659b8f238b83333241e721363b22adb01aa9dce421dc47826e47edd0ed2f7eee0209146ef322b2ca9fe6fe2733140c3e79c1498bc7c9b166 WHIRLPOOL 803efc7de3d18cd86a6b45675b01da79c271a8c36792fb875c307e224f8575e6c47d35816c56136ecd15f05029febae46faa6b020188c96e14269f2075f878e3
diff --git a/net-libs/nodejs/nodejs-6.10.0.ebuild b/net-libs/nodejs/nodejs-6.10.0.ebuild
new file mode 100644
index 000000000000..ec13dedcfa8e
--- /dev/null
+++ b/net-libs/nodejs/nodejs-6.10.0.ebuild
@@ -0,0 +1,194 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+RESTRICT="test"
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="threads"
+
+inherit bash-completion-r1 eutils flag-o-matic pax-utils python-single-r1 toolchain-funcs
+
+DESCRIPTION="A JavaScript runtime built on Chrome's V8 JavaScript engine"
+HOMEPAGE="https://nodejs.org/"
+SRC_URI="https://nodejs.org/dist/v${PV}/node-v${PV}.tar.xz"
+
+LICENSE="Apache-1.1 Apache-2.0 BSD BSD-2 MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~amd64-linux ~x64-macos"
+IUSE="cpu_flags_x86_sse2 debug doc icu +npm +snapshot +ssl test"
+
+RDEPEND="icu? ( >=dev-libs/icu-56:= )
+ npm? ( ${PYTHON_DEPS} )
+ >=net-libs/http-parser-2.6.2:=
+ >=dev-libs/libuv-1.9.0:=
+ >=dev-libs/openssl-1.0.2g:0=[-bindist]
+ sys-libs/zlib"
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ test? ( net-misc/curl )"
+
+S="${WORKDIR}/node-v${PV}"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+PATCHES=(
+ "${FILESDIR}"/gentoo-global-npm-config.patch
+)
+
+pkg_pretend() {
+ (use x86 && ! use cpu_flags_x86_sse2) && \
+ die "Your CPU doesn't support the required SSE2 instruction."
+
+ ( [[ ${MERGE_TYPE} != "binary" ]] && ! test-flag-CXX -std=c++11 ) && \
+ die "Your compiler doesn't support C++11. Use GCC 4.8, Clang 3.3 or newer."
+}
+
+src_prepare() {
+ tc-export CC CXX PKG_CONFIG
+ export V=1
+ export BUILDTYPE=Release
+
+ # fix compilation on Darwin
+ # https://code.google.com/p/gyp/issues/detail?id=260
+ sed -i -e "/append('-arch/d" tools/gyp/pylib/gyp/xcode_emulation.py || die
+
+ # make sure we use python2.* while using gyp
+ sed -i -e "s/python/${EPYTHON}/" deps/npm/node_modules/node-gyp/gyp/gyp || die
+ sed -i -e "s/|| 'python'/|| '${EPYTHON}'/" deps/npm/node_modules/node-gyp/lib/configure.js || die
+
+ # less verbose install output (stating the same as portage, basically)
+ sed -i -e "/print/d" tools/install.py || die
+
+ # proper libdir, hat tip @ryanpcmcquen https://github.com/iojs/io.js/issues/504
+ local LIBDIR=$(get_libdir)
+ sed -i -e "s|lib/|${LIBDIR}/|g" tools/install.py || die
+ sed -i -e "s/'lib'/'${LIBDIR}'/" lib/module.js || die
+ sed -i -e "s|\"lib\"|\"${LIBDIR}\"|" deps/npm/lib/npm.js || die
+
+ # Avoid writing a depfile, not useful
+ sed -i -e "/DEPFLAGS =/d" tools/gyp/pylib/gyp/generator/make.py || die
+
+ # Avoid a test that I've only been able to reproduce from emerge. It doesnt
+ # seem sandbox related either (invoking it from a sandbox works fine).
+ # The issue is that no stdin handle is openened when asked for one.
+ # It doesn't really belong upstream , so it'll just be removed until someone
+ # with more gentoo-knowledge than me (jbergstroem) figures it out.
+ rm test/parallel/test-stdout-close-unref.js || die
+
+ # debug builds. change install path, remove optimisations and override buildtype
+ if use debug; then
+ sed -i -e "s|out/Release/|out/Debug/|g" tools/install.py || die
+ BUILDTYPE=Debug
+ fi
+
+ default
+}
+
+src_configure() {
+ local myarch=""
+ local myconf=( --shared-openssl --shared-libuv --shared-http-parser --shared-zlib )
+ use npm || myconf+=( --without-npm )
+ use icu && myconf+=( --with-intl=system-icu )
+ use snapshot && myconf+=( --with-snapshot )
+ use ssl || myconf+=( --without-ssl )
+ use debug && myconf+=( --debug )
+
+ case ${ABI} in
+ amd64) myarch="x64";;
+ arm) myarch="arm";;
+ arm64) myarch="arm64";;
+ ppc64) myarch="ppc64";;
+ x32) myarch="x32";;
+ x86) myarch="ia32";;
+ *) myarch="${ABI}";;
+ esac
+
+ GYP_DEFINES="linux_use_gold_flags=0
+ linux_use_bundled_binutils=0
+ linux_use_bundled_gold=0" \
+ "${PYTHON}" configure \
+ --prefix="${EPREFIX}"/usr \
+ --dest-cpu=${myarch} \
+ --without-dtrace \
+ "${myconf[@]}" || die
+}
+
+src_compile() {
+ emake -C out mksnapshot
+ pax-mark m "out/${BUILDTYPE}/mksnapshot"
+ emake -C out
+}
+
+src_install() {
+ local LIBDIR="${ED}/usr/$(get_libdir)"
+ emake install DESTDIR="${D}"
+ pax-mark -m "${ED}"usr/bin/node
+
+ # set up a symlink structure that node-gyp expects..
+ dodir /usr/include/node/deps/{v8,uv}
+ dosym . /usr/include/node/src
+ for var in deps/{uv,v8}/include; do
+ dosym ../.. /usr/include/node/${var}
+ done
+
+ if use doc; then
+ # Patch docs to make them offline readable
+ for i in `grep -rl 'fonts.googleapis.com' "${S}"/out/doc/api/*`; do
+ sed -i '/fonts.googleapis.com/ d' $i;
+ done
+ # Install docs!
+ dohtml -r "${S}"/doc/*
+ fi
+
+ if use npm; then
+ dodir /etc/npm
+
+ # Install bash completion for `npm`
+ # We need to temporarily replace default config path since
+ # npm otherwise tries to write outside of the sandbox
+ local npm_config="usr/$(get_libdir)/node_modules/npm/lib/config/core.js"
+ sed -i -e "s|'/etc'|'${ED}/etc'|g" "${ED}/${npm_config}" || die
+ local tmp_npm_completion_file="$(emktemp)"
+ "${ED}/usr/bin/npm" completion > "${tmp_npm_completion_file}"
+ newbashcomp "${tmp_npm_completion_file}" npm
+ sed -i -e "s|'${ED}/etc'|'/etc'|g" "${ED}/${npm_config}" || die
+
+ # Move man pages
+ doman "${LIBDIR}"/node_modules/npm/man/man{1,5,7}/*
+
+ # Clean up
+ rm "${LIBDIR}"/node_modules/npm/{.mailmap,.npmignore,Makefile} || die
+ rm -rf "${LIBDIR}"/node_modules/npm/{doc,html,man} || die
+
+ local find_exp="-or -name"
+ local find_name=()
+ for match in "AUTHORS*" "CHANGELOG*" "CONTRIBUT*" "README*" \
+ ".travis.yml" ".eslint*" ".wercker.yml" ".npmignore" \
+ "*.md" "*.markdown" "*.bat" "*.cmd"; do
+ find_name+=( ${find_exp} "${match}" )
+ done
+
+ # Remove various development and/or inappropriate files and
+ # useless docs of dependend packages.
+ find "${LIBDIR}"/node_modules \
+ \( -type d -name examples \) -or \( -type f \( \
+ -iname "LICEN?E*" \
+ "${find_name[@]}" \
+ \) \) -exec rm -rf "{}" \;
+ fi
+}
+
+src_test() {
+ out/${BUILDTYPE}/cctest || die
+ "${PYTHON}" tools/test.py --mode=${BUILDTYPE,,} -J message parallel sequential || die
+}
+
+pkg_postinst() {
+ einfo "The global npm config lives in /etc/npm. This deviates slightly"
+ einfo "from upstream which otherwise would have it live in /usr/etc/."
+ einfo ""
+ einfo "Protip: When using node-gyp to install native modules, you can"
+ einfo "avoid having to download extras by doing the following:"
+ einfo "$ node-gyp --nodedir /usr/include/node <command>"
+}
diff --git a/net-libs/nodejs/nodejs-7.6.0.ebuild b/net-libs/nodejs/nodejs-7.6.0.ebuild
new file mode 100644
index 000000000000..4feb2a4a20bb
--- /dev/null
+++ b/net-libs/nodejs/nodejs-7.6.0.ebuild
@@ -0,0 +1,195 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+RESTRICT="test"
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="threads"
+
+inherit bash-completion-r1 eutils flag-o-matic pax-utils python-single-r1 toolchain-funcs
+
+DESCRIPTION="A JavaScript runtime built on Chrome's V8 JavaScript engine"
+HOMEPAGE="https://nodejs.org/"
+SRC_URI="https://nodejs.org/dist/v${PV}/node-v${PV}.tar.xz"
+
+LICENSE="Apache-1.1 Apache-2.0 BSD BSD-2 MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~amd64-linux ~x64-macos"
+IUSE="cpu_flags_x86_sse2 debug doc icu +npm +snapshot +ssl systemtap test"
+
+RDEPEND="icu? ( >=dev-libs/icu-56:= )
+ npm? ( ${PYTHON_DEPS} )
+ >=net-libs/http-parser-2.6.2:=
+ >=dev-libs/libuv-1.11.0:=
+ >=dev-libs/openssl-1.0.2g:0=[-bindist]
+ sys-libs/zlib"
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ systemtap? ( dev-util/systemtap )
+ test? ( net-misc/curl )"
+
+S="${WORKDIR}/node-v${PV}"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+PATCHES=(
+ "${FILESDIR}"/gentoo-global-npm-config.patch
+)
+
+pkg_pretend() {
+ (use x86 && ! use cpu_flags_x86_sse2) && \
+ die "Your CPU doesn't support the required SSE2 instruction."
+
+ ( [[ ${MERGE_TYPE} != "binary" ]] && ! test-flag-CXX -std=c++11 ) && \
+ die "Your compiler doesn't support C++11. Use GCC 4.8, Clang 3.3 or newer."
+}
+
+src_prepare() {
+ tc-export CC CXX PKG_CONFIG
+ export V=1
+ export BUILDTYPE=Release
+
+ # fix compilation on Darwin
+ # https://code.google.com/p/gyp/issues/detail?id=260
+ sed -i -e "/append('-arch/d" tools/gyp/pylib/gyp/xcode_emulation.py || die
+
+ # make sure we use python2.* while using gyp
+ sed -i -e "s/python/${EPYTHON}/" deps/npm/node_modules/node-gyp/gyp/gyp || die
+ sed -i -e "s/|| 'python'/|| '${EPYTHON}'/" deps/npm/node_modules/node-gyp/lib/configure.js || die
+
+ # less verbose install output (stating the same as portage, basically)
+ sed -i -e "/print/d" tools/install.py || die
+
+ # proper libdir, hat tip @ryanpcmcquen https://github.com/iojs/io.js/issues/504
+ local LIBDIR=$(get_libdir)
+ sed -i -e "s|lib/|${LIBDIR}/|g" tools/install.py || die
+ sed -i -e "s/'lib'/'${LIBDIR}'/" lib/module.js || die
+ sed -i -e "s|\"lib\"|\"${LIBDIR}\"|" deps/npm/lib/npm.js || die
+
+ # Avoid writing a depfile, not useful
+ sed -i -e "/DEPFLAGS =/d" tools/gyp/pylib/gyp/generator/make.py || die
+
+ # Avoid a test that I've only been able to reproduce from emerge. It doesnt
+ # seem sandbox related either (invoking it from a sandbox works fine).
+ # The issue is that no stdin handle is openened when asked for one.
+ # It doesn't really belong upstream , so it'll just be removed until someone
+ # with more gentoo-knowledge than me (jbergstroem) figures it out.
+ rm test/parallel/test-stdout-close-unref.js || die
+
+ # debug builds. change install path, remove optimisations and override buildtype
+ if use debug; then
+ sed -i -e "s|out/Release/|out/Debug/|g" tools/install.py || die
+ BUILDTYPE=Debug
+ fi
+
+ default
+}
+
+src_configure() {
+ local myarch=""
+ local myconf=( --shared-openssl --shared-libuv --shared-http-parser --shared-zlib )
+ use npm || myconf+=( --without-npm )
+ use icu && myconf+=( --with-intl=system-icu )
+ use snapshot && myconf+=( --with-snapshot )
+ use ssl || myconf+=( --without-ssl )
+ use debug && myconf+=( --debug )
+
+ case ${ABI} in
+ amd64) myarch="x64";;
+ arm) myarch="arm";;
+ arm64) myarch="arm64";;
+ ppc64) myarch="ppc64";;
+ x32) myarch="x32";;
+ x86) myarch="ia32";;
+ *) myarch="${ABI}";;
+ esac
+
+ GYP_DEFINES="linux_use_gold_flags=0
+ linux_use_bundled_binutils=0
+ linux_use_bundled_gold=0" \
+ "${PYTHON}" configure \
+ --prefix="${EPREFIX}"/usr \
+ --dest-cpu=${myarch} \
+ $(use_with systemtap dtrace) \
+ "${myconf[@]}" || die
+}
+
+src_compile() {
+ emake -C out mksnapshot
+ pax-mark m "out/${BUILDTYPE}/mksnapshot"
+ emake -C out
+}
+
+src_install() {
+ local LIBDIR="${ED}/usr/$(get_libdir)"
+ emake install DESTDIR="${D}"
+ pax-mark -m "${ED}"usr/bin/node
+
+ # set up a symlink structure that node-gyp expects..
+ dodir /usr/include/node/deps/{v8,uv}
+ dosym . /usr/include/node/src
+ for var in deps/{uv,v8}/include; do
+ dosym ../.. /usr/include/node/${var}
+ done
+
+ if use doc; then
+ # Patch docs to make them offline readable
+ for i in `grep -rl 'fonts.googleapis.com' "${S}"/out/doc/api/*`; do
+ sed -i '/fonts.googleapis.com/ d' $i;
+ done
+ # Install docs!
+ dohtml -r "${S}"/doc/*
+ fi
+
+ if use npm; then
+ dodir /etc/npm
+
+ # Install bash completion for `npm`
+ # We need to temporarily replace default config path since
+ # npm otherwise tries to write outside of the sandbox
+ local npm_config="usr/$(get_libdir)/node_modules/npm/lib/config/core.js"
+ sed -i -e "s|'/etc'|'${ED}/etc'|g" "${ED}/${npm_config}" || die
+ local tmp_npm_completion_file="$(emktemp)"
+ "${ED}/usr/bin/npm" completion > "${tmp_npm_completion_file}"
+ newbashcomp "${tmp_npm_completion_file}" npm
+ sed -i -e "s|'${ED}/etc'|'/etc'|g" "${ED}/${npm_config}" || die
+
+ # Move man pages
+ doman "${LIBDIR}"/node_modules/npm/man/man{1,5,7}/*
+
+ # Clean up
+ rm "${LIBDIR}"/node_modules/npm/{.mailmap,.npmignore,Makefile} || die
+ rm -rf "${LIBDIR}"/node_modules/npm/{doc,html,man} || die
+
+ local find_exp="-or -name"
+ local find_name=()
+ for match in "AUTHORS*" "CHANGELOG*" "CONTRIBUT*" "README*" \
+ ".travis.yml" ".eslint*" ".wercker.yml" ".npmignore" \
+ "*.md" "*.markdown" "*.bat" "*.cmd"; do
+ find_name+=( ${find_exp} "${match}" )
+ done
+
+ # Remove various development and/or inappropriate files and
+ # useless docs of dependend packages.
+ find "${LIBDIR}"/node_modules \
+ \( -type d -name examples \) -or \( -type f \( \
+ -iname "LICEN?E*" \
+ "${find_name[@]}" \
+ \) \) -exec rm -rf "{}" \;
+ fi
+}
+
+src_test() {
+ out/${BUILDTYPE}/cctest || die
+ "${PYTHON}" tools/test.py --mode=${BUILDTYPE,,} -J message parallel sequential || die
+}
+
+pkg_postinst() {
+ einfo "The global npm config lives in /etc/npm. This deviates slightly"
+ einfo "from upstream which otherwise would have it live in /usr/etc/."
+ einfo ""
+ einfo "Protip: When using node-gyp to install native modules, you can"
+ einfo "avoid having to download extras by doing the following:"
+ einfo "$ node-gyp --nodedir /usr/include/node <command>"
+}
diff --git a/net-misc/putty/Manifest b/net-misc/putty/Manifest
index 2c1e1f83f32d..af4fb319ec84 100644
--- a/net-misc/putty/Manifest
+++ b/net-misc/putty/Manifest
@@ -1,2 +1,3 @@
DIST putty-0.67.tar.gz 1955547 SHA256 80192458e8a46229de512afeca5c757dd8fce09606b3c992fbaeeee29b994a47 SHA512 c2b17da46b8db3fe3837a10cb9cf5dd4b3ef6bfa15cadab83f3b87cf1479ed31fced90b774297ae53bdcbbdf230fc80d5c73d5ff3be6916fb591fd7ce3d35eca WHIRLPOOL c1410a655cecfdbf49153f2fa12f39e4e1e0b1c1078293be2ce21f147baba404bcfed285d8da3cba460ae52b1bdbd526e4110d2a3c68dc4bb8dbb859751656fe
+DIST putty-0.68.tar.gz 2114499 SHA256 7ba256f46e5a353cafe811ce7914d0e22a52bdfc0e6e2d183ad28b5af44cd09c SHA512 e3a6e4f45e1fce70d4cbb6d4769ab72b23c10920e48a88bba95b3f4c225b0193ddc1444e69d572bdec5e505d2c56fed365f07d990c156b35f272b56f978ef5d3 WHIRLPOOL d24ceb3ed62eca52bb3a8f4fae08256269002265650e6fc42af10fc10a7b85b677b70c68e6b0a98915371921eabfbcbfa8a9b64b6be1a51cff418aef2feb6650
DIST putty-icons.tar.bz2 4878 SHA256 960b189069dbfb20a1f49e378ab88bed716c6457593815e414d51ad7a3fa93a7 SHA512 4e419a71e26770e159221f6b516e7210d29272917b4b9a9e0b67c72e73508b97278e56c82111b02e106c5d513c2561fec6da372b4b18246f29372ae618ff5f71 WHIRLPOOL ec96fe682582bfa58ce73c3e5cb7bb61d2363b7a5e9d3259dfd11cd6396512b5b9ed954f6a431baab36b1f17963714b30c239cdf4c08191d27b5abb858f54a57
diff --git a/net-misc/putty/putty-0.68.ebuild b/net-misc/putty/putty-0.68.ebuild
new file mode 100644
index 000000000000..d1db63a86c9b
--- /dev/null
+++ b/net-misc/putty/putty-0.68.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit autotools eutils gnome2-utils toolchain-funcs
+
+DESCRIPTION="A Free Telnet/SSH Client"
+HOMEPAGE="http://www.chiark.greenend.org.uk/~sgtatham/putty/"
+LICENSE="MIT"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc +gtk ipv6 kerberos"
+SRC_URI="
+ https://dev.gentoo.org/~jer/${PN}-icons.tar.bz2
+ http://the.earth.li/~sgtatham/${PN}/latest/${P}.tar.gz
+"
+
+RDEPEND="
+ !net-misc/pssh
+ gtk? (
+ dev-libs/glib:2
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:3
+ x11-libs/libX11
+ x11-libs/pango
+ )
+ kerberos? ( virtual/krb5 )
+"
+DEPEND="
+ ${RDEPEND}
+ dev-lang/perl
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e '/AM_PATH_GTK(/d' \
+ -e 's|-Werror||g' \
+ configure.ac || die
+
+ eautoreconf
+}
+
+src_configure() {
+ cd "${S}"/unix || die
+ econf \
+ $(use_with kerberos gssapi) \
+ $(use_with gtk)
+}
+
+src_compile() {
+ cd "${S}"/unix || die
+ emake AR=$(tc-getAR) $(usex ipv6 '' COMPAT=-DNO_IPV6)
+}
+
+src_install() {
+ dodoc doc/puttydoc.txt
+
+ if use doc; then
+ docinto html
+ dodoc doc/*.html
+ fi
+
+ cd "${S}"/unix || die
+ default
+
+ if use gtk ; then
+ for i in 16 22 24 32 48 64 128 256; do
+ newicon -s ${i} "${WORKDIR}"/${PN}-icons/${PN}-${i}.png ${PN}.png
+ done
+
+ # install desktop file provided by Gustav Schaffter in #49577
+ make_desktop_entry ${PN} PuTTY ${PN} Network
+ fi
+}
+
+pkg_preinst() {
+ use gtk && gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ use gtk && gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ use gtk && gnome2_icon_cache_update
+}
diff --git a/net-misc/putty/putty-9999.ebuild b/net-misc/putty/putty-9999.ebuild
index 5d552be32d4c..fbced904a692 100644
--- a/net-misc/putty/putty-9999.ebuild
+++ b/net-misc/putty/putty-9999.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
inherit autotools eutils gnome2-utils git-r3 toolchain-funcs
DESCRIPTION="A Free Telnet/SSH Client"
@@ -20,7 +20,7 @@ RDEPEND="
gtk? (
dev-libs/glib:2
x11-libs/gdk-pixbuf
- x11-libs/gtk+:2
+ x11-libs/gtk+:3
x11-libs/libX11
x11-libs/pango
)
@@ -39,6 +39,8 @@ src_unpack() {
}
src_prepare() {
+ default
+
sed -i \
-e '/AM_PATH_GTK(/d' \
-e 's|-Werror||g' \
@@ -65,7 +67,8 @@ src_install() {
dodoc doc/puttydoc.txt
if use doc; then
- dohtml doc/*.html
+ docinto html
+ dodoc doc/*.html
fi
cd "${S}"/unix || die
diff --git a/profiles/arch/x86/use.stable.mask b/profiles/arch/x86/use.stable.mask
index b121d58fa31b..cb796b4604a8 100644
--- a/profiles/arch/x86/use.stable.mask
+++ b/profiles/arch/x86/use.stable.mask
@@ -5,6 +5,10 @@
# This file requires eapi 5 or later. New entries go on top.
# Please use the same syntax as in use.mask
+# Brian Evans <grknight@gentoo.org> (22 Feb 2017)
+# Remove mask on stable PHP 7.x on major arch for extension testing
+-php_targets_php7-0
+
# Mike Gilbert <floppym@gentoo.org> (19 Oct 2014)
# sys-libs/libapparmor
apparmor