summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-apps/less/less-608-r1.ebuild2
-rw-r--r--sys-apps/less/less-612.ebuild11
2 files changed, 13 insertions, 0 deletions
diff --git a/sys-apps/less/less-608-r1.ebuild b/sys-apps/less/less-608-r1.ebuild
index 0c48837e70b3..0ad903424e2c 100644
--- a/sys-apps/less/less-608-r1.ebuild
+++ b/sys-apps/less/less-608-r1.ebuild
@@ -26,6 +26,8 @@ src_prepare() {
"${FILESDIR}/less-608-procfs.patch"
)
default
+ # Upstream uses unpatched autoconf-2.69, which breaks with clang-16.
+ # https://bugs.gentoo.org/870412
eautoreconf
}
diff --git a/sys-apps/less/less-612.ebuild b/sys-apps/less/less-612.ebuild
index 21c557ee9136..cb210766d048 100644
--- a/sys-apps/less/less-612.ebuild
+++ b/sys-apps/less/less-612.ebuild
@@ -2,6 +2,10 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=8
+WANT_AUTOMAKE=none
+WANT_LIBTOOL=none
+
+inherit autotools
# Releases are usually first a beta then promoted to stable if no
# issues were found. Upstream explicitly ask "to not generally distribute"
@@ -22,6 +26,13 @@ DEPEND=">=app-misc/editor-wrapper-3
pcre? ( dev-libs/libpcre2 )"
RDEPEND="${DEPEND}"
+src_prepare() {
+ default
+ # Upstream uses unpatched autoconf-2.69, which breaks with clang-16.
+ # https://bugs.gentoo.org/870412
+ eautoreconf
+}
+
src_configure() {
local myeconfargs=(
--with-regex=$(usex pcre pcre2 posix)