summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-emulation/dosbox/dosbox-0.75_pre4302.ebuild2
-rw-r--r--games-emulation/dosbox/files/dosbox-0.75-glide-libdl.patch18
2 files changed, 19 insertions, 1 deletions
diff --git a/games-emulation/dosbox/dosbox-0.75_pre4302.ebuild b/games-emulation/dosbox/dosbox-0.75_pre4302.ebuild
index 8ae6d980d50b..4cf2a4a4d981 100644
--- a/games-emulation/dosbox/dosbox-0.75_pre4302.ebuild
+++ b/games-emulation/dosbox/dosbox-0.75_pre4302.ebuild
@@ -54,7 +54,7 @@ PATCHES=(
)
src_prepare() {
- use glide && eapply "${DISTDIR}"/dosbox_glide-${GLIDE_PATCH}.diff
+ use glide && eapply "${DISTDIR}"/dosbox_glide-${GLIDE_PATCH}.diff "${FILESDIR}"/${PN}-0.75-glide-libdl.patch
default
eautoreconf
}
diff --git a/games-emulation/dosbox/files/dosbox-0.75-glide-libdl.patch b/games-emulation/dosbox/files/dosbox-0.75-glide-libdl.patch
new file mode 100644
index 000000000000..524c5839672e
--- /dev/null
+++ b/games-emulation/dosbox/files/dosbox-0.75-glide-libdl.patch
@@ -0,0 +1,18 @@
+https://github.com/voyageur/openglide/pull/25
+
+diff -Naur dosbox.orig/configure.ac dosbox/configure.ac
+--- dosbox.orig/configure.ac 2021-10-26 13:06:35.585761330 +0100
++++ dosbox/configure.ac 2021-10-26 13:07:31.641323631 +0100
+@@ -20,6 +20,12 @@
+ AC_PROG_RANLIB
+ AM_PROG_AR
+
++dnl The dlopen() function is in the C library for *BSD and in
++dnl libdl on GLIBC-based systems
++AC_SEARCH_LIBS([dlopen], [dl dld], [], [
++ AC_MSG_ERROR([unable to find the dlopen() function])
++])
++
+ dnl Some needed libaries for OS2
+ dnl perharps join this with the other target depended checks. move them upwards
+ if test x$host = xi386-pc-os2-emx ; then