summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-vim/gitv/gitv-1.3.1-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-vim/gitv/gitv-1.3.1-r1.ebuild b/app-vim/gitv/gitv-1.3.1-r1.ebuild
new file mode 100644
index 000000000000..967936be8c8d
--- /dev/null
+++ b/app-vim/gitv/gitv-1.3.1-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: gitk for vim"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=3574 https://github.com/gregsexton/gitv/"
+SRC_URI="https://github.com/gregsexton/gitv/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="vim"
+KEYWORDS="~amd64 ~x86 ~ppc-macos"
+
+VIM_PLUGIN_HELPFILES="gitv"
+
+RDEPEND="
+ dev-vcs/git
+ app-vim/fugitive"
+
+src_prepare() {
+ rm -f doc/tags || die
+ rm -r img || die
+ default
+}