summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/soupsieve/Manifest1
-rw-r--r--dev-python/soupsieve/soupsieve-2.5.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/soupsieve/Manifest b/dev-python/soupsieve/Manifest
index 1d50cb39e822..2ce27614daf4 100644
--- a/dev-python/soupsieve/Manifest
+++ b/dev-python/soupsieve/Manifest
@@ -1 +1,2 @@
DIST soupsieve-2.4.1.gh.tar.gz 105158 BLAKE2B 73ae01835ac7edf17bd1be1eb33cae5d06a7ef21c63fac50d61fd0f3246f734cd76f70245da19334d65746cf6e02a5a4c970ba2fbfb1a79de7fcda0bca1a38de SHA512 71ed91beabd9afef5756dddbb259f2607ca5109b8ff3f0a25bc3d4730f2948e160c20334b1c6e9f9095362f2b9e601e1ccfee09854e000b2f9f83af514790caa
+DIST soupsieve-2.5.gh.tar.gz 104832 BLAKE2B 8f3f2079e3ac758bb4459529e92015348e628be37f828c14d6729505097f208a2d88c2d315e0ff8c33ff3fcec7fc670df38c0a685dfb492c8f40d5a95d5f9d18 SHA512 5b3bb1f8ea84c69a97b273c87f385513baf9f0c49f5cf822120e4a73c16801ad8eb65f7ac32f83091b3efac716b3a7097b7511273e7fb8079f49ca6caa238656
diff --git a/dev-python/soupsieve/soupsieve-2.5.ebuild b/dev-python/soupsieve/soupsieve-2.5.ebuild
new file mode 100644
index 000000000000..338e40a5caa4
--- /dev/null
+++ b/dev-python/soupsieve/soupsieve-2.5.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A modern CSS selector implementation for BeautifulSoup"
+HOMEPAGE="
+ https://github.com/facelessuser/soupsieve/
+ https://pypi.org/project/soupsieve/
+"
+SRC_URI="
+ https://github.com/facelessuser/soupsieve/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/html5lib[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest