summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-fs/fswatch/Manifest1
-rw-r--r--sys-fs/fswatch/fswatch-1.16.0.ebuild27
-rw-r--r--sys-fs/fswatch/metadata.xml7
3 files changed, 35 insertions, 0 deletions
diff --git a/sys-fs/fswatch/Manifest b/sys-fs/fswatch/Manifest
new file mode 100644
index 000000000000..b9e7a1470faf
--- /dev/null
+++ b/sys-fs/fswatch/Manifest
@@ -0,0 +1 @@
+DIST fswatch-1.16.0.tar.gz 844804 BLAKE2B 55527e7d38421f16a9d2c51b5455b73de54220d280233d905a02d192bc374ef91b02c0d68dcd1c1ed6a29351421df0cd0ee9fad50bb98ec9c9018088a6064d4b SHA512 80100b92f5acef503436bbb684f07f5b692099a7eee0970a61c04670de67cd9bfa7942af40b348236dd97fc4d02fcd6a081b96486332efbd06500379c1eff806
diff --git a/sys-fs/fswatch/fswatch-1.16.0.ebuild b/sys-fs/fswatch/fswatch-1.16.0.ebuild
new file mode 100644
index 000000000000..f145c182b0f7
--- /dev/null
+++ b/sys-fs/fswatch/fswatch-1.16.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2021-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="cross-platform file change monitor with multiple backends"
+HOMEPAGE="https://github.com/emcrisostomo/fswatch"
+SRC_URI="https://github.com/emcrisostomo/${PN}/releases/download/${PV}/${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+LICENSE="GPL-3"
+SLOT="0"
+
+IUSE="nls static-libs"
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ $(use_enable static-libs static) \
+ CXX=$(tc-getCXX)
+}
+
+src_install() {
+ default
+ find "${ED}" -type f -name "*.la" -delete || die
+}
diff --git a/sys-fs/fswatch/metadata.xml b/sys-fs/fswatch/metadata.xml
new file mode 100644
index 000000000000..91e8ad9f5e33
--- /dev/null
+++ b/sys-fs/fswatch/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ada@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>