summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /xfce-extra/xfce4-linelight-plugin
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'xfce-extra/xfce4-linelight-plugin')
-rw-r--r--xfce-extra/xfce4-linelight-plugin/Manifest1
-rw-r--r--xfce-extra/xfce4-linelight-plugin/files/xfce4-linelight-plugin-0.1.7-port-to-xfcerc.patch61
-rw-r--r--xfce-extra/xfce4-linelight-plugin/metadata.xml8
-rw-r--r--xfce-extra/xfce4-linelight-plugin/xfce4-linelight-plugin-0.1.7.ebuild39
4 files changed, 109 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-linelight-plugin/Manifest b/xfce-extra/xfce4-linelight-plugin/Manifest
new file mode 100644
index 000000000000..7340d0ddae74
--- /dev/null
+++ b/xfce-extra/xfce4-linelight-plugin/Manifest
@@ -0,0 +1 @@
+DIST xfce4-linelight-plugin_0.1.7.orig.tar.bz2 239068 SHA256 0226ac62fd3b3875353cccaf8b2b971b923e1e6a560483c7e163141f7fe6b8ea
diff --git a/xfce-extra/xfce4-linelight-plugin/files/xfce4-linelight-plugin-0.1.7-port-to-xfcerc.patch b/xfce-extra/xfce4-linelight-plugin/files/xfce4-linelight-plugin-0.1.7-port-to-xfcerc.patch
new file mode 100644
index 000000000000..2c7bb4795248
--- /dev/null
+++ b/xfce-extra/xfce4-linelight-plugin/files/xfce4-linelight-plugin-0.1.7-port-to-xfcerc.patch
@@ -0,0 +1,61 @@
+http://bugs.gentoo.org/411949
+http://bugs.ganymede.ch/
+http://lionel.lefolgoc.net/misc/01_port-to-xfcerc.patch
+
+--- panel-plugin/linelight.c
++++ panel-plugin/linelight.c
+@@ -207,7 +207,7 @@ void linelight_add_list_entry(LineLightD
+ remove_newline(entry);
+
+ GtkTreeIter iter;
+- char *icon;
++ const gchar *icon = NULL;
+ GdkPixbuf *pixbuf;
+
+ gtk_list_store_insert(data->list, &iter, data->listPointer[sec]);
+@@ -218,13 +218,15 @@ void linelight_add_list_entry(LineLightD
+ //icon
+ if (g_file_query_exists (file, NULL) && sec == BIN_SECTION )
+ {
+- XfceDesktopEntry* app = xfce_desktop_entry_new(entry,categories,3);
++ XfceRc* app = xfce_rc_simple_open(entry, TRUE);
+
+- if (app != NULL && xfce_desktop_entry_get_string(app, "Icon", TRUE, &icon) && NULL != (pixbuf= load_icon(icon)))
++ if (app != NULL)
+ {
+- gtk_list_store_set(data->list, &iter, ICON_COL, pixbuf, -1);
+- g_object_unref(app);
+- free(icon);
++ xfce_rc_set_group(app, G_KEY_FILE_DESKTOP_GROUP);
++ icon = xfce_rc_read_entry(app, G_KEY_FILE_DESKTOP_KEY_ICON, NULL);
++ if (icon != NULL && NULL != (pixbuf= load_icon(icon)))
++ gtk_list_store_set(data->list, &iter, ICON_COL, pixbuf, -1);
++ xfce_rc_close(app);
+ }
+ }
+ else if (file != NULL)
+--- panel-plugin/main.c
++++ panel-plugin/main.c
+@@ -155,14 +155,15 @@ static void cell_renderer(GtkTreeViewCol
+ }
+ else if (strstr(name,".desktop") != NULL) //Application names based on .desktop files
+ {
+- XfceDesktopEntry *application = xfce_desktop_entry_new(path,categories,3);
+- if (XFCE_IS_DESKTOP_ENTRY(application))
++ XfceRc *application = xfce_rc_simple_open(path, TRUE);
++ if (application != NULL)
+ {
+- char* app_name;
+- xfce_desktop_entry_get_string(application, "Name", TRUE, &app_name);
+- g_object_unref(application);
+- g_object_set(cell,"text", app_name,NULL);
+- free(app_name);
++ const gchar* app_name = NULL;
++ xfce_rc_set_group(application, G_KEY_FILE_DESKTOP_GROUP);
++ app_name = xfce_rc_read_entry(application, G_KEY_FILE_DESKTOP_KEY_NAME, NULL);
++ if (app_name != NULL)
++ g_object_set(cell,"text", app_name, NULL);
++ xfce_rc_close(application);
+ }
+ }
+ else
diff --git a/xfce-extra/xfce4-linelight-plugin/metadata.xml b/xfce-extra/xfce4-linelight-plugin/metadata.xml
new file mode 100644
index 000000000000..008cf479f615
--- /dev/null
+++ b/xfce-extra/xfce4-linelight-plugin/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>xfce@gentoo.org</email>
+ <name>XFCE Team</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/xfce-extra/xfce4-linelight-plugin/xfce4-linelight-plugin-0.1.7.ebuild b/xfce-extra/xfce4-linelight-plugin/xfce4-linelight-plugin-0.1.7.ebuild
new file mode 100644
index 000000000000..d9480e702c1b
--- /dev/null
+++ b/xfce-extra/xfce4-linelight-plugin/xfce4-linelight-plugin-0.1.7.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+EAUTORECONF=yes
+inherit multilib xfconf
+
+DESCRIPTION="A simple locate based search plug-in for the Xfce panel"
+HOMEPAGE="http://goodies.xfce.org/projects/panel-plugins/xfce4-linelight-plugin"
+SRC_URI="mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${PV}.orig.tar.bz2"
+#SRC_URI="http://svn.ganymede.ch/private/trunk/${PN}/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~ppc64 x86"
+IUSE=""
+
+COMMON_DEPEND=">=dev-libs/glib-2.18:2
+ >=x11-libs/gtk+-2.12:2
+ >=xfce-base/xfce4-panel-4.8
+ >=xfce-base/libxfcegui4-4.8"
+RDEPEND="${COMMON_DEPEND}
+ sys-apps/mlocate"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig
+ sys-devel/gettext"
+
+pkg_setup() {
+ PATCHES=(
+ "${FILESDIR}"/${P}-port-to-xfcerc.patch
+ )
+
+ XFCONF=(
+ --libexecdir="${EPREFIX}"/usr/$(get_libdir)
+ )
+
+ DOCS=( AUTHORS ChangeLog NEWS )
+}