summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-10 21:25:33 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-10 21:28:00 +0100
commitd780912a06e0a86daed1b2be3b0ece5b06d43fa3 (patch)
tree8943eb442aa3a6d383e351ecac9d1b8590da1bef /xfce-base
parentxfce-base/libxfce4util: Bump to 4.18.1 (diff)
downloadgentoo-d780912a06e0a86daed1b2be3b0ece5b06d43fa3.tar.gz
gentoo-d780912a06e0a86daed1b2be3b0ece5b06d43fa3.tar.bz2
gentoo-d780912a06e0a86daed1b2be3b0ece5b06d43fa3.zip
xfce-base/xfce4-panel: Bump to 4.19.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/xfce4-panel/Manifest1
-rw-r--r--xfce-base/xfce4-panel/xfce4-panel-4.19.0.ebuild83
2 files changed, 84 insertions, 0 deletions
diff --git a/xfce-base/xfce4-panel/Manifest b/xfce-base/xfce4-panel/Manifest
index e27965b53466..19e6799bda79 100644
--- a/xfce-base/xfce4-panel/Manifest
+++ b/xfce-base/xfce4-panel/Manifest
@@ -1,3 +1,4 @@
DIST xfce4-panel-4.16.5.tar.bz2 1386556 BLAKE2B e0543e2c2259a03b09ddaef951434127a76f176626b5355497c1f27748c83857cb34ed1ddecf694c36e3422ca9e55fa4e7eae728b0b50e06feb40ca6e867ebdc SHA512 d72220fa2812ae3b420350dab4c9d33e01d26d27ba33e4c16ad848ed1915c3c4aaf41fef24e2e7271e31171536148ad32b55aabc3e1facd4bf8a411990fd27bb
DIST xfce4-panel-4.17.5.tar.bz2 1450044 BLAKE2B 5ee351df3ff56d82cd85c9bd4af85dc1fd2f597f4669167421f0af18255bb175ecb80fcc9ddae884d2e32184bb608833e22fe126a59cc48a03e8856520a3672e SHA512 149d41c190d2caf8e5f03ad8c2d53890b3529e21e31d34795673e4951c68ce6d96ca75a32d622ae211657f9ff1449cfffd5daa59cdc54bf4ff1b189f0cd7abfc
DIST xfce4-panel-4.18.0.tar.bz2 1451719 BLAKE2B 9a96c146b5d2764f3e5540979df7eecbe861c9527dfbb924643fc3335bf5f2648d760362024969b7d9d4005eec83805378d104bf5995e85afb9b2498946c47f0 SHA512 4269714fb4cd6fb915789f288a0464c7ceb8c0bca73040416f9f10b6c5ed936e0340b11da8bf7e662b5a1453764e360866abf0320a46e30d536603a329d9e727
+DIST xfce4-panel-4.19.0.tar.bz2 1485117 BLAKE2B a70654a1d8633f04310a1a9fb8554254de2f272f6fbbfede3c709a9bdc9b7d6138d5ab26ea83ccc75c9152ee0fb9d2ce7e7b174ace6369eb7d60e14db0828cec SHA512 a1c3c5f535581332c1b5e93bfecabae32cbe610d168f4452bed321466b73e4ca9ca09ca2e7c7f54cb82fe45a6102022bb30f77b57841a9bba03809b703bddf91
diff --git a/xfce-base/xfce4-panel/xfce4-panel-4.19.0.ebuild b/xfce-base/xfce4-panel/xfce4-panel-4.19.0.ebuild
new file mode 100644
index 000000000000..fff8efcd9fa6
--- /dev/null
+++ b/xfce-base/xfce4-panel/xfce4-panel-4.19.0.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit vala xdg-utils
+
+DESCRIPTION="Panel for the Xfce desktop environment"
+HOMEPAGE="
+ https://docs.xfce.org/xfce/xfce4-panel/start
+ https://gitlab.xfce.org/xfce/xfce4-panel/
+"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+ LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="X +dbusmenu introspection vala wayland"
+REQUIRED_USE="vala? ( introspection )"
+
+DEPEND="
+ >=dev-libs/glib-2.72.0
+ >=x11-libs/cairo-1.16.0
+ >=x11-libs/gtk+-3.24.0:3[X?,introspection?,wayland?]
+ >=xfce-base/exo-0.11.2:=
+ >=xfce-base/garcon-4.17.0:=
+ >=xfce-base/libxfce4ui-4.17.1:=
+ >=xfce-base/libxfce4util-4.17.2:=[introspection?,vala?]
+ >=xfce-base/libxfce4windowing-4.19.1:=
+ >=xfce-base/xfconf-4.13:=
+ X? (
+ x11-libs/libX11
+ x11-libs/libwnck:3
+ )
+ dbusmenu? ( >=dev-libs/libdbusmenu-16.04.0[gtk3] )
+ introspection? ( >=dev-libs/gobject-introspection-1.66:= )
+ wayland? (
+ >=dev-libs/wayland-1.15
+ >=gui-libs/gtk-layer-shell-0.7.0
+ )
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ vala? ( $(vala_depend) )
+ dev-lang/perl
+ dev-util/gdbus-codegen
+ dev-util/gtk-doc-am
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local myconf=(
+ $(use_enable introspection)
+ $(use_enable dbusmenu dbusmenu-gtk3)
+ $(use_enable vala)
+ $(use_enable X gtk-x11)
+ $(use_enable X libwnck)
+ $(use_enable wayland wayland-client)
+ $(use_enable wayland gtk-layer-shell)
+ )
+
+ use vala && vala_setup
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}