summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-10-16 19:15:31 +0200
committerMichał Górny <mgorny@gentoo.org>2018-10-16 19:21:22 +0200
commit761aefc9487301b3bdb46b55c0793d34f144252a (patch)
treef7b094523d9598fff7f409c8dc31b1d6794023ec /xfce-base
parentxfce-extra/xfce4-screenshooter: Add dep on glib-utils (diff)
downloadgentoo-761aefc9487301b3bdb46b55c0793d34f144252a.tar.gz
gentoo-761aefc9487301b3bdb46b55c0793d34f144252a.tar.bz2
gentoo-761aefc9487301b3bdb46b55c0793d34f144252a.zip
xfce-base/exo: Bump to 0.12.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/exo/Manifest1
-rw-r--r--xfce-base/exo/exo-0.12.3.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/xfce-base/exo/Manifest b/xfce-base/exo/Manifest
index 75ccdb23ea0e..ec5916ad4e46 100644
--- a/xfce-base/exo/Manifest
+++ b/xfce-base/exo/Manifest
@@ -1,2 +1,3 @@
DIST exo-0.12.0.tar.bz2 1310691 BLAKE2B 6acdfe0b3cf7b19717d17c4acc7973bc8e27e963b4213376061cee0bec72734303ed75b7bfd8d8cbe1da98af4a9b43132657ade0020f9d26add36aa77c184ff4 SHA512 8ec52aba3faa9728bb60e09cf696f772160bfd8357c06015a6d72a2302572e74389f78a20addcf3ac632a3ac84b3ee2f40750483a16e2f7e1cff7de6f7aa2692
DIST exo-0.12.2.tar.bz2 1321379 BLAKE2B bf17b8dfb6489b5c168893599e67bac603e6915e78930d0d460e94d23a60b53e720439653358c2566083a3773cd5bb898da5210200a2c6dfac7ca9b730ca4aaf SHA512 771c4e3c09683ccf2d028a5203d4b2af0da38e6ae97baa7825714ad6e2e81d128d9238d060cdd80c95660a0394b632caec3e31df1f2cc28b1fed8ef19ee2011a
+DIST exo-0.12.3.tar.bz2 1233053 BLAKE2B 27cb6041778d5b0c93002f474d96d3a0ae9b02d651d3be047eb0e3d1e6640614c457fbac7557216c46b28008bca3f3be674e29e8be48243b6bf15917bae0c907 SHA512 1a727050b822aa4bdfbce22c1668372b10ddfd9c3988f6949ee32a5c5213d90e20ebafc923193c70dea373d217994fb42101fe2aad7bf55c8e81f983c5a2106f
diff --git a/xfce-base/exo/exo-0.12.3.ebuild b/xfce-base/exo/exo-0.12.3.ebuild
new file mode 100644
index 000000000000..9a0d73773d13
--- /dev/null
+++ b/xfce-base/exo/exo-0.12.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome2-utils
+
+DESCRIPTION="Extensions, widgets and framework library with session support for Xfce"
+HOMEPAGE="https://www.xfce.org/projects/"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+ LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND=">=dev-lang/perl-5.6
+ >=dev-libs/glib-2.42:=
+ dev-perl/URI
+ >=x11-libs/gtk+-2.24:2=
+ >=x11-libs/gtk+-3.22:3=
+ >=xfce-base/libxfce4ui-4.12:=[gtk3(+)]
+ >=xfce-base/libxfce4util-4.12:="
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc-am
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}