summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2019-09-28 12:45:16 +0200
committerJohannes Huber <johu@gentoo.org>2019-09-28 12:45:53 +0200
commitbe3b270d9e1ae89d12875793595eab3ff82eb37d (patch)
tree1afb8adc34d36657b720b04364689e19a4af30e6 /x11-wm
parentgnome-base/gnome-core-apps: bump to 3.32.2 (diff)
downloadgentoo-be3b270d9e1ae89d12875793595eab3ff82eb37d.tar.gz
gentoo-be3b270d9e1ae89d12875793595eab3ff82eb37d.tar.bz2
gentoo-be3b270d9e1ae89d12875793595eab3ff82eb37d.zip
x11-wm/i3-gaps: Version bump 4.17.1
Reported-by: Marcin Kowalski <yoshi3@autograf.pl> Closes: https://bugs.gentoo.org/693822 Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Johannes Huber <johu@gentoo.org>
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/i3-gaps/Manifest1
-rw-r--r--x11-wm/i3-gaps/files/i3-gaps-4.17-musl.patch71
-rw-r--r--x11-wm/i3-gaps/i3-gaps-4.17.1.ebuild87
3 files changed, 159 insertions, 0 deletions
diff --git a/x11-wm/i3-gaps/Manifest b/x11-wm/i3-gaps/Manifest
index 4d3541756866..652f73bdb1de 100644
--- a/x11-wm/i3-gaps/Manifest
+++ b/x11-wm/i3-gaps/Manifest
@@ -1 +1,2 @@
DIST i3-gaps-4.16.1.tar.gz 3983420 BLAKE2B f0d5a85b06ce33e1cc177af6da29f9cdf42ed754bb767aa9eaa5ab52f3b9f4f688d251f2a16fb222fc8cf5052e79859891c4185b1325b2ef6c1a813aa220468c SHA512 904c2f63c6a35573f13fd216625c1349ac71de70ae8f0440667c9d76048cdaf30a398ab358f2366d5f46502d87e801713b625cb509a05f39dbca1371d2b8d0e9
+DIST i3-gaps-4.17.1.tar.gz 3991747 BLAKE2B e5ff8293abf41ffbd15c35590a0594861d7c8b70c0f42886ef7f15fb34b8da57a92cf9bcae76576e7db6db9bacc2356722e5653b1cf35b8446716f8845468b4b SHA512 31e47487f6f662f27b2642925f4ddfc553f1fd075e612d0d2661db723897b12eeae0a2bcefa8a43e7f1d4c15aec2222d3a63e37c8f7e1f9fc96567faa380ebff
diff --git a/x11-wm/i3-gaps/files/i3-gaps-4.17-musl.patch b/x11-wm/i3-gaps/files/i3-gaps-4.17-musl.patch
new file mode 100644
index 000000000000..d4f9113e6b15
--- /dev/null
+++ b/x11-wm/i3-gaps/files/i3-gaps-4.17-musl.patch
@@ -0,0 +1,71 @@
+--- a/i3bar/src/main.c
++++ b/i3bar/src/main.c
+@@ -48,14 +48,20 @@ void debuglog(char *fmt, ...) {
+ *
+ */
+ static char *expand_path(char *path) {
+- static glob_t globbuf;
+- if (glob(path, GLOB_NOCHECK | GLOB_TILDE, NULL, &globbuf) < 0) {
+- ELOG("glob() failed\n");
+- exit(EXIT_FAILURE);
++ char *home, *expanded;
++
++ if (strncmp(path, "~/", 2) == 0) {
++ home = getenv("HOME");
++ if (home != NULL) {
++ /* new length: sum - 1 (omit '~') + 1 (for '\0') */
++ expanded = scalloc(strlen(home)+strlen(path), 1);
++ strcpy(expanded, home);
++ strcat(expanded, path+1);
++ return expanded;
++ }
+ }
+- char *result = sstrdup(globbuf.gl_pathc > 0 ? globbuf.gl_pathv[0] : path);
+- globfree(&globbuf);
+- return result;
++
++ return sstrdup(path);
+ }
+
+ void print_usage(char *elf_name) {
+--- a/libi3/resolve_tilde.c
++++ b/libi3/resolve_tilde.c
+@@ -19,28 +19,18 @@
+ *
+ */
+ char *resolve_tilde(const char *path) {
+- static glob_t globbuf;
+- char *head, *tail, *result;
++ char *home, *expanded;
+
+- tail = strchr(path, '/');
+- head = sstrndup(path, tail ? (size_t)(tail - path) : strlen(path));
+-
+- int res = glob(head, GLOB_TILDE, NULL, &globbuf);
+- free(head);
+- /* no match, or many wildcard matches are bad */
+- if (res == GLOB_NOMATCH || globbuf.gl_pathc != 1)
+- result = sstrdup(path);
+- else if (res != 0) {
+- err(EXIT_FAILURE, "glob() failed");
+- } else {
+- head = globbuf.gl_pathv[0];
+- result = scalloc(strlen(head) + (tail ? strlen(tail) : 0) + 1, 1);
+- strcpy(result, head);
+- if (tail) {
+- strcat(result, tail);
++ if (strncmp(path, "~/", 2) == 0) {
++ home = getenv("HOME");
++ if (home != NULL) {
++ /* new length: sum - 1 (omit '~') + 1 (for '\0') */
++ expanded = scalloc(strlen(home)+strlen(path), 1);
++ strcpy(expanded, home);
++ strcat(expanded, path+1);
++ return expanded;
+ }
+ }
+- globfree(&globbuf);
+
+- return result;
++ return sstrdup(path);
+ }
diff --git a/x11-wm/i3-gaps/i3-gaps-4.17.1.ebuild b/x11-wm/i3-gaps/i3-gaps-4.17.1.ebuild
new file mode 100644
index 000000000000..0f5113ed0c6a
--- /dev/null
+++ b/x11-wm/i3-gaps/i3-gaps-4.17.1.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools out-of-source
+
+DESCRIPTION="i3 fork with gaps and some more features"
+HOMEPAGE="https://github.com/Airblader/i3"
+SRC_URI="https://github.com/Airblader/i3/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND="
+ dev-libs/glib:2
+ dev-libs/libev
+ dev-libs/libpcre
+ dev-libs/yajl
+ x11-libs/cairo[X,xcb]
+ x11-libs/libxcb[xkb]
+ x11-libs/libxkbcommon[X]
+ x11-libs/pango[X]
+ x11-libs/startup-notification
+ x11-libs/xcb-util
+ x11-libs/xcb-util-cursor
+ x11-libs/xcb-util-keysyms
+ x11-libs/xcb-util-wm
+ x11-libs/xcb-util-xrm
+"
+BDEPEND="
+ app-text/asciidoc
+ app-text/xmlto
+ dev-lang/perl
+ virtual/pkgconfig
+"
+RDEPEND="${DEPEND}
+ dev-lang/perl
+ dev-perl/AnyEvent-I3
+ dev-perl/JSON-XS
+ !x11-wm/i3
+"
+
+S=${WORKDIR}/i3-${PV}
+
+DOCS=( RELEASE-NOTES-$(ver_cut 1-3) )
+
+PATCHES=( "${FILESDIR}/${PN}-$(ver_cut 1-2)-musl.patch" )
+
+src_prepare() {
+ default
+ eautoreconf
+ cat <<- EOF > "${T}"/i3wm
+ #!/bin/sh
+ exec /usr/bin/i3
+ EOF
+}
+
+my_src_configure() {
+ # disable sanitizer: otherwise injects -O0 -g
+ local myeconfargs=(
+ $(use_enable doc docs)
+ --enable-debug=no
+ --enable-mans
+ --disable-sanitizers
+ )
+ econf "${myeconfargs[@]}"
+}
+
+my_src_install_all() {
+ doman "${BUILD_DIR}"/man/*.1
+ einstalldocs
+
+ exeinto /etc/X11/Sessions
+ doexe "${T}"/i3wm
+}
+
+pkg_postinst() {
+ einfo "There are several packages that you may find useful with ${PN} and"
+ einfo "their usage is suggested by the upstream maintainers, namely:"
+ einfo " x11-misc/dmenu"
+ einfo " x11-misc/i3lock"
+ einfo " x11-misc/i3status"
+ einfo "Please refer to their description for additional info."
+}