summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2016-09-05 14:00:43 +0300
committerSergey Popov <pinkbyte@gentoo.org>2016-09-05 14:00:59 +0300
commitbb37b61c77a952cb43f7adb7cfae53d4fdf54098 (patch)
treea2b6481dc0d48869a5e8d84a26e5f06c46dc2114 /x11-wm
parentapp-arch/zstd: Initial import, ebuild by me (diff)
downloadgentoo-bb37b61c77a952cb43f7adb7cfae53d4fdf54098.tar.gz
gentoo-bb37b61c77a952cb43f7adb7cfae53d4fdf54098.tar.bz2
gentoo-bb37b61c77a952cb43f7adb7cfae53d4fdf54098.zip
x11-wm/emerald: revision bump
Bump EAPI to 6, fix crash in cairo processing with some UTF-8 symbols in windows title - backported from compiz-reloaded project. Drop old revision Package-Manager: portage-2.2.28
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/emerald/emerald-0.8.8-r1.ebuild (renamed from x11-wm/emerald/emerald-0.8.8.ebuild)11
-rw-r--r--x11-wm/emerald/files/emerald-0.8.8-fix-cairo-crash.patch12
-rw-r--r--x11-wm/emerald/files/emerald-0.8.8-pkgconfig-pollution.patch4
3 files changed, 20 insertions, 7 deletions
diff --git a/x11-wm/emerald/emerald-0.8.8.ebuild b/x11-wm/emerald/emerald-0.8.8-r1.ebuild
index 921726a76801..be388ba89b8a 100644
--- a/x11-wm/emerald/emerald-0.8.8.ebuild
+++ b/x11-wm/emerald/emerald-0.8.8-r1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="4"
+EAPI=6
inherit eutils flag-o-matic
@@ -15,7 +15,6 @@ SRC_URI="http://releases.compiz.org/${PV}/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-IUSE=""
PDEPEND="~x11-themes/emerald-themes-${THEMES_RELEASE}"
@@ -35,14 +34,16 @@ DOCS=( AUTHORS ChangeLog INSTALL NEWS README TODO )
src_prepare() {
# Fix pkg-config file pollution wrt #380197
- epatch "${FILESDIR}"/${P}-pkgconfig-pollution.patch
+ eapply "${FILESDIR}/${P}-pkgconfig-pollution.patch"
+ # Fix crashes with some UTF-8 characters in window title
+ eapply "${FILESDIR}/${P}-fix-cairo-crash.patch"
# fix build with gtk+-2.22 - bug 341143
sed -i -e '/#define G[DT]K_DISABLE_DEPRECATED/s:^://:' \
include/emerald.h || die
# Fix underlinking
append-libs -ldl -lm
- epatch_user
+ eapply_user
}
src_configure() {
diff --git a/x11-wm/emerald/files/emerald-0.8.8-fix-cairo-crash.patch b/x11-wm/emerald/files/emerald-0.8.8-fix-cairo-crash.patch
new file mode 100644
index 000000000000..34ba3585c963
--- /dev/null
+++ b/x11-wm/emerald/files/emerald-0.8.8-fix-cairo-crash.patch
@@ -0,0 +1,12 @@
+https://github.com/compiz-reloaded/emerald/commit/7f712c5f4fb2dbc8bbe298acc8fef239815aea08
+
+--- a/src/main.c 2011-04-21 16:06:20.000000000 +0400
++++ b/src/main.c 2016-09-01 14:35:08.142020100 +0300
+@@ -1644,6 +1644,7 @@
+
+ /* ===================active text colors */
+ cairo_set_source_alpha_color(cr, &fs->text_halo);
++ pango_cairo_update_layout(cr, d->layout);
+ pango_cairo_layout_path(cr, d->layout);
+ cairo_stroke(cr);
+
diff --git a/x11-wm/emerald/files/emerald-0.8.8-pkgconfig-pollution.patch b/x11-wm/emerald/files/emerald-0.8.8-pkgconfig-pollution.patch
index 047d8dfad786..7d8a784853fd 100644
--- a/x11-wm/emerald/files/emerald-0.8.8-pkgconfig-pollution.patch
+++ b/x11-wm/emerald/files/emerald-0.8.8-pkgconfig-pollution.patch
@@ -1,5 +1,5 @@
---- libengine/emeraldengine.pc.in
-+++ libengine/emeraldengine.pc.in
+--- a/libengine/emeraldengine.pc.in
++++ b/libengine/emeraldengine.pc.in
@@ -7,6 +7,7 @@
Description: Library for Emerald Engines
Version: @VERSION@