summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorFlorian Schmaus <flo@geekplace.eu>2021-04-01 08:54:22 +0200
committerJoonas Niilola <juippis@gentoo.org>2021-04-11 10:39:30 +0300
commitae3794e3280ad609cd7a6ff28c275603d908b3a8 (patch)
treedca1164bd4fb2de27004de3de4b5829b0fc048ab /x11-wm
parentmedia-plugins/vdr-osdteletext: version bump to 1.1.1 (diff)
downloadgentoo-ae3794e3280ad609cd7a6ff28c275603d908b3a8.tar.gz
gentoo-ae3794e3280ad609cd7a6ff28c275603d908b3a8.tar.bz2
gentoo-ae3794e3280ad609cd7a6ff28c275603d908b3a8.zip
x11-wm/herbstluftwm: add 0.9.2
Closes: https://bugs.gentoo.org/779646 Signed-off-by: Florian Schmaus <flo@geekplace.eu> Closes: https://github.com/gentoo/gentoo/pull/20215 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/herbstluftwm/Manifest1
-rw-r--r--x11-wm/herbstluftwm/herbstluftwm-0.9.2.ebuild93
2 files changed, 94 insertions, 0 deletions
diff --git a/x11-wm/herbstluftwm/Manifest b/x11-wm/herbstluftwm/Manifest
index f311a69b3342..91e0df75ff96 100644
--- a/x11-wm/herbstluftwm/Manifest
+++ b/x11-wm/herbstluftwm/Manifest
@@ -1,2 +1,3 @@
DIST herbstluftwm-0.7.2.tar.gz 245506 BLAKE2B 72d0bb2a77e519161d193ac7b2b9f1f878ccb6cfe4914b6c75d060e2daa0bec4203ee4ebf203b9fa1dfb844d71d50aa7c03257c78aa22e906bf42519d1e592af SHA512 abb49bbc3de9a0ef619ce7063c1cea0d0d25ab2195c53dc0d33e061ad24060da4bbe9b99b9b9126028cdf68b462d4fcc8d1534431e4892d571ff897a68d2113c
DIST herbstluftwm-0.9.1.tar.gz 432926 BLAKE2B 38f8626f3f8957cae32d71202b03515c26a4e174ce550ed6b31e7e024c3a3095374ad68f5aecc55c608c0a8565063ff39f85596444884557f38ff39043bd1d7d SHA512 c69cc5a77e98e2e0a1c84938394fe97cd985bfedb8bb1e2dceddb0268f30597cdf9b30048aa3618c20ec549f2113b7a6bbbb94f2fbcc578b8f0117bdd8cac85d
+DIST herbstluftwm-0.9.2.tar.gz 448757 BLAKE2B f969e4a02aad11c5bd75ac261c7dd8c9448234a050f82f0cdd9bc29c998c4f6bb496f6e32d20016b06849218952c6a2f993f46aa94c29d011f4ff6865a2197bc SHA512 5426b4d1810f01cf043cf43644d4c65692a5aa207893be484c86eb0eeb96ca6259c86b843146a9eebdf4de988f2d2ed742674907be47262c6029d8aa7ab2265c
diff --git a/x11-wm/herbstluftwm/herbstluftwm-0.9.2.ebuild b/x11-wm/herbstluftwm/herbstluftwm-0.9.2.ebuild
new file mode 100644
index 000000000000..31f1710a7b3e
--- /dev/null
+++ b/x11-wm/herbstluftwm/herbstluftwm-0.9.2.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+DISTUTILS_OPTIONAL=1
+
+inherit cmake distutils-r1 toolchain-funcs
+
+DESCRIPTION="A manual tiling window manager for X"
+HOMEPAGE="https://herbstluftwm.org/"
+
+if [[ "${PV}" == "9999" ]] || [[ -n "${EGIT_COMMIT_ID}" ]]; then
+ EGIT_REPO_URI="https://github.com/herbstluftwm/herbstluftwm"
+ inherit git-r3
+else
+ SRC_URI="https://herbstluftwm.org/tarballs/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="BSD-2"
+SLOT="0"
+IUSE="doc examples python"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+DEPEND="
+ media-libs/freetype
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXft
+ x11-libs/libXinerama
+ x11-libs/libXrandr
+"
+RDEPEND="
+ ${DEPEND}
+ app-shells/bash
+ python? ( ${PYTHON_DEPS} )
+"
+BDEPEND="
+ ${PYTHON_DEPS}
+ virtual/pkgconfig
+ doc? ( app-text/asciidoc )
+"
+
+src_prepare() {
+ sed -i \
+ -e '/^install.*LICENSEDIR/d' \
+ -e '/set(DOCDIR / s#.*#set(DOCDIR ${CMAKE_INSTALL_DOCDIR})#' \
+ CMakeLists.txt || die
+ cmake_src_prepare
+
+ if use python; then
+ pushd "${S}"/python > /dev/null || die
+ distutils-r1_src_prepare
+ popd > /dev/null || die
+ fi
+}
+
+src_configure() {
+ # Ensure that 'python3' is in PATH. #765118
+ python_setup
+
+ mycmakeargs=(
+ -DWITH_DOCUMENTATION=$(usex doc)
+ )
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+
+ if use python; then
+ pushd python > /dev/null || die
+ distutils-r1_src_compile
+ popd >/dev/null || die
+ fi
+}
+
+src_install() {
+ cmake_src_install
+
+ if ! use examples; then
+ rm -r "${ED}"/usr/share/doc/${PF}/examples || die
+ fi
+
+ if use python; then
+ pushd python > /dev/null || die
+ distutils-r1_src_install
+ popd > /dev/null || die
+ fi
+
+}