summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorNelo-T. Wallus <nelo@wallus.de>2018-01-15 21:00:51 +0100
committerLars Wendler <polynomial-c@gentoo.org>2018-01-16 01:03:32 +0100
commit8f74772e20fb2992a0fd19ec5b08fe09c7418908 (patch)
tree729ee7e1493b46507a25b2b82128b3f1abb1a0a5 /x11-wm
parentkde-frameworks: Drop KDE Frameworks 5.41.0 (diff)
downloadgentoo-8f74772e20fb2992a0fd19ec5b08fe09c7418908.tar.gz
gentoo-8f74772e20fb2992a0fd19ec5b08fe09c7418908.tar.bz2
gentoo-8f74772e20fb2992a0fd19ec5b08fe09c7418908.zip
x11-wm/i3: Use out-of-source eclass
Package-Manager: Portage-2.3.19, Repoman-2.3.6 Closes: https://github.com/gentoo/gentoo/pull/6873
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/i3/i3-4.14.1.ebuild39
1 files changed, 9 insertions, 30 deletions
diff --git a/x11-wm/i3/i3-4.14.1.ebuild b/x11-wm/i3/i3-4.14.1.ebuild
index 1d884372499b..73ad789867b5 100644
--- a/x11-wm/i3/i3-4.14.1.ebuild
+++ b/x11-wm/i3/i3-4.14.1.ebuild
@@ -1,15 +1,16 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
AEVER=0.17
-inherit autotools virtualx
+inherit autotools out-of-source
DESCRIPTION="An improved dynamic tiling window manager"
HOMEPAGE="https://i3wm.org/"
SRC_URI="https://i3wm.org/downloads/${P}.tar.bz2"
+
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~arm64 ~x86"
@@ -53,29 +54,10 @@ RDEPEND="${CDEPEND}
# in type-punned pointers - which in turn causes test failures.
REQUIRED_USE="test? ( debug )"
-DOCS=(
- "RELEASE-NOTES-${PV}"
- docs
-)
PATCHES=(
"${FILESDIR}/${PN}-musl-GLOB_TILDE.patch"
)
-# https://github.com/i3/i3/issues/3013
-RESTRICT="test"
-
-src_test() {
- emake -C "${CBUILD}" \
- test.commands_parser \
- test.config_parser \
- test.inject_randr15
-
- virtx perl \
- -I "${S}/testcases/lib" \
- -I "${CBUILD}/testcases/lib" \
- "${CBUILD}/testcases/complete-run.pl"
-}
-
src_prepare() {
default
@@ -87,22 +69,19 @@ src_prepare() {
eautoreconf
}
-src_configure() {
+my_src_configure() {
local myeconfargs=(
$(use_enable debug)
)
econf "${myeconfargs[@]}"
}
-src_compile() {
- emake -C "${CBUILD}"
-}
-
-src_install() {
- emake -C "${CBUILD}" DESTDIR="${D}" install
- doman "${S}"/man/*.1
+my_src_install() {
+ emake install
+ doman man/*.1
- use doc && einstalldocs
+ einstalldocs
+ use docs && dodoc -r docs "RELEASE-NOTES-${PV}"
exeinto /etc/X11/Sessions
doexe "${T}/i3wm"