summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2019-08-24 09:27:28 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2019-08-24 09:34:08 +0100
commit49e88fe8e930b6ff2b8bc70d99518a4c275ff8fc (patch)
treeb43e0ec889767f9c6e903a3a0b03ac17741a6b5b /x11-wm
parentdev-ruby/activejob: add 6.0.0 (diff)
downloadgentoo-49e88fe8e930b6ff2b8bc70d99518a4c275ff8fc.tar.gz
gentoo-49e88fe8e930b6ff2b8bc70d99518a4c275ff8fc.tar.bz2
gentoo-49e88fe8e930b6ff2b8bc70d99518a4c275ff8fc.zip
x11-wm/xmonad: bump up to 0.15, bug #680504
Reported-by: yuLya Bug: https://bugs.gentoo.org/680504 Package-Manager: Portage-2.3.72, Repoman-2.3.17 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/xmonad/Manifest1
-rw-r--r--x11-wm/xmonad/xmonad-0.15.ebuild85
2 files changed, 86 insertions, 0 deletions
diff --git a/x11-wm/xmonad/Manifest b/x11-wm/xmonad/Manifest
index 06dd3bafa235..906195a5a503 100644
--- a/x11-wm/xmonad/Manifest
+++ b/x11-wm/xmonad/Manifest
@@ -2,3 +2,4 @@ DIST xmonad-0.11.1.tar.gz 59307 BLAKE2B 98dc31dd53e933f68dbf00121c6a0b4e4a24a19c
DIST xmonad-0.11.tar.gz 59119 BLAKE2B 75ae39e2e54d4b5ed14f99d0144d4ee7741c611f18b5692aedce49b0a4dc07a17f613280d93fd715b812a2c22e27ad9f7fe8693dba38739ccf6dde9742fe03b9 SHA512 34740f032508584f34f6b138d21394eca17e8020bccc4d8c6e8b3cb6b7ca64b153077cfd16636a6130768ebd145fe993569f8a229862d7816d0c89c905ee08bc
DIST xmonad-0.12.tar.gz 61436 BLAKE2B ea42fc105e30be59a2cb0180c05ef88024e51a1a224bdd6bb910d45cddabc2709411e2f0c7aa6c5723f54653db242bda80ab92249204106955be75a4a077f1ea SHA512 e519c038d90db037bc81e7baf7b07cfa53922509e98ffddacfc4a6cc2c7376383be1e721f613057a5febbfcc661807b6382124eb673ac7a7cda23c738d3539ab
DIST xmonad-0.13.tar.gz 72034 BLAKE2B c95b24ae406268da642168defcc633cf8185f0f2dbcede1122c48c3812bf250df69d917c479f328cca450dec362ae0614d2acaf09d62123d15d646dcae8d98ec SHA512 9d9436f36fe0f6a9732502b0211fc41a224b1320b843d266b6d2dd201e4329b688f7eed5b08597b2edd713cc25f2b88a2a1f1ee43e18615c0a78e97e4716b122
+DIST xmonad-0.15.tar.gz 68822 BLAKE2B 9ee9a070f6743fbab2cffe05ee9e60b64fded0b4916fdec03a550f5d5ec5a34102ab2d4e9586b9a0ca534db284a8058f11ee248072f3f3b312ae30c09873feff SHA512 f881f3faa4f5a0de7a5a37118cd7041083ae3a7569c7094b55dedb9aa858176789aff459d426b237ebae5cc4598b06de790938775a7ac968c2d76be3f0efc8ba
diff --git a/x11-wm/xmonad/xmonad-0.15.ebuild b/x11-wm/xmonad/xmonad-0.15.ebuild
new file mode 100644
index 000000000000..a65b517e3950
--- /dev/null
+++ b/x11-wm/xmonad/xmonad-0.15.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.6.9999
+#hackport: flags: -generatemanpage,-testing,-profiling
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="A tiling window manager"
+HOMEPAGE="http://xmonad.org"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="no-autorepeat-keys"
+
+RDEPEND="dev-haskell/data-default:=[profile?]
+ dev-haskell/extensible-exceptions:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ dev-haskell/setlocale:=[profile?]
+ >=dev-haskell/utf8-string-0.3:=[profile?] <dev-haskell/utf8-string-1.1:=[profile?]
+ >=dev-haskell/x11-1.8:=[profile?] <dev-haskell/x11-1.10:=[profile?]
+ >=dev-lang/ghc-8.0.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.24.0.0
+ test? ( >=dev-haskell/quickcheck-2 )
+"
+
+DOCS=( CONFIG README.md CHANGES.md )
+HTML_DOCS=( man/${PN}.1.html )
+
+SAMPLE_CONFIG="${PN}.hs"
+
+src_prepare() {
+ default
+ use no-autorepeat-keys && eapply "${FILESDIR}"/${PN}-0.14-check-repeat.patch
+}
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-generatemanpage \
+ --flag=-profiling \
+ --flag=-testing
+}
+
+src_install() {
+ default
+
+ cabal_src_install
+
+ echo -e "#!/bin/sh\n/usr/bin/${PN}" > "${T}/${PN}"
+ exeinto /etc/X11/Sessions
+ doexe "${T}/${PN}"
+
+ insinto /usr/share/xsessions
+ doins "${FILESDIR}/${PN}.desktop"
+
+ insinto /usr/share/${PF}/ghc-$(ghc-version)/man
+ doins man/${SAMPLE_CONFIG}
+
+ doman man/${PN}.1
+}
+
+pkg_postinst() {
+ haskell-cabal_pkg_postinst
+
+ elog "A sample ${SAMPLE_CONFIG} configuration file can be found here:"
+ elog " /usr/share/${PF}/ghc-$(ghc-version)/man/${SAMPLE_CONFIG}"
+ elog "The parameters in this file are the defaults used by ${PN}."
+ elog "To customize ${PN}, copy this file to:"
+ elog " ~/.${PN}/${SAMPLE_CONFIG}"
+ elog "After editing, use 'mod-q' to dynamically restart ${PN} "
+ elog "(where the 'mod' key defaults to 'Alt')."
+ elog ""
+ elog "Read the README or man page for more information, and to see "
+ elog "other possible configurations go to:"
+ elog " http://haskell.org/haskellwiki/Xmonad/Config_archive"
+ elog "Please note that many of these configurations will require the "
+ elog "x11-wm/xmonad-contrib package to be installed."
+}