summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorVlastimil Krejčíř <vlastimil.krejcir@gmail.com>2022-02-24 22:49:03 +0100
committerJoonas Niilola <juippis@gentoo.org>2022-03-03 12:59:19 +0200
commit3274ca3cb9c734dec4a74c1900376d47338c1ecd (patch)
tree2dbe63c4aea6c147e806ba03f3fa67c619210d61 /x11-wm
parentmedia-fonts/iosevka: add 15.0.1 (diff)
downloadgentoo-3274ca3cb9c734dec4a74c1900376d47338c1ecd.tar.gz
gentoo-3274ca3cb9c734dec4a74c1900376d47338c1ecd.tar.bz2
gentoo-3274ca3cb9c734dec4a74c1900376d47338c1ecd.zip
x11-wm/pekwm: version bump 0.2.1
A new ebuild for pekwm version 0.2.1. Pekwm moved to Cmake since version 0.2.0, so the older ebuilds based on autotools can't be used and this one was created from scratch. Changes: - Themes are handled by pekwm_theme app (requires git) and not need to be installed by ebuild. - Significant change to pekwm menu config (Exec vs. ShellExec and '&' usage) that causes some apps doesn't start (e.g. thunderbird-bin). - Remove contrib USE flag and install contrib scripts unconditionally and post the postinst message unconditionally. Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Vlastimil Krejčíř <vlastimil.krejcir@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/24340 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/pekwm/Manifest1
-rw-r--r--x11-wm/pekwm/pekwm-0.2.1.ebuild88
2 files changed, 89 insertions, 0 deletions
diff --git a/x11-wm/pekwm/Manifest b/x11-wm/pekwm/Manifest
index 3e6d8f6527fd..26578e86af6c 100644
--- a/x11-wm/pekwm/Manifest
+++ b/x11-wm/pekwm/Manifest
@@ -1,3 +1,4 @@
DIST pekwm-0.1.17.tar.gz 429100 BLAKE2B 2b467539ef47f4404411f25146f9f945f9a63b7e4c85c997ed2cd0bf76ea713758e3a09dc9648064c02ab29818399623d12d78394f250c79f8f667a6e057281c SHA512 1950888402f11c5cd72c9d82de976c472d4a0443da206629a039d19a1729660fd7cd09535d35984d554dcdb366918d9e29536b1272521f36f7e54499df0c14af
DIST pekwm-0.1.18.tar.gz 441810 BLAKE2B 8c3e98490681eed68e0f127c38c1653f8d643ceca2ddf8388f6b434d16daeb376fc9337de71786a658e9d9e7a080de922207173edb624b78732bc14da5d42eeb SHA512 31fe291b245b6e13fdfe27878162fd405fd60a766e9a7e762e817391179e7f82c41b664fba568af91e009582729e4633d23f76db95302f6f702cb74c2571db15
+DIST pekwm-0.2.1.tar.gz 943072 BLAKE2B 61a278a42517de4b2924c6e0cffdd0b112c3a1a52b70e24d6ed852a8e5005f76b4eb9a342af073481404fae68265452b140ea19539723733ec860f7cbd615598 SHA512 cefb5abb43f88cff874f12586f0f2c0b88d30fd0ce22c6e18731b11055abea389819a08a4e85a9290021ffe30708ea210c66a0f3f8c263717c05abd798fdf297
DIST pekwm-themes.tar.bz2 138599 BLAKE2B b0c103d7ade6f9bb1ed19b7e12cfcf00fb48be7e1ed141a4b52aee404ebf9c7af5d29af166ff7265a720ca8d122ad7eddb6eaf42a0a8e18b6c1ff3af7b5e12d0 SHA512 c95bc980b5aeeb4f4832cb2dbbf82adf72e4a784fcd46432fd6e6a6577ef02823ec1c4b861d07747c066050fc5040aca975e2cdc78342abab99a3d486888a25d
diff --git a/x11-wm/pekwm/pekwm-0.2.1.ebuild b/x11-wm/pekwm/pekwm-0.2.1.ebuild
new file mode 100644
index 000000000000..8f6cd45e0704
--- /dev/null
+++ b/x11-wm/pekwm/pekwm-0.2.1.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake desktop optfeature
+
+DESCRIPTION="A lightweight window manager initially based on aewm++"
+HOMEPAGE="
+ https://www.pekwm.se/
+ https://github.com/pekdon/pekwm
+"
+SRC_URI="
+ https://github.com/pekdon/${PN}/releases/download/release-${PV}/pekwm-${PV}.tar.gz
+"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~ppc ~x86"
+IUSE="debug +jpeg +png truetype xinerama +xpm"
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXext
+ jpeg? ( virtual/jpeg:0 )
+ png? ( media-libs/libpng:0 )
+ truetype? ( x11-libs/libXft )
+ xinerama? ( x11-libs/libXinerama )
+ xpm? ( x11-libs/libXpm )"
+
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_IMAGE_JPEG=$(usex jpeg)
+ -DENABLE_IMAGE_PNG=$(usex png)
+ -DENABLE_IMAGE_XPM=$(usex xpm)
+ -DENABLE_XINERAMA=$(usex xinerama)
+ -DENABLE_XFT=$(usex truetype)
+ )
+
+ CMAKE_BUILD_TYPE=$(usex debug Debug)
+
+ cmake_src_configure
+}
+
+src_install() {
+
+ cmake_src_install
+
+ # Install contributor scripts into doc folder
+ docinto contrib
+ dodoc "${S}"/contrib/lobo/*.{pl,vars,png} "${S}"/contrib/lobo/README
+
+ # Insert an Xsession
+ exeinto /etc/X11/Sessions
+ newexe - pekwm <<- _EOF_
+ #!/bin/sh
+ /usr/bin/pekwm
+ _EOF_
+
+ # Insert a GDM/KDM xsession file
+ make_session_desktop ${PN} ${PN}
+}
+
+pkg_postinst() {
+
+ elog "Since pekwm 0.2.0 themes can be installed and maintained using "
+ elog "pekwm_theme [install|uninstall|show|search|new|update]."
+ elog "Check https://www.pekwm.se/themes/ for details."
+
+ elog
+
+ optfeature "themes management (pekwm_theme) support" dev-vcs/git
+
+ elog
+
+ elog "User contributed scripts have been installed into:"
+ elog "${EROOT}/usr/share/doc/${PF}/contrib"
+
+ elog "If updated from previous versions remove '&' from the "
+ elog "'Exec ... &' in the menu configuration. Quote: "
+ elog "\"Exec no longer use sh -c to run commands which will cause "
+ elog "incompatabilites depending on /bin/sh configuration, if shell "
+ elog "variables have been used or the command ends with &. ShellExec has "
+ elog "been added implementing the legacy behaviour.\""
+}