summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-05-15 08:40:04 +0200
committerJeroen Roovers <jer@gentoo.org>2020-05-15 08:42:49 +0200
commit20ea5c16ad43b40187e8c5f681658de70fdae3c9 (patch)
treed38b9b947d392276e49236226667796bbdb1cf5e /x11-wm
parentx11-wm/sawfish: Fix building with CFLAGS=-fno-common (diff)
downloadgentoo-20ea5c16ad43b40187e8c5f681658de70fdae3c9.tar.gz
gentoo-20ea5c16ad43b40187e8c5f681658de70fdae3c9.tar.bz2
gentoo-20ea5c16ad43b40187e8c5f681658de70fdae3c9.zip
x11-wm/sawfish: Version 1.12.90
- Uncompress man pages - Update icon cache Package-Manager: Portage-2.3.99, Repoman-2.3.22 Closes: https://bugs.gentoo.org/show_bug.cgi?id=706354 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/sawfish/Manifest1
-rw-r--r--x11-wm/sawfish/sawfish-1.12.90.ebuild99
2 files changed, 100 insertions, 0 deletions
diff --git a/x11-wm/sawfish/Manifest b/x11-wm/sawfish/Manifest
index 2738e3a67fee..d914db967aff 100644
--- a/x11-wm/sawfish/Manifest
+++ b/x11-wm/sawfish/Manifest
@@ -1 +1,2 @@
DIST sawfish_1.12.0.tar.xz 2814340 BLAKE2B 58901cf62d10641ef32756a3283c6d53b27a68a4af7c578c49e6968045f5993f744eb0b6c7b81da08b91774f1fb8faec467a6a22cd046a2fea135f749ac24319 SHA512 e8f831a9f6206ccf4e2a823bc3464c11b9d2d38a72ada4a142f952813a56c620b511f9cd8912bbf06e38976e54f1d9445f68d6dd24ee5ed59918c18de379e71f
+DIST sawfish_1.12.90.tar.xz 2602372 BLAKE2B 180d3ed1081fffa0fe6c60c15b96a4b530be1349e162d0b6e7553e753e0462aea89caf7bfe379b1993f883e544e27bb553d259d0348fcceb53619dc54536cc47 SHA512 444cdc21b368d9ffb89e1ccd0377d9ce9d9b42f9bd93aa85ca29763781f90cb393a0c9c8da47ff0a161bf5e3881e6d6895a7c5749761ccc7b4b5a1ed8438c93d
diff --git a/x11-wm/sawfish/sawfish-1.12.90.ebuild b/x11-wm/sawfish/sawfish-1.12.90.ebuild
new file mode 100644
index 000000000000..62df528557df
--- /dev/null
+++ b/x11-wm/sawfish/sawfish-1.12.90.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_P="${P/-/_}"
+inherit autotools elisp-common eutils xdg-utils
+
+DESCRIPTION="Extensible window manager using a Lisp-based scripting language"
+HOMEPAGE="https://sawfish.fandom.com/wiki/Main_Page"
+SRC_URI="https://download.tuxfamily.org/sawfish/${MY_P}.tar.xz"
+
+LICENSE="GPL-2 Artistic-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="emacs kde nls xinerama"
+
+RDEPEND="
+ emacs? ( >=app-editors/emacs-23.1:* )
+ >=dev-libs/librep-0.92.1
+ >=x11-libs/rep-gtk-0.90.7
+ x11-libs/gdk-pixbuf:2[X]
+ >=x11-libs/gtk+-2.24.0:2
+ x11-libs/libXtst
+ kde? ( kde-frameworks/kdelibs4support )
+ nls? ( sys-devel/gettext )
+ xinerama? ( x11-libs/libXinerama )
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+S="${WORKDIR}/${MY_P}"
+PATCHES=(
+ # From Fedora
+ "${FILESDIR}"/${PN}-1.12.0-desktop.patch
+ "${FILESDIR}"/${PN}-1.12.0-fno-common.patch
+)
+DOCS=(
+ AUTHORS ChangeLog CONTRIBUTING doc/AUTOSTART doc/KEYBINDINGS doc/OPTIONS
+ doc/XSettings MAINTAINERS NEWS README README.IMPORTANT TODO
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ set -- \
+ $(use_with kde kde5session) \
+ $(use_with xinerama) \
+ --with-gdk-pixbuf \
+ --without-kde4session \
+ --disable-static
+
+ if ! use nls; then
+ # Use a space because configure script reads --enable-linguas=""
+ # as "install everything". Don't use --disable-linguas, because
+ # that means --enable-linguas="no", which means "install
+ # Norwegian translations".
+ set -- "$@" --enable-linguas=" "
+ elif [[ "${LINGUAS+set}" == "set" ]]; then
+ strip-linguas -i po
+ set -- "$@" --enable-linguas=" ${LINGUAS} "
+ else
+ set -- "$@" --enable-linguas=""
+ fi
+
+ econf "$@"
+}
+
+src_compile() {
+ default
+ use emacs && elisp-compile sawfish.el
+}
+
+src_install() {
+ default
+
+ find "${D}" -name '*.la' -delete || die
+
+ find "${D}/usr/share/man" -name '*.gz' -exec gunzip {} \; || die
+
+ if use emacs; then
+ elisp-install ${PN} sawfish.{el,elc}
+ elisp-site-file-install "${FILESDIR}"/50${PN}-gentoo.el
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+ xdg_icon_cache_update
+}