summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJosé María Alonso Josa <nimiux@gentoo.org>2016-06-16 12:54:03 +0200
committerJosé María Alonso Josa <nimiux@gentoo.org>2016-06-16 12:54:20 +0200
commit181643a222b641720d2f34c08482d33d548d09b3 (patch)
tree8043929579679b81f310f02e4c419c99e4825618 /x11-wm/stumpwm
parentsys-libs/libunwind: Stable for HPPA (bug #585830). (diff)
downloadgentoo-181643a222b641720d2f34c08482d33d548d09b3.tar.gz
gentoo-181643a222b641720d2f34c08482d33d548d09b3.tar.bz2
gentoo-181643a222b641720d2f34c08482d33d548d09b3.zip
x11-wm/stumpwm: Reset xdg environment
Fixes bug #585852 Package-Manager: portage-2.2.28
Diffstat (limited to 'x11-wm/stumpwm')
-rw-r--r--x11-wm/stumpwm/stumpwm-0.9.9.ebuild3
-rw-r--r--x11-wm/stumpwm/stumpwm-9999.ebuild6
2 files changed, 7 insertions, 2 deletions
diff --git a/x11-wm/stumpwm/stumpwm-0.9.9.ebuild b/x11-wm/stumpwm/stumpwm-0.9.9.ebuild
index ef3ef84dbb2c..3400b1298dfa 100644
--- a/x11-wm/stumpwm/stumpwm-0.9.9.ebuild
+++ b/x11-wm/stumpwm/stumpwm-0.9.9.ebuild
@@ -4,7 +4,7 @@
EAPI=5
-inherit common-lisp-3 eutils elisp-common autotools
+inherit autotools common-lisp-3 eutils elisp-common xdg-utils
DESCRIPTION="Stumpwm is a Window Manager written entirely in Common Lisp."
HOMEPAGE="https://stumpwm.github.io/"
@@ -72,6 +72,7 @@ src_prepare() {
src_configure() {
local moduleconfig
+ xdg_environment_reset
use contrib && moduleconfig="--with-module-dir=${CONTRIBDIR}/contrib"
econf --with-lisp=$(get_lisp sbcl clisp ecl) "${moduleconfig}"
}
diff --git a/x11-wm/stumpwm/stumpwm-9999.ebuild b/x11-wm/stumpwm/stumpwm-9999.ebuild
index a76acd4bb6a3..0775f884a990 100644
--- a/x11-wm/stumpwm/stumpwm-9999.ebuild
+++ b/x11-wm/stumpwm/stumpwm-9999.ebuild
@@ -4,7 +4,7 @@
EAPI=5
-inherit autotools common-lisp-3 git-2
+inherit autotools common-lisp-3 git-2 xdg-utils
DESCRIPTION="Stumpwm is a Window Manager written entirely in Common Lisp."
HOMEPAGE="https://stumpwm.github.io/"
@@ -38,6 +38,10 @@ src_prepare() {
eautoreconf
}
+src_configure() {
+ xdg_environment_reset
+}
+
src_compile() {
emake -j1
}