summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJake Lilly <lillyjsm@gmail.com>2021-03-23 04:10:19 -0400
committerJoonas Niilola <juippis@gentoo.org>2021-03-26 11:23:10 +0200
commitb5c89a2d0eea024513fed664c0627fd19d78079e (patch)
treeb6016f31f88f0d5f8e6b5fdc2d6c956da857572e /x11-wm/ctwm
parentdev-perl/PDL: improve deps (diff)
downloadgentoo-b5c89a2d0eea024513fed664c0627fd19d78079e.tar.gz
gentoo-b5c89a2d0eea024513fed664c0627fd19d78079e.tar.bz2
gentoo-b5c89a2d0eea024513fed664c0627fd19d78079e.zip
x11-wm/ctwm: adopt and fix
Bug: https://bugs.gentoo.org/715904 Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Jake Lilly <lillyjsm@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/20074 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'x11-wm/ctwm')
-rw-r--r--x11-wm/ctwm/ctwm-4.0.3.ebuild33
-rw-r--r--x11-wm/ctwm/metadata.xml19
2 files changed, 44 insertions, 8 deletions
diff --git a/x11-wm/ctwm/ctwm-4.0.3.ebuild b/x11-wm/ctwm/ctwm-4.0.3.ebuild
index 4cf2574b36c4..7c24c6682a8f 100644
--- a/x11-wm/ctwm/ctwm-4.0.3.ebuild
+++ b/x11-wm/ctwm/ctwm-4.0.3.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit cmake
+
+inherit cmake flag-o-matic virtualx
DESCRIPTION="A clean, light window manager"
HOMEPAGE="https://ctwm.org/"
@@ -11,6 +12,8 @@ SRC_URI="https://ctwm.org/dist/${P}.tar.xz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="jpeg rplay test xpm"
+RESTRICT="!test? ( test )"
RDEPEND="
x11-libs/libICE
@@ -18,18 +21,21 @@ RDEPEND="
x11-libs/libX11
x11-libs/libXext
x11-libs/libXmu
- x11-libs/libXpm
x11-libs/libXt
+ jpeg? ( virtual/jpeg )
+ rplay? ( media-sound/rplay )
+ xpm? ( x11-libs/libXpm )
"
DEPEND="
${RDEPEND}
app-arch/xz-utils
- app-text/rman
- virtual/jpeg
x11-base/xorg-proto
"
src_prepare() {
+ # Bug 715904, sigjmp_buf is guarded by GNU_SOURCE
+ use elibc_musl && append-cflags -D_GNU_SOURCE
+
cmake_src_prepare
# implicit 'isspace'
@@ -37,10 +43,23 @@ src_prepare() {
}
src_configure() {
- mycmakeargs=(
+ local mycmakeargs=(
-DNOMANCOMPRESS=yes
- -DDOCDIR=/usr/share/doc/${PF}
+ -DDOCDIR="${EPREFIX}"/usr/share/doc/${PF}
+ -DUSE_JPEG=$(usex jpeg ON OFF)
+ -DUSE_RPLAY=$(usex rplay ON OFF)
+ -DUSE_XPM=$(usex xpm ON OFF)
)
cmake_src_configure
}
+
+src_compile() {
+ # Bug 701656, test_bins target needs to be compiled
+ # to satisfy the 't_efp' test
+ cmake_src_compile all $(usex test test_bins '')
+}
+
+src_test() {
+ virtx cmake_src_test
+}
diff --git a/x11-wm/ctwm/metadata.xml b/x11-wm/ctwm/metadata.xml
index 6f49eba8f496..ef70fcb22252 100644
--- a/x11-wm/ctwm/metadata.xml
+++ b/x11-wm/ctwm/metadata.xml
@@ -1,5 +1,22 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<!-- maintainer-needed -->
+ <maintainer type="person" proxied="yes">
+ <email>lillyjsm@gmail.com</email>
+ <name>Jake Lilly</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <changelog>http://www.ctwm.org/CHANGES.html</changelog>
+ <doc>http://www.ctwm.org/docs.html</doc>
+ </upstream>
+ <use>
+ <flag name="jpeg">Enable jpeg image support with <pkg>virtual/jpeg</pkg></flag>
+ <flag name="rplay">Enable sound support from <pkg>media-sound/rplay</pkg></flag>
+ <flag name="test">Enable upstream test suite, build required binary</flag>
+ <flag name="xpm">Enable xpm icon support with <pkg>x11-libs/libXpm</pkg></flag>
+ </use>
</pkgmetadata>