summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFrancesco Turco <fturco@fastmail.fm>2017-11-16 17:00:45 +0100
committerPatrice Clement <monsieurp@gentoo.org>2018-01-26 22:48:02 +0100
commit59089e88c33ec150a3d1abd93d5fcea2d975d556 (patch)
treec9d6da2bb4ad327e37d00bebe29cb3bfa68ad50d /x11-themes
parentnet-misc/electrum: add python3_6 support. (diff)
downloadgentoo-59089e88c33ec150a3d1abd93d5fcea2d975d556.tar.gz
gentoo-59089e88c33ec150a3d1abd93d5fcea2d975d556.tar.bz2
gentoo-59089e88c33ec150a3d1abd93d5fcea2d975d556.zip
x11-themes/silver-xcursors: use readme.gentoo-r1.eclass and EAPI 6 bump.
Closes: https://bugs.gentoo.org/637686 Closes: https://github.com/gentoo/gentoo/pull/6205
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/silver-xcursors/silver-xcursors-0.4-r1.ebuild4
-rw-r--r--x11-themes/silver-xcursors/silver-xcursors-0.4.ebuild56
2 files changed, 36 insertions, 24 deletions
diff --git a/x11-themes/silver-xcursors/silver-xcursors-0.4-r1.ebuild b/x11-themes/silver-xcursors/silver-xcursors-0.4-r1.ebuild
index 2ccc6d42f3ca..992984f80adc 100644
--- a/x11-themes/silver-xcursors/silver-xcursors-0.4-r1.ebuild
+++ b/x11-themes/silver-xcursors/silver-xcursors-0.4-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -12,7 +12,7 @@ LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~sparc ~x86 ~x86-fbsd"
-S=${WORKDIR}/${MY_P:5}
+S="${WORKDIR}/${MY_P:5}"
src_install() {
dodir /usr/share/cursors/xorg-x11/Silver/cursors/
diff --git a/x11-themes/silver-xcursors/silver-xcursors-0.4.ebuild b/x11-themes/silver-xcursors/silver-xcursors-0.4.ebuild
index 05b59f73bb3d..b01150131ce7 100644
--- a/x11-themes/silver-xcursors/silver-xcursors-0.4.ebuild
+++ b/x11-themes/silver-xcursors/silver-xcursors-0.4.ebuild
@@ -1,6 +1,10 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
+EAPI=6
+
+inherit readme.gentoo-r1
+
MY_P="5533-Silver-XCursors-3D-${PV}"
DESCRIPTION="A high quality set of Xfree 4.3.0 animated mouse cursors"
HOMEPAGE="http://www.kde-look.org/content/show.php?content=5533"
@@ -14,31 +18,39 @@ IUSE=""
RDEPEND=""
DEPEND="${RDEPEND}"
+S="${WORKDIR}/${MY_P:5}"
+
+DOC_CONTENTS="To use this set of cursors, edit or create the file ~/.Xdefaults
+and add the following line:
+Xcursor.theme: Silver
+
+You can change the size by adding a line like:
+Xcursor.size: 48
+
+Also, to globally use this set of mouse cursors edit the file:
+ /usr/share/cursors/xorg-x11/default/index.theme
+and change the line:
+ Inherits=[current setting]
+to
+ Inherits=Silver
+
+Note this will be overruled by a user's ~/.Xdefaults file."
+
src_install() {
- dodir /usr/share/cursors/xorg-x11/Silver/cursors/
- cp -R "${WORKDIR}"/${MY_P:5}/Silver/cursors "${D}"/usr/share/cursors/xorg-x11/Silver/ || die
- dodoc "${WORKDIR}"/${MY_P:5}/README
+ insinto /usr/share/cursors/xorg-x11/Silver
+ doins -r Silver/cursors
+ einstalldocs
+
+ DISABLE_AUTOFORMATTING="yes"
+ readme.gentoo_create_doc
}
pkg_postinst() {
- einfo "To use this set of cursors, edit or create the file ~/.Xdefaults"
- einfo "and add the following line:"
- einfo "Xcursor.theme: Silver"
- einfo ""
- einfo "You can change the size by adding a line like:"
- einfo "Xcursor.size: 48"
- einfo ""
- einfo "Also, to globally use this set of mouse cursors edit the file:"
- einfo " /usr/share/cursors/xorg-x11/default/index.theme"
- einfo "and change the line:"
- einfo " Inherits=[current setting]"
- einfo "to"
- einfo " Inherits=Silver"
- einfo ""
- einfo "Note this will be overruled by a user's ~/.Xdefaults file."
- einfo ""
+ DISABLE_AUTOFORMATTING="yes"
+ readme.gentoo_print_elog
+
ewarn "If you experience flickering, try setting the following line in"
- ewarn ""
ewarn "the Device section of your xorg.conf file:"
- ewarn " Option \"HWCursor\" \"false\""
+ ewarn " Option \"HWCursor\" \"false\""
+
}