summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRonny (tastytea) Gutbrod <gentoo@tastytea.de>2022-06-03 16:55:56 +0200
committerJoonas Niilola <juippis@gentoo.org>2022-06-12 10:27:02 +0300
commit43bc5e50f8cc9737891ec600ec8bb602d5e03e53 (patch)
treeac333d52eb94ea6f90494fa82f4c17e7751c6cab /x11-themes
parentmail-filter/rspamd: remove dev-cpp/doctest version restriction (diff)
downloadgentoo-43bc5e50f8cc9737891ec600ec8bb602d5e03e53.tar.gz
gentoo-43bc5e50f8cc9737891ec600ec8bb602d5e03e53.tar.bz2
gentoo-43bc5e50f8cc9737891ec600ec8bb602d5e03e53.zip
x11-themes/gentoo-xcursors: fix install location, update EAPI 7 -> 8
Switch to default install location¹, because the Gentoo-specific path is problematic². Symlinks are added at old location for backwards compatibility. ¹ <https://www.x.org/releases/X11R7.7/doc/man/man3/Xcursor.3.xhtml> ² <https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=3a95901> Closes: https://bugs.gentoo.org/848606 Signed-off-by: Ronny (tastytea) Gutbrod <gentoo@tastytea.de> Closes: https://github.com/gentoo/gentoo/pull/25740 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/gentoo-xcursors/gentoo-xcursors-0.3.2-r2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/x11-themes/gentoo-xcursors/gentoo-xcursors-0.3.2-r2.ebuild b/x11-themes/gentoo-xcursors/gentoo-xcursors-0.3.2-r2.ebuild
new file mode 100644
index 000000000000..170c5bdcc09c
--- /dev/null
+++ b/x11-themes/gentoo-xcursors/gentoo-xcursors-0.3.2-r2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="A high quality set of animated mouse cursors"
+HOMEPAGE="https://schlomp.space/tastytea/gentoo-xcursors"
+SRC_URI="https://schlomp.space/tastytea/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+src_install() {
+ insinto /usr/share/icons
+ doins -r cursors/*
+
+ # Add symlinks in Gentoo-specific location for backwards compatibility
+ mkdir -p ${ED}/usr/share/cursors/xorg-x11 || die
+ cd ${ED}/usr/share/cursors/xorg-x11 || die
+ for cursorset in ../../icons/*; do
+ dosym ${cursorset} /usr/share/cursors/xorg-x11/${cursorset##*/}
+ done
+}
+
+pkg_postinst() {
+ einfo "To use this set of cursors, consult <https://wiki.gentoo.org/wiki/Cursor_themes>."
+ einfo "The three sets installed are gentoo, gentoo-silver and gentoo-blue."
+}